LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 04-17-2004, 02:11 AM   #1
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
Unhappy Mandy 10.0 Now here's another funny thing!


OK,
Followed the threads for the knotify problem, and the choose external->artsplay works for me to. So I go into control centre and choose notifications for say kde events. I choose an event, it could be anything, and enable the play sound box. Then I browse for a sound, which by default opens /usr/share/sounds, with the filter set to show all supported files. But, the directory viewer only shows other sub directories, and files ending with the .ogg extension. If I set the filter to show WAV Audio, it displays no files, even though all of the sound event files are in this directory, and are .wav files. Does this mean that .wav files aren't supported, or is this another Mandy feature!!
Also, and I don't know if this is connected, or whether to start another thread, in my previous incarnation of Mandy 9.0/9.2, when I browsed my PC using konqueror, and I simply hovered my mouse over an audio file, be it .wav, .ogg, .mp3 etc, then the file would just play. Now I have to click on it and choose which application to use. Again, is this something new. If it is, then it seems to be a retrograde step IMHO. If this facility is still available, can anyone tell me how?, or has KDE lost the ability to do this as part of it's evolution.
 
Old 04-17-2004, 02:46 AM   #2
dredgemortle
Member
 
Registered: Feb 2004
Location: Fort Worth, TX
Distribution: Kubuntu 8.04
Posts: 33

Rep: Reputation: 15
Easy answer for your second question:
go to view-preview-and check sound files in Konqueror. That should make the hover over sound work.
The reason it's off by default this time around IMO is that it can turn on at inopportune moments like when you click a movie to watch and the pointer falls on a sound file after so that you've got two audios mixing together.
 
Old 04-17-2004, 03:05 AM   #3
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Half way there then

OK, So far that has sort of worked. Now when I hover over .ogg and .mp3 files, they play automatically as I have been used to. Still does nothing though with .wav files. Do you have any more suggestions.

TIA
 
Old 04-17-2004, 05:14 AM   #4
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
Konqueror bug? Mandy 10 is out, with loads of bug fixes...
 
Old 04-17-2004, 05:15 AM   #5
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
By the way, I don't experience that prob.
 
Old 04-17-2004, 12:03 PM   #6
dredgemortle
Member
 
Registered: Feb 2004
Location: Fort Worth, TX
Distribution: Kubuntu 8.04
Posts: 33

Rep: Reputation: 15
Here's a thread re .wav problems that may help:

http://www.linuxquestions.org/questi...highlight=.wav
 
Old 04-17-2004, 01:50 PM   #7
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Tried that thread but no luck. Here is something else that may be connected. If I browse to a .wav file and then right click and look at the properties, then they are as follows:-

shutdown1.wav located in /usr/share/sounds

Type audio/x-pn-windows-pcm
Contents WAV Audio

Why is this not of type audio/wav?

This just gets stranger all the time.
All the .wav files on my PC that I have checked all show the same. Is this a bug perhaps?

Last edited by vdemuth; 04-17-2004 at 01:51 PM.
 
Old 04-17-2004, 04:00 PM   #8
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
No, that's just the mime-type.
 
Old 04-18-2004, 02:20 AM   #9
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
OK, Have checked out and read up on mime types, and now I'm even more confused. When I look at my file associations, using .wav as a filter, I have several different mime types using that extension.
i.e. audio/wav, audio/x-wav, audio/x-pn-windows-pcm/asm etc. I have tried all sorts to get any audio from .wav files including setting all/none of the above to a combination of:- use embedded player, use external player and use settings for group audio. What do you suggest I try next?
 
Old 04-18-2004, 04:42 AM   #10
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
You can't get knotify to play them or you can't get any program at all to play them?
 
Old 04-18-2004, 06:06 AM   #11
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Hello again,
I can't get any programme to play .wav files, but here is some more info for you.
If I log in as root, then everything works fine. As user running konqueror as root, no .wav files will play with any app. As root, the mime type for the .wav files on the system is audio/wav. As user the mime type for .wav files is audio/x-pn-windows-pcm. So, can I make the mime types under user the same as under root?, as this may well fix my problem.
 
Old 04-18-2004, 04:10 PM   #12
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
Let me think..... In the mean time you can try opening them in a different desktop environment.
 
Old 04-18-2004, 05:46 PM   #13
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
<See next post first>

Hmmm, Okay I did some investigating. Before you continue maybe you should try making another user and see if you have the same problem, not that it's dangerous or anything, it'll just save you some hassle.
Okay, I did a search for the word mime and found some config files:
Relevant ones being:
/usr/share/mimelnk/
/etc/mime-magic
/usr/share/misc/magic.mime
/usr/share/misc/file/magic.mime
There's probably some that I missed though.
Anyway, I compare the wav entries of /etc/mime-magic and /usr/share/misc/magic.mime, they both have the same entry for wav:
0 string RIFF audio/x-wav

The entry for wav in /etc/mime.types is: audio/x-wav wav
and the entry in /usr/share/misc/file/magic.mime is:
>8 string WAVE audio/x-wav

Right, that's the troubleshooting I've done. Maybe you can try some more.
One more thing, was this a new install of Mandrake? Something is definitely broken here, coz I don't know much about mimetypes, so I can't really suggest anything useful.

Last edited by beejayzed; 04-18-2004 at 06:31 PM.
 
Old 04-18-2004, 06:33 PM   #14
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
I found these in my search results:
/usr/bin/restorekdemimetypes.pl
/usr/bin/savekdemimetypes.pl

That might just work.
 
Old 04-19-2004, 01:25 AM   #15
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Original Poster
Rep: Reputation: 98
Hello again,
It turns out that this is a bug in Mandy 10.0 According to the developers of KDE, there is no mime type audio/x-pn-windows-pcm recognised or incorporated into it. I have safely renamed that offending mime type with no adverse effects, and my system is now responding as I would expect it to do.
Thank you very much for your help, it has been a worthwhile learning experience.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Funny thing happened on the way...... Rick069 Mandriva 5 11-01-2005 12:39 AM
Funny little thing... Mathiasdm General 2 01-15-2005 05:34 AM
Funny flash thing... Mega Man X General 2 05-07-2004 05:02 PM
VERY VERY funny thing @ mandrake site TigerCardeo Mandriva 1 04-17-2004 12:15 AM
Funny "thing" on wine PortOS Linux - Software 0 12-10-2002 10:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration