-   Mandriva (
-   -   Mandriva 2010 cannot boot after installation on Raid 1 (

zhuqing8027 11-14-2009 11:07 PM

Mandriva 2010 cannot boot after installation on Raid 1
I tried to install Mandriva 2010 on a raid 1 device. I built up a 20G raid 1 during the installation process and mount it as /, a 4G raid device for swap, and the installation finished without issue. But I cannot go into the system after reboot, it always says 'cannot find /dev/md0' during startup. I don't know what I did wrong. Can anybody help me with this? Thank you.

ongte 11-16-2009 07:38 AM

If I remember correctly, the kernels & bootloader cannot reside in an md array. You need to create a seperate /boot partition that is not inside the raid array. About 100MB should be enough.

ernie 11-16-2009 04:01 PM

IIRC a /boot partition can be as small as 25 MB, but 100 is not too large, depending on if you remove older kernel versions after installing and testing updated kernels

zhuqing8027 11-17-2009 01:54 PM

Problem solved. I have five drives on a controller card. I had to unplug all the drives on the controller card to install the system on raid-1 successfully, then replug the drives again. Otherwise, the fstab file will be messed up, so the system cannot find the raid-1 array after reboot.

All times are GMT -5. The time now is 11:42 AM.