LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 01-29-2008, 06:19 PM   #1
Newy
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Rep: Reputation: 0
Mandriva 2008 internet says connected, but not


I've recently installed Mandriva 2008 to give it a go. Works fine, except when I configure the internet it doesn't work.

I have a dual-boot setup, windows NTDLR loads the linux bootloader and mandriva starts. Both installations are on seperate HDD's and getting to Mandriva is fine. The problem I have is that when I manually setup my network device (onboard Realtek) I get two ethernet device choices, Realtek and an Eth0:9, the latter I'm not sure what that is. I don't have DHCP configured on my router so I entered everything manually (same as my windows installation which works, as I'm typing on it now) and it says it connects, but when I try to browse to a web-page it just sits "looking up...", I can't ping my router or any other machines on my network. ifconfig shows two ethernet devices eth0 and lo, eth0 shows the IP and subnet etc that I've entered says its up, just I can't get to the internet.

Any help that you guys could give would be appreciated
 
Old 01-29-2008, 06:45 PM   #2
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Is your computer connected to a router? If so you can set up a static IP address because the LAN is yours. If your computer connects directly to a DSL or Cable modem, you must configure your system to use DHCP to get an IP address dynamically.

In your static configuration did you make sure the gateway IP address is correct (must be the LAN IP address of your router)? Did you confirm your DNS server IP address(es) to be correct? Is this computer the only one on the LAN with this IP address?

These are a few very simple things to check.

HTH,

Last edited by ernie; 01-29-2008 at 06:46 PM.
 
Old 01-29-2008, 08:38 PM   #3
Newy
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Yes, unfortunately I do connect to a router and my DNS settings are correct, and this is the only machine on the network with that IP, as a note it did manage to work ONCE when I was using the live CD, but I've tried those settings again and they haven't worked. I guess I'll try some other configurations tommarow.
 
Old 01-30-2008, 02:57 AM   #4
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Since the LAN settings are correct, see if you can connect to the router's IP address (same as the gateway IP) using a WEB browser. If you get the router's configuration / status page, the computer is connected to the router. Check the router's WAN settings. If this is a DSL connection, the router should obtain it's an IP automatically using DHCP, and the router may need PPPoE set up and a log in. If this is a cable connection, the router should obtain an IP automatically using DHCP.

If the router's settings are correct, see if you can access the modem's IP address using a WEB browser. Many cable modems use a LAN IP of 192.168.100.1 and perhaps DSL modems do as well although I have never used DSL here. If you are unable to get the modem's page, with the computer shut down reset the modem, then the router. Unplug the modem from the electric power supply. If the modem has a battery (also provides phone service), remove the battery for a complete power down. Put the battery back in (if so equipped) and plug in the modem. After the modem lamps indicate connection is obtained, power down the router. Power up the router. Start the computer. This procedure has worked for me.

HTH,
 
Old 01-30-2008, 07:34 AM   #5
Richie55
Member
 
Registered: Nov 2004
Location: UK
Distribution: Mandriva 2010.1
Posts: 128

Rep: Reputation: 15
Hi,
I recently updated my adsl routers firmware, after setting up my dns user name password etc, my windows machine worked fine, but Linux connected to everything but web pages and ping. (ftp, skype, amsn, etc. all fine). I was very puzzled for ages.

It turned out the modulation type (set in the router was incorrect). I'm not sure why windows worked but Linux didn't, but correcting it made everything work fine.

Not sure if this is the same problem you have, but it does sound a bit like it so I thought I'd suggest it. You will have to check with your isp for the correct setting.

Hope it helps.
 
Old 01-30-2008, 08:30 PM   #6
Newy
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Hm... Thank you for those suggestions, there's one more question I have,
when I type ifconfig, I get 3 interfaces that are "up".

eth0
eth0:9
lo

first is eth0 it has no ip or subnet mask but has the mac address and stats about packets and whatnot, then I have another device eth0:9 this has the ip and the subnet mask and the same mac as eth0, is there some way I can maybe uninstall drivers for my onboard lan and re-install it to see if it will only show up as one interface (final interface is lo) because I'm thinking this might be the problem.
 
Old 01-30-2008, 11:49 PM   #7
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
lo is the loop back device. You need it. Best to leave it alone.

To manage your network connection(s) in a GUI interface, open MCC (in the menu system: Tools > System Tools > Configure Your Computer)

Select Network & Internet in the navigation bar (left).

To set up a new connection:
Open the Set up a new Network interface (LAN, ISDN, ADSL, ...) icon (main pane)
Follow the prompts to set up your Network connection.

To re-configure or disconnect an existing connection (we will disconnect eth0:9 and re-configure eth0):
Open the Network Center icon (main pane)
Expand the eth0:9 entry (click the right arrow - left)
Click the Disconnect button (right)
Expand the eth0 entry (click the right arrow - left)
Click the Configure button (left-center)
Complete the eth0 configuration dialog, then click the OK button (bottom-left).

HTH,
 
Old 02-02-2008, 07:03 PM   #8
Newy
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Actually, I think there's another problem, the Ethernet light on my onboard NIC card isn't lit up at all. disabling the eth0:9 and reconfiguring eth0 still didn't do anything. I guess I'll try another distribution and see if I get better results
 
Old 02-02-2008, 08:01 PM   #9
Newy
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Ok, for whatever reason Mandriva didn't like my onboard NIC, so I got a really old 3Comm and it's fine, worked perfect using the same settings >.>, but thanks for your guys help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: DistroWatch Weekly: First Look at Mandriva Flash 2008, Gentoo Linux 2008.0 sche LXer Syndicated Linux News 0 01-28-2008 05:30 AM
Mandriva 2008 + internet antoniog Mandriva 28 01-11-2008 08:26 AM
LXer: The Perfect Desktop - Mandriva 2008 Free (Mandriva 2008.0) LXer Syndicated Linux News 0 10-16-2007 07:20 PM
LXer: The Perfect Server - Mandriva 2008 Free (Mandriva 2008.0) LXer Syndicated Linux News 0 10-11-2007 09:41 PM
Sending FAX while connected to the Internet through Mandriva Kristoffer G Linux - Software 1 04-26-2007 08:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 12:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration