-   Mandriva (
-   -   Mandriva 2006 fails install with "set_loop failed on /dev/loop0" (

iguest 05-03-2006 01:22 PM

Mandriva 2006 fails install with "set_loop failed on /dev/loop0"

Does anyone know what is causing this "set_loop failed on /dev/loop0 (Out of memory)" error?

I'm trying to install the 2006.0 free release. I've downloaded the 3 CD iso's, and tried the following with the same results:

Burned a boot.iso - Boot the machine from CD and try to install iso's from hdd (NTFS partition) - I get the above error as soon as I get finnished specifing the location of the iso's.

I've tried the above, but this this time using an ext3 partition to hold the iso's - Same error message.

I've tried setting up a local media distribution mirror on a local server and install via FTP. After setting up the network paramters, and pointing to the local server the install starts and then bang - The exact same error message.

I've downloaded the iso images a 2nd time, just to be sure, but I get the same result.

NOTES: Machine is a Dell - 3 GHz Proc, 1 Gig Ram, 120Gig SCSI disk - No IDE disks in the machine.

Any ideas?

Regards Iestyn

indienick 05-03-2006 03:32 PM

hey lestyn,

I believe /dev/loop0 is your loopback interface...

Have you partitioned your drive to allow for the mandriva install?
I personally don't trust the option that allows the installer to pre-partition your drive for you.

The only reason that I can think of that would give you an out of memory error (at this point in time of operation) is if Mandriva's trying to install to a drive partition that's too small for the OS and the package list you've selected.

If the hard drive is fresh as a daisy and has never before seen an OS, then I have no idea...

Emmanuel_uk 05-05-2006 02:48 AM

>>Boot the machine from CD and try to install iso's from hdd
Did you try to install from a cd-drive direct (from burnt isos on cd)

What is the hdd controller model?

iguest 05-07-2006 06:19 AM

Hi All,

Thanks for the help. I haven't been able to move forward much on this machine. Here is some more info:

The drive is currently partitioned. NTFS on the first 90 Gig or so. Then the rest of the drive is Native Linux ext3 and Linux swap. (~25 Gig ext3, and 1 Gig swap)

I used Partition Magic to shrink the NTFS partition down, so as to make room for linux. The machine is company owned, and is my bread-n-butter machine, so I need to have XP up and running with all the company software on it. All the partitioning for both linux and NTFS has worked fine. I just can't get by that damn loop back problem.

Anyhow, I'll have to wait until I go to work before I can get the specs on the controller. I think it's the 53C1030 dual channel Ultra320, but I'm not 100% sure.

So I haven't tried burning all the isos to CD to do the install. The CD rom drive in the machine is a bit fussy on the media. If the CD is not the right color, the drive won't work. I considered myself lucky to burn the boot iso.

I'm curious, is /dev/loop in ram or on disk during the point of initial install?

Regards, Iestyn

Emmanuel_uk 05-07-2006 12:08 PM

just one thing, if this is your bread and butter, follow advanced instructions whenever possible,
do choose to install the bootloader in the linux partition, NOT the MBR,
unless you have done a dual boot before with XP,
I would not suggest you write onto the MBR.

indienick 05-07-2006 01:16 PM

iguest, I'm almost certain it uses your RAM for the loopback.

Complementing what Emmanuel_uk said, whatever you do, DO NOT INSTALL THE LINUX BOOT LOADER TO THE MBR (Master Boot Record). Install the Linux Boot Loader to the linux partition. If you can get to the point in the install where you can choose your boot loader, run with GRUB. I have this handy-dandy little manual (which I can't remember where I got it from) and it outlines how to dual boot Windows with Linux.

If you can get far enough into the install to choose the boot loader (which is at the end of the installation), I'll put up the instructions on how to do it here in this thread. =) (I've used this manual before, and I've never had a problem with it)

All times are GMT -5. The time now is 12:54 PM.