LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 02-19-2006, 09:21 AM   #1
cootetom
Member
 
Registered: May 2004
Location: UK
Distribution: Ubuntu
Posts: 96

Rep: Reputation: 15
Mandriva 2006 Failing to start


Hey all, i installed Mandriva 2006 today. I used Lilo as my boot loader. Installation went well with no problems at all, however when i choose mandriva from lilo the boot sequence starts but gets stuck early on. Here is where it is getting stuck.

Quote:
Vendor : ATA Model: WDC WD1600JD-75H Rev : 08.0
Type : Direct Access ANSI SCSI revision : 05
ata2 : SATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xFFA8 irq 15
ata2 : dev 0 ATAPI, max UDMA/33
ata2 : dev 1 ATAPI, max UDMA/33
It stops there and goes no further. Have tried booting in safe mode etc but the same thing always happens. Maybe I should try the install process again but seeing as I had no problems the first time i can't see how it might be different a second time.

Any info would be appreciated.
 
Old 02-19-2006, 09:41 AM   #2
Vampirite
Member
 
Registered: Apr 2005
Location: England
Distribution: Arch Linux
Posts: 223

Rep: Reputation: 30
Dodgy problem...

You could also pass some options to the kernel, I suggest reading up on something, I think when you boot the Mandriva Install CD it gives you a few options to try.

It could be a framebuffer problem, what bootloader are you using?

Does the Kernel have full support for your system? You might have to recompile one for your system...a last resort I think.

It could be many problems, try the ones above first.

Hope that helps!

--
Kourosh
 
Old 02-19-2006, 10:04 AM   #3
cootetom
Member
 
Registered: May 2004
Location: UK
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 15
I have some time on my hands today so I tried the DVD install instead of the network install. This solved the earlier problem but created a new simular problem. It still gets stuck at boot but here is where it is getting stuck now. Can i pass options to the kernel using Lilo? If so how?

Quote:
Mounting root filesystem /dev/root
mount : error 6 mounting ext3 flags defaults
well, retrying without the option flags
mount : error 6 mounting ext3
well, retrying read-only without any flags
mount : error 6 mounting ext3
pivot root: pivot_root (/sysroot,/sysroot/initrd) failed: 2
umount /initrd/sys failed: 2
umount /initrd/proc failed: 2
Initrd finished
Freeing unusual kernel memory : 296k freed
Kernel panic - not syncing: No init found. try passing inits option to kernel.
 
Old 02-19-2006, 12:57 PM   #4
Vampirite
Member
 
Registered: Apr 2005
Location: England
Distribution: Arch Linux
Posts: 223

Rep: Reputation: 30
You can pass options to the kernel in lilo by using the "append=" I think.

I use GRUB though, I find it to be much better.

I've never heard of /dev/root before, are you sure you have an ext3 partition with the initrd configured properly?

Try booting with the minimum of options,

Try this for a lilo.conf:
Code:
# Start LILO global section
boot = /dev/hda
prompt
timeout = 300
# End LILO global section

# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda1
label = Mandriva 2006
initrd = /boot/initrd[.gz,.img?]
append = ?
read-only 
# Linux bootable partition config ends

# Windows bootable partition config begins
other = /dev/hda5
label = Windows
table = /dev/hda
# Windows bootable partition config ends
You will have to edit it to your system.

Hope thats a bit more helpful.

--
Kourosh
 
Old 02-19-2006, 01:18 PM   #5
cootetom
Member
 
Registered: May 2004
Location: UK
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 15
Here is my lilo.conf file.

Quote:
# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="Windows_XP"
boot=/dev/sda
map=/boot/map
keytable=/boot/uk.klt
menu-scheme=wb:bw:wb:bw
prompt
nowarn
timeout=100
message=/boot/message
image=/boot/vmlinuz
label="Mandriva_Linux"
root=/dev/sda6
initrd=/boot/initrd.img
append="splash=silent resume=/dev/sda7"
vga=788
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/sda6
initrd=/boot/initrd.img
append="splash=silent resume=/dev/sda7"
other=/dev/sda2
label="Windows_XP"
image=/boot/vmlinuz
label="failsafe"
root=/dev/sda6
initrd=/boot/initrd.img
append="failsafe splash=silent resume=/dev/sda7"
I managed to get this only by using a live CD version of mandriva and then mounting 'sda6'. This looks fine to me so i'm thinking it's something wrong with the initrd file but that's where my knowledge in this problem ends so i need further help.
 
Old 02-19-2006, 02:12 PM   #6
Vampirite
Member
 
Registered: Apr 2005
Location: England
Distribution: Arch Linux
Posts: 223

Rep: Reputation: 30
mkinitrd?

Works on Slackware and creates initial ramdisks. I have never used it before, read up some documentation on it, or try man mkinitrd or mkinitrd --help. Then again, Google is always good.

I'll try and find some more info when I have more time. Failsafe is the best option to use to boot up by the looks of it.

Good luck!

---EDIT---
This seems to be a good link, it is Slackware orientated but it should be good enough:
ftp://ftp.slackware.com/pub/slackwar.../README.initrd

--
Kourosh

Last edited by Vampirite; 02-19-2006 at 02:18 PM.
 
Old 02-19-2006, 05:24 PM   #7
cootetom
Member
 
Registered: May 2004
Location: UK
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 15
Thanks Vampirite for all your help on this. I'll do some reading and try a few things then tell you how it went.
 
Old 02-19-2006, 06:17 PM   #8
cootetom
Member
 
Registered: May 2004
Location: UK
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 15
Ok here is an update. I booted up the liveCD of madriva and mounted sda6. I then 'chroot' to that mount point and started editing a few things. First of all i noticed there was another initrd.img file in the /boot folder called 'initrd-2.6.12-12mdksmp.img' so i changed /etc/lilo.conf to use this file instead and then ran lilo to make changes. After re-booting the same problem occured so this changed nothing.

Secondly i read through the readme you linked to and tried this out. I ran mkinitrd but it wouldn't let me use the same options as stated in the readme so i just put 'mkinitrd <nameOfFile> <kernelVersion>'. i created a new initrd and called it initrd2.img i then changed the /etc/lilo.conf again and ran lilo again. This again didn't solve anything.

So once again i feel like it's back to the drawing board but for now i'm going to bed and i'll try some new things tomoz.
 
Old 02-20-2006, 12:02 PM   #9
Vampirite
Member
 
Registered: Apr 2005
Location: England
Distribution: Arch Linux
Posts: 223

Rep: Reputation: 30
Do you really need the initrd.img?

You might be able to boot without it, which might solve something.

I always use ext2 for my filesystems and don't use anything that would need an initrd, so I do not get these problems.

Try booting without the initrd, and let me see what happens.

--
Kourosh
 
Old 02-20-2006, 01:41 PM   #10
cootetom
Member
 
Registered: May 2004
Location: UK
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 15
If i remove the initrd from my lilo.conf i get the following error at boot.
Quote:
VFS: Cannot open root device "806" or unknown-block (8,6)
Please append a correct "root=" boot option
kernel panic - not syncing VFS: unable to mount root fs on unknown-block (8,6)
I've done some reading anyway and have found that the problem i'm getting sometimes occures because the support for ext3 hasn't been compiled into the kernel. I was thinking of re-compiling the kernel and making sure this option was checked but this would require me getting the source and then having to do it all without being booted into the actual OS i wanted to compile the kernel for, which is just annoying to have to do. Surely from a fresh install these options should have been made.

I'm now wondering if it would be a better idea to do as you have and just use ext2. I've read up on the difference between the two.

Also is there anyway of checking kernel options during the install of the mandriva?
 
Old 02-23-2006, 01:52 PM   #11
Vampirite
Member
 
Registered: Apr 2005
Location: England
Distribution: Arch Linux
Posts: 223

Rep: Reputation: 30
Try adding "read-only" underneath the "image=".

Then, try doing "append=root=/dev/sda7"

Without using initrd.

P.S. I find GRUB to be the best bootloader and I can use that easier then LILO.
 
Old 02-23-2006, 03:13 PM   #12
cootetom
Member
 
Registered: May 2004
Location: UK
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 15
Ok it appears I have tried everything that I can find information on to solve this but have had no luck. So i've just installed Suse again upgrading to 10.0. I wanted to check out mandriva but i'm not going to struggle with something when Suse always installs well on my machine!

Thanks a lot Vampirite for all your help, very much appreciated.
 
Old 02-26-2006, 09:28 AM   #13
Vampirite
Member
 
Registered: Apr 2005
Location: England
Distribution: Arch Linux
Posts: 223

Rep: Reputation: 30
You could always try Mandriva with ext2 though!
 
Old 02-26-2006, 03:40 PM   #14
cootetom
Member
 
Registered: May 2004
Location: UK
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 15
I did try that before posting my last reply. I think if i remember rightly i had the root partition set as ext2, then i had my swap space and then i had my home partition as ext3. It still came up with the same error when appearing to try and mount root.
 
Old 02-27-2006, 01:08 PM   #15
Vampirite
Member
 
Registered: Apr 2005
Location: England
Distribution: Arch Linux
Posts: 223

Rep: Reputation: 30
Okay, stay with the SUSE then.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva 10.1 or Mandriva 2006 RC1 ronlon Mandriva 17 04-17-2006 02:24 AM
LXer: Mandriva and HP launch new computers pre-loaded with Mandriva Linux 2006 in 37 Countries in Latin America LXer Syndicated Linux News 0 01-18-2006 10:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 01:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration