LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 04-16-2004, 08:41 AM   #1
wpg9210
Member
 
Registered: Apr 2004
Distribution: Fedora 4
Posts: 68

Rep: Reputation: 16
Mandrake lockup problem...


For some odd reason mandrake 10 has been locking up on me when i leave it running with an open session in screen...i do alot of SSH remote downloading to my home computer and i just started using screen to detatch from console sessions in order to leave remotely initialized downloads running. When i leave it going for a long time (I.E. over night) and try to reconnect i get a host unreachable error, then when i get home and look at the computer there is no video and it is just running, but i cant tell whats going on. Anyone have any experience with this?

Bill
 
Old 04-16-2004, 09:20 PM   #2
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
Trying adding noapic nolapic to your kernel parameters. I have a Asus A7n8x motherboard and nforce chipset and I had a lot of lockups ( la Windows 95) without those.
 
Old 04-17-2004, 08:24 AM   #3
wpg9210
Member
 
Registered: Apr 2004
Distribution: Fedora 4
Posts: 68

Original Poster
Rep: Reputation: 16
ok...where exactly do i add this? do i have to recompile the kernel?
 
Old 04-17-2004, 11:12 AM   #4
doug_s
Member
 
Registered: Apr 2004
Posts: 82

Rep: Reputation: 15
No, just edit /etc/lilo.conf and rerun lilo.
 
Old 04-17-2004, 04:03 PM   #5
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
Add those to "append" on the entry that you boot.
 
Old 04-18-2004, 09:43 AM   #6
wpg9210
Member
 
Registered: Apr 2004
Distribution: Fedora 4
Posts: 68

Original Poster
Rep: Reputation: 16
alright i added them exactly as you have them typed, no arguements or anything...well see if theres any diff...
 
Old 04-25-2004, 05:33 PM   #7
stroggoff
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Hi everybody...
I seem to have the same problem as wpg9210. I am using the mandrake 10.0 community release.

I too have added noapic nolapic to my kernel parameters and still I get
random lockups (after a day or so since the last successful access) . The pc seems to be on but I cannot access it though ssh, ping, vnc or any other means...The only way out is "cold" reboot. Since I basically manage this pc remotely (it is actually located in a different city miles away), this is cold reboot is a rather frustrating task...

Also I get no pertinent error message in the messages log file...

Any other suggestions above how to resolve this? I would really appreciate some help with this, since I am totally lost!
 
Old 04-25-2004, 07:00 PM   #8
Quasar3D
LQ Newbie
 
Registered: Nov 2003
Posts: 11

Rep: Reputation: 0
I have this problem too, with Mandrake 10 and an a7n8x mother board. I added the noapic and nolapic parameters, but it doesn't make any difference, it still locks up all the time. It's a completely fresh install, I didn't install any additional software at all, only mandrake itself.
 
Old 04-25-2004, 07:16 PM   #9
Quasar3D
LQ Newbie
 
Registered: Nov 2003
Posts: 11

Rep: Reputation: 0
In some other threads I see that people are also using a noacpi parameter.
which one should I use? And what do they all do?
 
Old 04-26-2004, 12:32 AM   #10
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
Try them all
 
Old 04-26-2004, 03:23 AM   #11
stroggoff
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Actually trying them all won't work too. I have already tried adding the noacpi parameter ! Still the pc inexpicably locks up !
 
Old 04-26-2004, 07:33 AM   #12
Quasar3D
LQ Newbie
 
Registered: Nov 2003
Posts: 11

Rep: Reputation: 0
I too have tried them all, and I still get the lock ups all the time
 
Old 04-26-2004, 04:13 PM   #13
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
Tell mandrake expert.
 
Old 04-27-2004, 01:39 AM   #14
thane777
LQ Newbie
 
Registered: Oct 2003
Location: Packerland
Distribution: Redhat/Mandrake
Posts: 19

Rep: Reputation: 0
Quote:
Originally posted by Quasar3D
I have this problem too, with Mandrake 10 and an a7n8x mother board. I added the noapic and nolapic parameters, but it doesn't make any difference, it still locks up all the time. It's a completely fresh install, I didn't install any additional software at all, only mandrake itself.
Hey all, I had this same problem with 9.2 and 10. You need to add the noapic nolapic like an earlier poster said but you also must remove the resume=/dev/hdX phrase from the append line as well. Keep acpi=ht. That should straighten you out.

If that does not work go into the power and control module and set it so it does not suspend after a preset time.


Thane

I'm not at my linux box at the moment but if you'd like my actual append line let me know and I'll post it later.





Last edited by thane777; 04-27-2004 at 01:41 AM.
 
Old 04-27-2004, 07:56 AM   #15
Quasar3D
LQ Newbie
 
Registered: Nov 2003
Posts: 11

Rep: Reputation: 0
Quote:
Originally posted by thane777
Hey all, I had this same problem with 9.2 and 10. You need to add the noapic nolapic like an earlier poster said but you also must remove the resume=/dev/hdX phrase from the append line as well. Keep acpi=ht. That should straighten you out.

If that does not work go into the power and control module and set it so it does not suspend after a preset time.


Thane

I'm not at my linux box at the moment but if you'd like my actual append line let me know and I'll post it later.
Yes, please post your lilo.conf.

There is no resume parameter in my appen list. My lilo.conf looks like this:

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

boot=/dev/hda
map=/boot/map
install=menu
default="linux"
keytable=/boot/us-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda4
initrd=/boot/initrd.img
append="devfs=mount acpi=ht splash=silent noapic nolapic"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda4
initrd=/boot/initrd.img
append="devfs=mount acpi=ht"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda4
initrd=/boot/initrd.img
append="failsafe acpi=ht devfs=nomount"
read-only
other=/dev/hda1
label="windows"
table=/dev/hda
other=/dev/fd0
label="floppy"
unsafe

How do I set it that it doesn suspend? I've looked in HardDrake, but I couldn't find it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10.1 lockup DaveRowntree Mandriva 2 09-14-2005 12:43 PM
KDE lockup on Mandrake 10.1 gavinbeatty Linux - Newbie 6 04-09-2004 03:29 PM
Mandrake 9.1 Lockup Problem falcon56215 Linux - Software 2 10-31-2003 09:51 PM
Mandrake 9.1 boot lockup messenjah Linux - Distributions 1 07-17-2003 01:12 PM
Internet lockup in Mandrake 8.2 drakoth Linux - Networking 4 07-31-2002 09:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 05:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration