LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 08-28-2004, 08:04 PM   #1
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Rep: Reputation: 0
Mandrake fails to bring up eth0


I'm new to Mandrake. I have successfully installed v.10, but am unable to connect to the Internet.

On boot, M10 fails to bring up eth0. In MCC, my NIC is recognized (Realtek 8139), but I can't connect. I've done some research, but can't solve the problem. I can ping localhost, but when I try to execute ifconfig or route bash tells me the commands are not found.

My DHCP router (Dlink 713-P) is correctly configured as far as I can tell, though it doesn't see my Mandrake box's NIC. I've manually entered the MAC address, but that doesn't seem to help.

One last thing - when I enter the network settings manually, the computer is sending packets, but does not receive any. When I've done this, M10 manages to bring up eth0 on boot, but I'm still not able to receive packets after reboot.

Any help would be much appreciated. I've heard great things about Mandrake, but if I can't get this resolved soon, I'm going to give SuSE a try.

Thanks in advance.
 
Old 08-28-2004, 08:24 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,838

Rep: Reputation: 5971Reputation: 5971Reputation: 5971Reputation: 5971Reputation: 5971Reputation: 5971Reputation: 5971Reputation: 5971Reputation: 5971Reputation: 5971Reputation: 5971
ifconfig and route is not in a users path environment. Use the full path /sbin/ifconfig. My first guess would be a firewall is blocking DHCP.
 
Old 08-28-2004, 09:19 PM   #3
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for the reply.

I forgot I wasn't logged in as root. When I run ifconfig, I get

etho Link encap:Ethernet HWaddr 00:30:1B:3B:77:50
inet6 addr: fe80: : 230:1bff:fe3b:7750/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:4827 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:4140 (4.0 Kb)
Interrupt:11 Base address:0xd000

lo Link encap:Local Loopack
inet addr: 127.0.0.1 Mas:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP BROADCAST RUNNING MTU:16436 Metric:1
RX packets:98 errors:0 dropped:0 overruns:0 frame:0
TX packets:98 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6420 (6.2 Kb) TX bytes:6420 (6.2 Kb)

I'm pretty sure it's not a firewall issue at this point because I'm not even getting assigned an IP through DHCP, and I have Mandrake's firewall turned off.

Last edited by 9re9; 08-28-2004 at 09:25 PM.
 
Old 08-28-2004, 10:38 PM   #4
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 573

Rep: Reputation: 30
Turn off the hotplug in the network configuration in the MCC. . Evey System I have I have to turn it off to get network activity.
 
Old 08-29-2004, 10:42 AM   #5
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Original Poster
Rep: Reputation: 0
It's off.

Any other suggestions?
 
Old 08-29-2004, 04:02 PM   #6
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Original Poster
Rep: Reputation: 0
OK. I've done more research, and have turned off IPv6 in /etc/modprobe.conf , and have tweaked /etc/sysconfig/network-scripts/ifcfg-eth0.

When I run dmesg I am told, among other things
Code:
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
However, after restarting network services, and rebooting (at which point eth0 loads quickly) I am still unable to connect. I can't even ping my router - I'm told destination is unreachable. Any other suggestions?

Thanks.
 
Old 08-29-2004, 07:41 PM   #7
Harnic
LQ Newbie
 
Registered: Aug 2004
Location: BC Canada
Distribution: Mandrake 10
Posts: 29

Rep: Reputation: 15
Thankyou CourtrrbI I am new to Linux & was having trouble getting eth0 to load at the startup too. Disabling hotplug did it for me!
 
Old 08-30-2004, 07:31 AM   #8
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I'm still stuck... Some more info.

When I don't edit /etc/modprobe.conf - which seems to leave IPv6 enabled, and run route, M10 returns the following:

Code:
Kernel IP routing table
Destination          Gateway          Genmask          Flags         Metric         Ref         Use         Iface
192.168.0.0         *                      255.255.255.0  U               0                0             0            eth0
127.0.0.0             *                      255.0.0.0          U               0                0             0            lo
default                 192.168.0.1     0.0.0.0              UG             0                0             0            eth0
However, when I edit /etc/modprobe.conf - to turn off IPv6, I get the following:

Code:
Destination          Gateway          Genmask          Flags         Metric         Ref         Use         Iface
192.168.0.0         *                      255.255.255.0  U               0                0             0            eth0
127.0.0.0             *                      255.0.0.0          U               0                0             0            lo
My router is at 192.168.0.1

Hopefully someone can pull some useful info out of this. Thanks.
 
Old 08-30-2004, 07:48 AM   #9
barrys
Member
 
Registered: Sep 2003
Location: London
Distribution: Susi 9.1, Man10 amd64, Man10.1
Posts: 243

Rep: Reputation: 30
I am making a guess but your config says you are connected.

I suspect your dns is not setup yet. ping a number not a name.

The ping with an ip number does not do lookup in the dns and if the servers are not listed then you can not connect to a dns name.

It could also be a router problem if you have disabled the dhcp in your router.

Enter in your browser a ip address such as 62.3.99.219

If this works you haven't enabled dhcp in your MCC
go back to mcc and add a new connection this time adding dhcp you can get the connection but on man 10 you need to reboot for the DHCP to load the
dns server address's.

You could enter them manually if you have them, but shouldn't need to.
 
Old 08-30-2004, 09:21 AM   #10
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for your feedback.

Unfortunately, I have manually configured all of the settings - IP, Gateway, Mask and DNS. Still no luck. In addition, I can't ping the router, the IP address you suggested - anything other than localhost.

Interestingly, my router doesn't even see my Linux box's NIC. I thought it might be that I have enabled Access Control on my router. (In other words, unless you enter the MAC address of a NIC, it can't associate or connect to the router.) I have manually entered the MAC address into this configuration, and I have turned the feature off, neither of which has resolved the problem. However, given the huge number of people who are having trouble connecting to the Internet with Mandrake, I suspect the problem lies elsewhere.

Any other suggestions?

Thanks again.
 
Old 08-30-2004, 03:23 PM   #11
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Original Poster
Rep: Reputation: 0
One last comment, really this is a *bump*, but it might help.

If I try and ping my ISP's DNS servers, I get the following:

Code:
connect: Network is unreachable
Has anyone every seen this before, and know to what it is attributable?

Thanks.
 
Old 08-30-2004, 03:30 PM   #12
zionz
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Rep: Reputation: 0
I get that message when i enabled the firewall, it is called shorewall, i used "shorewall stop".
 
Old 08-30-2004, 03:48 PM   #13
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Even after stopping shorewall I get the same error.

Also, after following the advise in another post, I have no checkboxes checked in the MCC firewall panel.
 
Old 08-31-2004, 09:18 AM   #14
9re9
LQ Newbie
 
Registered: Aug 2004
Posts: 9

Original Poster
Rep: Reputation: 0
SOLVED!

Thanks to those who tried to help. This was obviously an obscure issue.

It turns out that I was able to access the Internet by turning off full duplex / autodect.

If you have a RealTek 8139 NIC, and also cannot connect to the internet, do the following:

1. Install ethtool from Disc 4
2. Launch your terminal
3. su to root
4. Type: ethtool -s eth0 speed 10 duplex half autoneg off
5. ping your router

You should be good to go.

Hope this helps prevent some other folks from tearing their hair out.
 
Old 08-31-2004, 09:30 AM   #15
snt
Member
 
Registered: May 2004
Posts: 53

Rep: Reputation: 15
MCC --> Boot --> Bootloader

Check 'Force no APIC'.

Reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can'r bring up eth0 in Mandrake 10.1 Official nonlintech Mandriva 4 09-11-2005 11:07 PM
can not bring up eth0 summerfish Linux - Networking 2 07-19-2004 10:09 PM
Mandrake 10 fails eth0 MysteriousRevC Mandriva 18 05-22-2004 01:39 PM
Mandrake 10 eth0 fails on boot and no display Storm660 Mandriva 5 04-22-2004 04:02 PM
eth0 fails on boot - mandrake 10 Power_Penguin Linux - Networking 5 04-17-2004 07:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration