-   Mandriva (
-   -   Mandrake 9.1 -> rpmDrake starts, but fails - Please help me! (

Eagle3386 10-26-2003 08:11 AM

Mandrake 9.1 -> rpmDrake starts, but fails - Please help me!
Hello everyone! :)

I'm new to Linux - to be correctly 2 weeks... ;)
But in fact, I was working 2 hours on Linux and thought why I still use Windows...
Well, I think because of the problem with Win-games on Linux (although there's WineX and others... ;))

But the question I got is from an other type:

Since 3 days I can't install rpm-files anymore - as a normal user.
If I'm logged in as root, everything works fine and runs correct.
But as soon as I log myself in under my normal account, something goes strange.
If I execute the rpm-file (I'm doing a double click on it) rpmDrake is displayed in the Taskbar, stays there for 10 or 20 seconds, the sand-glass is turning and after these 10 or 20 seconds rpmDrake disappears from the Taskbar and the rpm-file isn't installed...

Also (as the rpmDrake worked correctly) there was a root-password-prompt - but now, there isn't one anymore...
If I go to the Mandrake Control Centre, rpmDrake works fine, I can install and uninstall packages, but the double click-installation doesn't.

Please help me!

Thanks for any helpful advice, Martin :)

My System:

AMD Athlon XP 2000+
Windows 2000 Professional
Mandrake 9.1 (Bamboo)

Baldrick65 10-26-2003 08:26 AM

You don't say if you are using KDE or GNOME. If it's KDE, install kpackage from the Mandrake Control Centre. Double-clicking on rpm files should then open kpackage. You may have to be root to install some packages anyway.


Eagle3386 10-26-2003 09:42 AM

Oh, sorry!

I'm using KDE.

I'll install it when I come back from a more than boring "party"... ;)

The package(s) I'd like to install can be installed without being root - that was at least said by the author(s) of the package(s)... :)

But great thanks for your quick reply! :)

Regards, martin :)

Eagle3386 10-27-2003 01:11 AM

Hi, Baldrick! :)

Ehm, I got a question about kpackage.

In my Control Centre are 2 KPackages:

Name: kdeadmin-kpackage
Size: 473 KB
Source: main


Name: kdeadmin-kpackage
Size: 473 KB
Source: texstar

Which of them is the one I should install?!?
And why isn't anyone of these 2 packages already installed?!?

Thx a lot, Martin :)

Baldrick65 10-27-2003 05:14 AM

OK, it probably doesn't matter which version you install, but I would go for the mdk version from "main" source. The texstar version looks like an update so it probably doesn't matter in any case.

I don't know why they don't install it in MDK9.1, it was in a standard install of 9.0. The only reason I prefer it is because I've beeen using it a long time and it works ok for me.


Eagle3386 10-27-2003 05:24 AM

Hmm, well, IMHO your way installs an alternative RPM-Front-End, isn't it?

I might be wrong (As I said, I work with Linux since 2 weeks...), but if I'm right, don't you know a way to "repair" the rpmDrake?!?

Excuse me for my maybe bad English, I'm from Germany and the English we learn at school is not more than bull-shit, because we don't learn sayings and although I'm on a technical High School, we don't learn technical words in English...

Baldrick65 10-27-2003 05:34 AM

OK, in that case, can you install rpm's from the console? Try this:

rpm -Uvh <package_name>.rpm
or we might be going around in circles :) On my machine, when I execute rpmdrake from a console as a normal user, it asks for the root password.

kpackage is really only a front-end for the rpm command. As far as installing software via rpm, I don't think I've come across a package that installs as a user. Maybe I'm lucky, but I always install rpm's as root.


Eagle3386 10-27-2003 06:44 AM

Yep, the "console-version" is working probably - also with .rpm-files and when I'm under my normal user-account.

Well, I think I should explain the problem once again - but more detailed:

I got several .rpm-files, which I downloaded from and others.
These .rpm-files are the flash player-plugin for Konqueror, Mosfets Liquid-Theme-Patch and some others.

As root everything can be installed without any problem - and they run perfectly - I double-click on the .rpm-file(s) and then the package installs everything needed.
But under the normal user (when I also double-click on the .rpm-file) rpmDrake launches, the sand-glass in the taskbar (left to the word "rpmDrake") is turning and then the taskbar-entry disappears - but that's not correct!

One week ago when I double-clicked on a .rpm-file (under my normal user-account) the rpmDrake was also launched and the sand-glass was also turning - but after 2 or 3 seconds a dialog-box appeared and asked me for the root-password.

Since an action (I don't know what I should have done so that it doesn't appear now...) I took (or maybe rpmDrake can't work probably because of something I also don't know...) this box doesn't appear anymore and I think because of that no root-password is entered, rpmDrake can't install and that's why it disappears in the taskbar.

So I'd like (and need ;) :D) to get rpmDrake working as before - double-clicking on the .rpm-file, asking for the root-password, installing the package, making me happy (;) :D).

So can you help me in this case with any helpful advice? - I don't like to install Linux again...

Baldrick65 10-27-2003 07:00 AM

This might be considered a "sledge-hammer approach", but maybe you could upgrade the rpmdrake program itself.

Surf over to and see if there is a later version than the one you are using.

Your version should be 2.1-13mdk. There is a 2.1-35mdk version that might fix the problem. After that, I'm out of suggestions for the moment :(


Eagle3386 10-28-2003 01:19 PM

Ok, here we'll go again... ;)

First of all, I'd like to know what a "sledge-hammer approach" means, because the way my dictonary and the google-translator translated it into german is total confusing, although I tried both ways: the whole word-group and word by word... ;)

The scond one is that I've installed the 2.1-35mdk version over my current version - but nothing changed since that.

While doing what you said I found out something: the programm, which installs the .rpm-files is grpmi, the graphical front-end of mandrake for the .rpm-file-installer, called "rpm" (What a surprise... ;) :D).

But when I launch the .rpm-files via double-click, the rpmDrake is launched and NORMALLY it should display a prompt asking for the root-password.

Could you please contact anyone you know who knows Mandrake Linux 9.1 and ask them what the hell is causing this mistake and how to fix it?!? - I've asked all the people I know who use Linux and maybe know a fix for that problem, but none of them had an idea that worked...

If there won't be any way that work, I'm forced to install Linux again... :'(

All times are GMT -5. The time now is 08:41 PM.