LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-11-2004, 11:49 AM   #1
cyber6
LQ Newbie
 
Registered: Sep 2004
Location: Luxembourg
Posts: 4

Rep: Reputation: 0
Unhappy Mandrake 10+sound


I have been able to get sound working on Mandrake 10 by running alsaconf and it set up my Creative soundblaster live card OK. [emu10k1]
Playing music in XMMS-no problem.

BUT when I reboot I get the error message along the lines of
.....''sound server will continue using the null output device''.
[I am at work now and away from the machine so I cannot recite the exact messsage.]
So, how do I get the sound to start automatically every boot?
Also, I do not have the start up music or system sounds-how do I enable these again?

All sound was working OK in Mandrake 9.1??

Thanks in advance.
 
Old 09-11-2004, 11:53 AM   #2
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
i have the same card. open your /etc/modprobe.conf file with a text editor of your choice. if it's missing any the lines in red below, add them in the order they are in, save the file, & reboot.

Code:
alias sound-slot-0 snd-emu10k1
alias eth0 tulip
install scsi_hostadapter ; /bin/true
install snd-emu10k1 /sbin/modprobe --first-time --ignore-install snd-emu10k1 && { /sbin/modprobe snd-pcm-oss; /bin/true; }
install usb-interface /sbin/modprobe usb-uhci; /sbin/modprobe ehci-hcd; /bin/true
remove snd-emu10k1 { /sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe -r --first-time --ignore-remove snd-emu10k1
alias /dev/nvidia*   nvidia
otis
 
Old 09-11-2004, 12:04 PM   #3
cyber6
LQ Newbie
 
Registered: Sep 2004
Location: Luxembourg
Posts: 4

Original Poster
Rep: Reputation: 0
modprobe.conf

otish1000c,
Thanks for the tip-I will try it as soon as I have finished work-get back to you later.
 
Old 09-12-2004, 04:39 AM   #4
cyber6
LQ Newbie
 
Registered: Sep 2004
Location: Luxembourg
Posts: 4

Original Poster
Rep: Reputation: 0
modprobe.conf

OK,
I checked the modrobe file as you suggested and it is axactly as you have it.
I still have to run alsaconf to get sound working and I still am unable to get KDE system sounds working.

Do you have any other suggestions?
 
Old 09-12-2004, 06:57 AM   #5
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
in mandrake control center->system->services do you have alsa set to start at boot?

otis
 
Old 09-12-2004, 07:02 AM   #6
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
maybe it's because of sound server?
try to disable it and point XMMS' output directly to Alsa.

If you're missing kde system sounds, set up KDE to use aplay as an external player.
If your card doesn't support hardware mixing of multiple sounds (SB Live should) try to use dmix plugin.
 
Old 09-13-2004, 07:04 AM   #7
cyber6
LQ Newbie
 
Registered: Sep 2004
Location: Luxembourg
Posts: 4

Original Poster
Rep: Reputation: 0
alsa

alsa is set to start at boot....
 
Old 09-18-2004, 01:07 PM   #8
chilehead
Member
 
Registered: Sep 2003
Location: Lancaster, CA
Distribution: Ubuntu 9.10
Posts: 97

Rep: Reputation: 15
sorry to jump this thread, but I am having the same problem....no sound on boot. I have to either run alsaconf, or go to Mandrake Control Center and start the alsa service. The "on boot" box is checked, so I assume that it is supposed to start on boot, but when I go into services, alsa status is "stopped". I also have no KDE sounds and am not sure how to "set up KDE to use aplay as an external player" as leadazide suggested. Thanks in advance....
 
Old 09-18-2004, 02:29 PM   #9
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
chilehead:
I don't know how it is on Mandrake, but on SuSE you have to have a symlink to /etc/init.d/alsasound in /etc/init.d/rc5.d/ - it is named (at least on my machine) K08alsasound. If you don't have alsasound script, then it's BAD. Try to reinstall ALSA (or first update it via internet, and then install). Setting up aplay in kde as a default player only helps to get rid of KDE sound server, it won't work if you don't have alsasound started.
Can't you tell services in mandrake cc to start automatically on boot? I don't know, since I don't have Mandrake.
If you can't make alsa start on boot, take a look at /etc/init.d directory and rc script.

If you want to be aplay as an external player in KDE go to Kde control center, Sound & Multimedia, System Messages, click on 'Playback Settings' and type 'aplay' into the edit field'.
(The names may not be correct, since I have only German translation of KDE now).
 
Old 09-19-2004, 01:33 PM   #10
myr
LQ Newbie
 
Registered: May 2004
Location: Finland
Distribution: Mandrake
Posts: 19

Rep: Reputation: 0
For the systemsounds in KDE-boot, look for file /home/*****/.kde/share/config/knotifyrc. In this file should be section StartProgress like this:
[StartProgress]
Arts Init=true
KNotify Init=true
Use Arts=true

Hope this helps.

Last edited by myr; 09-19-2004 at 01:34 PM.
 
Old 09-19-2004, 01:58 PM   #11
chilehead
Member
 
Registered: Sep 2003
Location: Lancaster, CA
Distribution: Ubuntu 9.10
Posts: 97

Rep: Reputation: 15
myr:

I looked in knotifyrc, and mine read

Arts Init=false
KNotify Init=true
Use Arts=false

I changed the settings to true, but when I rebooted, they reverted back to false
I'm not sure whether it did any good anyway because I still didn't have KDE sounds before I rebooted.
 
Old 09-19-2004, 02:07 PM   #12
chilehead
Member
 
Registered: Sep 2003
Location: Lancaster, CA
Distribution: Ubuntu 9.10
Posts: 97

Rep: Reputation: 15
leadazide,
thanks for KDE sounds advice - changing the settings to an external player seemed to work. Took a while to find what you had described....but it worked. the names WERE a bit different. Haven't tried the symbolic link yet, but will when I have some time and I'll post the results Thanks
 
Old 09-20-2004, 11:39 AM   #13
chilehead
Member
 
Registered: Sep 2003
Location: Lancaster, CA
Distribution: Ubuntu 9.10
Posts: 97

Rep: Reputation: 15
I guess I was a little premature in calling this problem resolved.... My KDE sounds now work, but only if alsa is started....and I still need to start alsa services each time I start my computer, even though it seems to be configured to automatically start at boot in the Mandrake Control Center. Don't know if it helps, but I noticed during startup, when all the services are getting started, that a message goes by that reads something like "alsa already running" Anyway, any help is much appreciated.
 
Old 09-21-2004, 10:01 AM   #14
philw
LQ Newbie
 
Registered: Sep 2004
Location: Madison WI
Distribution: Mandrake 10, Knoppix, Phlak
Posts: 9

Rep: Reputation: 0
I was having a similar (or the same) problem with MDK 10, Alsa, and onboard AC'97 sound. Boot message would say "Alsa <version> already running", an artsMsg in KDE would say "device:default not found. Using null output" or something like that. Alsa showed up in services, but was stopped. I beat my head against the monitor for 3 or 4 days, searching message boards, alsa-project.org etc. Tried various versions of alsa, on and on and on...

Finally I stuck in an old Turtle Beach card, disabled the onboard sound, and booted up mandrake. Harddrake found the card, alsa configured itself, and like magic I had sound! Until I rebooted again, and got the exact same messages as before. Pulled TB card, enabled AC97, and voila! I had sound again!

Now, somewhere on one of these boards, maybe this one, someone said "Try running 'alsactl store' (or maybe alsactl -store, don' remember). Did that, rebooted, still had sound. Reboot, reboot, reboot....Yay! Still have sound.

Funny that none of the "official" alsa instructions mentioned that little tidbit. Thank Torvald for forums like this!
 
Old 09-21-2004, 04:49 PM   #15
philw
LQ Newbie
 
Registered: Sep 2004
Location: Madison WI
Distribution: Mandrake 10, Knoppix, Phlak
Posts: 9

Rep: Reputation: 0
GODDAMMIT! Spoke too soon I guess. Left Mandrake, went into windows for a while, and now I have no sound in linux. I even tried switching cards again, but no luck.

I'm beginning to identify with the people at linuxsucks.org. This is worse than windows 3.0 for godsake! What a bunch of crap!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Other problem with the sound in Mandrake - onboard sound card Swetko Linux - Hardware 24 06-19-2006 03:27 PM
Sound Help - Sound Blaster AudioPCI64V/AudioPCI128 // Mandrake 9.2 mpyrewoody Linux - Newbie 1 08-31-2004 09:01 AM
running Mandrake 9.2, i do have sound in x-chat, cd playing no sound. AdrEnochrOme Linux - Newbie 5 01-24-2004 03:49 PM
Can't get sound from Mandrake 9.1 with SoundBlaster Audigy 2 Sound Card... shortyzms Linux - Newbie 3 12-08-2003 05:36 PM
A7N8X + Mandrake 9.1 + onboard sound card = No SOUND st_purple Linux - Hardware 3 11-07-2003 08:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration