LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 04-12-2004, 11:10 AM   #16
Rory in Toronto
Member
 
Registered: Mar 2004
Posts: 136

Rep: Reputation: 15

Hi Gary,

I'm a newbie, just like you, the value of my advice is limited.

Your ISOs sounded fine and should be, if you used them throughout the install.

If typing "kde" doesn't work at the prompt, I wonder if typing "GNOME" or "iceWM" "failsafe" or "default" would help. I'm not entirely positive where you're stuck in the boot process, so I suspect after your last message, these won't work. I guess the trick is to see if any of them are linked to a kernal that will bring you in to your desktop.

And I'm sure when you come to the Lilo screen, you've tried all your options: linuxfb, failsafe... If none of those work, it's a problem better left to posters more familiar with Linux.

Let us know how it goes. Off to figure out my own ACPI problem...

Rory
 
Old 04-14-2004, 09:23 PM   #17
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Greets Gary and Rory:

I am currently stuck with this problem as well after I tried to learn how to use Grub (I know Lilo pretty well) and installed Debian Sarge again. I can't get to Mandrake right now. I will keep you up to date if I get there first.

I am sure its a bootloader option. Therefore, its either a fix in /etc/lilo.conf or a fix in /boot/grub/menu.lst, depending on your bootloader.

What caught my eye was the command to start X. I struggled getting both Gnome and KDE to start from the command line at first. The command for starting KDE is
Code:
startkde
and Gnome is
Code:
gnome-session
Before you try that, you may just want to try
Code:
startx
. KDE is usually the default for Mandy anyhow, so it'd be the one to start. Good luck. If you solve the init thing first, tell! Do tell! This is the first time I have really tried to address the problem and I don't want to ever be troubled by it again (and I plan to install zillions of distros yet, over time).
 
Old 04-14-2004, 10:08 PM   #18
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Thumbs up

OMG! First try! I am now in Mandrake again after 3 days of exile! Woohoo. I'll try to explain what I did. I am gonna go back and fix the rest so I get a full framebuffer login again but here I am!

My suspicion was correct. It was a config option. I edited the Grub config file, menu.lst, so the terminology will be slightly different, and may not translate properly to Lilo's language, but I'll help any way I can.

Here's what I used as an example to work with at first:
from my /etc/lilo.conf file
boot=/dev/hda
map=/boot/map
default="linux"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz #the grub line is kernel /boot/whatever
label="linux"
root=/dev/hda1
initrd=/boot/initrd.img
append="devfs=mount acpi=ht resume=/dev/hda5 splash=silent"
vga=788
read-only

If I read it correctly, to get the same result in Grub like this:
from my Debian /boot/gub/menu.lst file
default 0 #same as default="linux"
timeout 5
color cyan/blue white/blue
title Mandrake bare
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1 ro #the root=/x/x switch was what got it to work
initrd /boot/initrd.img
savedefault
boot

Here's what didn't work (and I am gonna go back into Debian and edit the file to include a root=/x/x switch on the kernel line to see if I was right):
from my /boot/grub/menu.lst file
title Mandrake
root (hd0,0)
kernel /boot/vmlinuz devfs=mount acpi=ht splash=silent ro vga=788
initrd /boot/initrd.img
savedefault
boot


So, if I make the "kernel" line read:
kernel /boot/vmlinuz devfs=mount acpi=ht splash=silent ro vga=788 root=/dev/hda1
Perhaps it'll work. I'll report with success and propose a lilo solution.



.............then we can tackle your no graphical startup problem.
 
Old 04-14-2004, 11:47 PM   #19
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
I am back to admit that the root= argument is what worked, but after I updated Mandrake and took the new kernel-patch, which prompted Mandrake to overwrite grub with lilo again - with no stanza about Debian. So to get back to Debian to run grub-install and try the added switch, I had to solve the lilo problem first. So, I had to solve this problem from a similar POV as you, in a way. I am pleased to report that reversing the logic did actually work - I got back to Debian so I could rewrite the MBR with Grub and test my theory, which I did and am now back in Mandrake from grub. (phewf)

So, here's the stanza for Debian in my /etc/lilo.conf
image=/mnt/deb/boot/vmlinuz-2.6.3-1-686
label=Debian
root=/dev/hda6
read-only
initrd=/mnt/deb/boot/initrd.img-2.6.3-1-686

That got me back in to Debian. So, my conclusion from this, since the kernel didn't panic, is that you need:

1)the exact path (if multiple drives, they have to be created as mount-points in /etc/fstab first, as mine is) to the kernel must be listed as the kernel image
2)Its very important to tell where the root partition is.
3)Don't pass some video parameters that are out of spec, as your machine will panic.

So, my advice is to gain access to your /etc/lilo.conf file and be sure that to correct partition is listed as root (so the kernel will know where to find /sbin/init). To be sure that you isolate the problem, Start with a really basic stanza in your /etc/lilo.conf file, leaving out any
Code:
append=
stuff for the first run. You can add those after you lose the kernel panic.
 
Old 05-12-2004, 10:16 AM   #20
jeepskate
LQ Newbie
 
Registered: May 2004
Posts: 2

Rep: Reputation: 0
What worked for ME!

I've been using Mandrake since back in the 7 days. I also had this same exact error message with 10.0 CE. What got me out of it was Debian.

I see that another user also corrected this by booting into Debian to get the good old #. I however don't think I'll be going back to Mandrake, not trying to be a troll or start a flame war. Just giving in my two cents. I like Debian, the apt-get is pretty nice and I'm going to keep it, for awhile anyway.

After Mandrake 9.2 and the rumors of the same bugginess being in 10.0 I think I may be done with Mandrake.
 
Old 05-12-2004, 12:14 PM   #21
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
didn't realize this thread was still around

Funny, I found the opposite. Sarge was a bit buggy for me and Mandy 10 was flawless. Don't get me wrong, I love Debian!
 
Old 05-20-2004, 09:38 PM   #22
crzyflll
Member
 
Registered: May 2004
Location: Brisbane, Australia
Distribution: Mandrake 10
Posts: 31

Rep: Reputation: 15
I have the same problem with the init kernel panic as Garry_100 , I am running mandrake 10 and trying to upgrade to 2.6.6. I have a SATA drive as my root and it will not boot. In one of the threads I read that you should not have the default runlevel as 5 when trying to boot a new kernel in Red Hat (and therefore mandrake as it is based on rehat). But changing this does not seem to make any difference other than making the system boot to a command line rather than X. I am going to try and include support for more device types into my kernel and recompile as I am sure that it is just support that I am lacking for my particular HDD. Will including all the drive options slow my kernel down much?
 
Old 05-23-2004, 12:40 PM   #23
andrew
LQ Newbie
 
Registered: Mar 2004
Location: Southwick, MA, USA
Distribution: Fedora Core 2
Posts: 4

Rep: Reputation: 0
stupid mistake

i got this error message once after i did somthing stupid.

I was running fedora core 1 at the time. I deleted the /initrd directory because it was empty. When I rebooted I got "Kernel panic: No init found. Try passing init= option to kernel". All I had to do was recreate this blank directory and all was back to normal.

it might not be the same location for you.
 
Old 06-09-2004, 02:34 AM   #24
BOUCH
LQ Newbie
 
Registered: Jun 2004
Posts: 7

Rep: Reputation: 0
This hasn't been discussed in a while... I was wondering if the origional poster had resolved his issues. If not I believe there to be issues with the SATA drive. I've been trying everything that everyone here has mentioned with both boot loaders, choosing upgrade... but what it gets down to is if Mandrake is seeing my hd at all... and I'm not convinced it is... even when I boot with a KNoppix CD, I can't see my drive... and when I reinstall... all my partitions have went from EXT3 to EXT2 s... I don't know.. was hoping that someone had gotten somewhere with this.
 
Old 06-09-2004, 04:19 AM   #25
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
Usually, the error message you are seeing when trying to boot was caused because an error occurred when executing the 'lilo' command. If that happens the bootstrap information is not updated.

You need to boot into the rescue system. Boot with the first install cd, press F1 for more options, enter the option 'rescue'.

The rescue system will try to locate your linux partitions for you. There is an option to mount your partitions under /mnt.
Also enter in the lsparts command to list your detected partitions. You will compare it later with your /etc/lilo.conf file.
Select this option. Next cd to the /mnt directory and list the directory to make sure your root hierarchy is there.
If it is, we want to change the root partition to what is should be normally. Type in 'chroot /mnt'. This will change the root to your systems root partition. Now lilo won't get confused.
To set up the normal PATH variable and aliases type: bash -l
This will execute your bash startup scripts and allow you to execute programs in the /sbin and /bin directories. Before this you would have had to use vim-minimal instead of vim, which would actually not be bad, just different then you might expect.

Take a look at your /etc/lilo.conf file. Do all of the partitions in all of the stanzas exists. A normal windows partition may have it's own stanza that you want to delete.

What is the boot= partition. With NTFS on the first partition, if you are dual booting, you may need to change it to a linux partition instead.

If you don't see any errors in the lilo.conf file, type :q! to exit. Type in the command 'lilo'. There will be a line printed out for each stanza.
Make sure that it doesn't error out. If it does you need to recheck your partitions and the lilo.conf file.

If you are unable to select the drive with the active MBR as your boot= entry, you may need to follow the instructions in one of the 'NT Lilo Boot Howto's. This would entail copying the first 256 bytes of the linux boot= partition to a file, saving the file to the XP's c:\ directory, and adding an entry for Linux in the C:\BOOT.INI file.
 
Old 06-09-2004, 05:34 AM   #26
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 394

Rep: Reputation: 52
Is this boot problem fixed yet? Can't tell from this thread. If not, post output of 'fdisk /dev/hda' and the text of your lilo.conf of grub.conf. We'll get this puppy fixed.

Glennzo
 
Old 06-09-2004, 08:29 AM   #27
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Yeah, I'm curious too. LOL, I forgot that I was still subbed to this thread
 
Old 06-09-2004, 12:14 PM   #28
BOUCH
LQ Newbie
 
Registered: Jun 2004
Posts: 7

Rep: Reputation: 0
I'm not at home so I don't have my computer here for that, but I don't think it's Lilo or my partitions (Lilo identifies hda5 as my root ptn, and that is what it is. But here's a curious note:
I use Knoppix to troubleshoot, nothing like Linux on CD... But Knoppix using kernel 2.4 doesn't detect my SATA (WD160GB) drive... hmmm... so this sent me into thinking. So I booted Knoppix with the beta 2.6 kernel and it got my drive fine, note, it loaded the via8237SATA module... so now back to my machine
During installs, it tells me it is loading via8237Sata driver, and in doing so, there are no problems during the install... BUT on the reboot it loads the sata-via.ko instead (which has the driver).... And this is where I think my problem lies. It does not read my sata drive as hda, it does not see /dev/hda5 therefore can not fine /boot/rdinit

thoughts? How can I force the module to compile into the kernel... keep in mind I have NO access to my computer once the install is done.... so any editing must be done via rescue mode.

*** UPDATED WITH SOLUTION ***
If you are having this problem, it may be that you did as I did, you installed from another hard drive thinking that this is faster then CDs. In this case the reboot names your drive sda, thus your bootloader pointing to hda does squat... I downloaded the CDs for RC1, installed off CDs, and it works fine now. Moral : install off CDs if you don't want to confuse your machine when it comes to SATA drives.

Last edited by BOUCH; 06-10-2004 at 11:50 AM.
 
Old 06-28-2004, 09:05 AM   #29
permittivity2
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 9 & 10
Posts: 1

Rep: Reputation: 0
How to drop to command line at boot

some of the problems that you are having is that you may not have a "command line" from LILO at boot. When you see the graphical interface at boot, you may want to press ESC to get a command line.

I noticed that my kernel panic was due to swapping my hard drive to the IDE secondary controller and my cdrom to the IDE primary controller....this was not intentional. I was able to get my system to boot by telling it where the root file system is located by passing the kernel optoin root=/dev/hdc1 . Typically in Mandrake they layout is such:

hda = Primary IDE, Master device
hdb = Pimary IDE, Slave device
hdc = Secondary IDE, Master Device
hdd = Secondary IDE, Slave Device

After the device listing the partition number needs to be listed. This can be a bit tricky but I doubt if it is higher than 5 or 6.

Usually your hard drive to boot from is located as a "Master Device". None the less, you may need to try several boot options.

root=/dev/hda1
root=/dev/hda2
root=/dev/hda3
....
etc
.....
root=/dev/hdb1
root=/dev/hdb2
.....
etc
.....
root=/dev/hdd5


I hope that helps a bit.

If you need any further help, I'd be happy to give you a call or you can call me, so long as it's not out of the U.S.

Although I have learned a lot about linux, I am certainly no expert.

Sincerely,

Jeff
 
Old 06-28-2004, 05:29 PM   #30
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
I must say, that because of this type of crap that can't be fixed without a rescue disk some times, I am glad that I took the time recently to understand the grub syntax. I have fixed little typos like these simply by hitting "e" for edit at the menu. Its nice to have that bash-like prompt to fix stuff like that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic: No init found. (mandrake) corvus2 Linux - General 5 04-21-2004 09:08 AM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-18-2004 11:10 PM
kernel panic: no init found. Try passing init= option to kernel rroorroo Red Hat 7 03-07-2004 04:19 PM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 10:18 PM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 03:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 11:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration