LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Mandrake 10 Installation problems (https://www.linuxquestions.org/questions/mandriva-30/mandrake-10-installation-problems-197273/)

Stig 06-24-2004 02:31 PM

Mandrake 10 Installation problems
 
Please any help would be greatly appreciated. I am totally know to this whole Linux idea. I got hold of Mandrake 10.0 install disks (Hurray) And then try install it and it says hell no to me and won’t let me install.
I put the CD in and boot the CD all fine and good then I push enter to install and it scans USB etc but then it comes up with an error that says something like “could not uncompress 2nd stage ramdisk” And it suggests that there is a hardware error or an error with the kernel and at that point if I push alt f3 and look at the log thing the last couple of lines go something like

Trying to load /temp/image/mandrake/base/mdkinst_stage2.bz2 as ramdisk

Reading uncompressed ramdisk: data_error_magic

Unsetting automatic

From my understanding I think that there is a problem with the file system that the hard-drive is formatted in as it is FAT32 there is only one hard-drive connected as I can’t mess up the one that has xp so I disconnected that one. But please I know very little when it comes to Linux and I can’t for the life of me think how I can sort it out so please could some one help me

penguin4 06-24-2004 04:21 PM

stig; u did not say whether xp takes up all of hd if so then u may have to make that partition smaller on xp. altough linux is not a partition hog as W
but it does need some space which xp may have. ? size of hdd?

jct842 06-24-2004 08:45 PM

I now have 10 running, but it was the hardest linux install I have ever encountered. (I have done maybe 12 installs so far in almost 3 years) I was using a msi cd burner to read the disks I purchased. (both official and power pack) I kept getting errors using either set. The ram error rings a bell with me too. ended up with one install I could not log out of, could shut down but not log back in, got a text screen that indicated x server waiting to shut down, but never did. got no x, got as many as 7 errors where a file would not install on the first disk. I finally wiped it and installed 9.2 flawlessly, then upgraded it. then I actually had to put 10 in as an upgrade 4 more times on top of what was there already to get it all running. It may have been the cd drive, but it puts 9.2 in with out errors. the cds were download editions of official and power pack from 2 different sources. I do not trouble shoot, I reinstall. terrminals and command line cause my brain to smoke and my body to shake. I found a cd with a rpm for java and that went in flawlessly.

as far as I can see it, there is something very different with mdk 10 on the install. I want my linux to use, not to be fixing and improvising so that I can use it. John

Stig 06-25-2004 04:09 PM

The hard drive size is not a problem it is about a 40gb that has recently been formatted but what i think i am going to try is get copy from a local company that send the cd's and will try with that.

shapeshifter65 06-25-2004 08:38 PM

try disconecting all usb devices that aren't need for the install process - everything but your keyboard and mouse.

also, the fact that you have disconnected your primary hard drive may be contributing to the problem. in order to set up a duel boot system via the linux bootloader (LILO or GRUB) the system has to be able to locate the master boot record which is on your primary drive. obviously if the drive isn't conected this just ain't gonna happen. In addition the drive you disconnected was probably set as the "master" on that IDE controller. if that drive is disconnected and the new drive isn't set as "master" it ain't gonna work. i know its a bit scary but i would recommend that you reconnect your old drive, make sure it is set as "master", make sure the new drive is set as " slave" (assuming that they are on the same controller and your optical drive is on the other), and give her a go. if it works you will be asked early in the install process where you want to install linux and how you want to format your drives. this is where you will need to exercise some care not to accedently format the drive with xp on it.

good luck!

sbohning 06-28-2004 07:29 PM

Stig -

This probably won't help you, but FWIW, I received exactly the same message during a text mode install, except the log said "IO_ERROR" instead of "data_error_magic". I had booted from a floppy (because my machine is too old to be able to boot from CD), and the error occured very early in the install process, before even giving me the choice of language to use.

I installed to a FAT32 1.6 GB disk that I erased during this install; a second disk (slave) has Windows on it. (I didn't disconnect it since I knew I'd be able to specify drive to install on, and bootloader would get written to master disk, leaving slave undisturbed.) You do not state at what point your error occurred, but since mine was so early & before partitioning & formatting the hard drive, I suspect that the problem was not the drive.

Interestingly, I was allowed to proceed, and was able to complete the install, and have been able to run X & KDE, etc. but have not tried to install any other software. At least one problem, though, the "Mandrake Control Center", aka drakconf, was not installed, so I can't use KDE to change any aspect of my configuration; thi smay be unrealted to the error. Of course there is little documentation, so I not only have to figure out Linux, but also what Mandrake Linux thinks it's doing... It'd be nice if there was a list of error messages and what they mean somewhere, or some documentation about how to recover from failed installs. Maybe one has to pay for support to get that. Hours of fun await. I never had this problem with Mac or Windows...

- Scott B.

Stig 06-29-2004 02:30 AM

with my installation when it gives me the error that i said above and it then bombs out and will not go any further and tells me to re-boot etc

sbohning 06-29-2004 08:05 AM

Addendum to my previous post:

In addition to the log screen (alt-F3), there is the kernel message screen (alt-F4), which in my case showed what I think were a series of sector read errors for hdc. That would be a third hard drive, which I don't have, so I guess this was the RAM disk that is created & used during install. So maybe I have some bad RAM, or not enough RAM (only 96 MB) & the installer didn't properly check for that. (Though http://www.linux-mandrake.com/drakx/README (an old file?) says it checks for enough RAM.)

You might check for a similar error message, & run some hardware diagnostic program to check that all your RAM is working.

Good luck!

Another addendum: I was wrong, hdc is the CDROM. So maybe I just have a bad CD image (even though I was able to copy the mdkinst_stage2 file from the CD on another computer...).

So, you might try acquiring/making a new installation CD.

Stig 06-30-2004 04:07 AM

I am going to get a copy of cd 1 re-burned and if that still gives problems will get a new copy and then give it another base

KlaymenDK 06-30-2004 04:29 AM

I too have had this sort of problems, and for me the solution was to take out some of my menory, so I did the installation with 128Mb of RAM. Afterwards I put in the rest again. Maybe this will help you, maybe not.

Motown 06-30-2004 01:50 PM

I am having the same trouble with 10. I'm beggining to think that it's physically impossible for mandrake to produce a fully-functional release. That's a real shame, too, because mandrake is the best "easy" distro out there. I have a set of 3 cd's, and it won't boot. I get the "unable to decompress stage 2" or whatever. I had to burn a new copy, and now the first disk works. I don't think it's the cd burner, because I have used several different drives burning md10ce copies, and none of those worked, either.

jschiwal 06-30-2004 01:57 PM

I installed Mandrake Linux 10 by downloading the tree instead of the iso files, so I don't know if the rescue system is like the disk produced by the command mkrescue --iso. If it is, there is a menu option which analyzes your hardware and suggests kernel boot options you may want to try.

sbohning 07-01-2004 10:03 PM

FWIW, I had same 2nd stage ramdisk error message with new CD burned from an .iso image downloaded from a U. Delaware mirror; md5 sum was OK. So, problem was not my original CD being corrupt.

Maybe there's some incompatibility with my (rather old) CD drive, as kernel messages showed I/O errors reading a whole series of logical blocks.

In any case, I don't know enough to figure it out, or who to ask to figure it out, so I'm giving up on this distribution. I'll write it off to my old hardware being the problem.

From another thread it sounds like CD drive compatibility is a problem with this release.

penguin4 07-02-2004 03:08 PM

sbohning; before throwing in the towel, look at http://tldp.org/HOWTO/Hardware-HOWTO/index sections 17 subsections
17.1,17.2 ,17.3, 18, and 19. 17 & 18 on cd/cdrw n 19 dvd,s expand all

jjorloff1 07-31-2004 10:14 PM

I wrote this post somewhere else but theres more activity here and its the same problem
.................................................................................................... ..........................................................
Ok, I'm trying to install Mandrake 10 cuz my friend tells me how much more awesome than rh9 it is, but i come to an error, when it is trying to load the program into the computers memory. I am relatively sure its either my cdrom (which i doubt) or the cd its self (but my friend said it worked fine for him) the error i recieve after it says: loading program into memory is

-----------------| Error |---------------------
Could not uncompress second stage ramdisk. This
is probably an hardware error while reading the
data. (this may be caused by a hardware failure or a
linux kernel bug)

also i hit Alt-F4 so that i could see the system messages and there were a bunch (i dont think i saw them all cuz i cant scroll up) of errors that looked like this: (repeated)

<3>Bufer I/O error on device hdd, logical block 337826
<4>hdd: media error (bad sector): status=0x51 {DriveReady SeekComplete Error}
<4>hdd: media error (bad sector): error=0x34
<4>end_request: I/O error, dev hdd, sector 1351308

that is repeated multiple times with different blocks and sectors listed, but the status and error (status=0x51, error=0x34) to the best of my knowledge remains the same throughout.

hdd im pretty sure is my cdrom, which is why i am guessing its either a cdrom or cd failure.

If anyone knows the best method to fix this problem please tell me. Would it be easiest just to get a new cd or download mandrake 10 off the net?

Thank You
Selebus947
.................................................................................................... ...................

I did download the iso file from some mirror, and it has the same problem. . . and i really dont know what to do. . .I have found that my cdrom is fine. Also when i try to read the files on the cd in an operating system (win xp or red hat nine, probably any others) it seems it cant read any of the data besides the file names. I tried to run rawwrite.exe and stuff but windows popped the error that it was not a windows executable file.


All times are GMT -5. The time now is 09:40 PM.