LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Mandrake 10 hangs on KDE or Gnome start (https://www.linuxquestions.org/questions/mandriva-30/mandrake-10-hangs-on-kde-or-gnome-start-185164/)

Powerin 05-24-2004 07:04 AM

Mandrake 10 hangs on KDE or Gnome start
 
I have freshly installed (and reinstalled) Mandrake10. I'm having the similar problem to previous posts in that KDE hangs at the splash screen at 85%. I then tried GNOME which also hangs after the splash. The mouse still works at this stage and there is random disk activity, but I cannot Ctr-Alt-F* to a console and cannot Ctr-Alt-Backspace to restart X. This happens with root or normal user and doesn't matter if it is started from kdm or started from console with startx.

The hardware is old but ran Mandrake9.0 fine (and 8.2 for that matter) and also runs Win98, Lycoris, Knoppix CD and Lindows CD fine.

Anyone have any ideas? The only thing I can think of that both KDE and GNOME would do at this stage is try to activate sound (which seems to start OK earlier in the boot process). Can anyone tell me where to find KDE or GNOME logs?

P

Powerin 05-24-2004 07:32 AM

BTW.....just tried IceWM which starts OK

P.

ryeman 05-24-2004 07:33 AM

Try logging in under Linux_old (if you have upgraded from 9.0) this should boot into an older kernel. See if that helps. There may be a module that is hanging.

Look into your /var/logs (as root) for anything that looks to be hanging

Powerin 05-24-2004 07:58 AM

Thanks ryeman, but for once I did a fresh install, so no Linux_old.

Have checked every log I can think of in /var/log including messages, dmesg and Xfree86 and everything I can find in home directories. Have been using Linux since RH5.2 but this has me stumped (I have never asked for help before). I was keen to see how fast 2.6 kernel and KDE 3.2 work on older hardware. Oh well... :-(

P.

shoki_neu 05-24-2004 08:19 AM

are your X set to use 8-bit colors??? If that is so, I had the same problem.
The problem is, I believe, in Qt, or more precisely, in login screen written using qt.
Try setting your color to 15 bit. It solved my problem.

Powerin 05-24-2004 08:52 AM

Thanks shoki_neu, my colours were 24bit...but I tried 16bit as well.

P.


All times are GMT -5. The time now is 11:35 AM.