LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 07-18-2004, 05:41 AM   #16
munkie_poo
Member
 
Registered: Apr 2004
Location: Newcastle, UK
Distribution: Slackware 10.2
Posts: 134

Rep: Reputation: 15

I managed to power off

I read through some other posts about acpi, I knew that in mcc -> bootloader I had ticked acpi=enabled.

but I added " acpi=force" into lilo just out of curiosity, and what do you know....it worked, I now see all the programs shutting down.... halting system....and off

I edited lilo from the kde control center and added 'acpi=force' to the append line.

image=/boot/vmlinuz-2.6.3-7mdk
label="263-7"
root=/dev/hda5
initrd=/boot/initrd-2.6.3-7mdk.img
append="devfs=mount resume=/dev/hda6 acpi=force"
read-only


then ran 'lilo -v'

rebooted and shut down.
 
Old 07-18-2004, 06:17 AM   #17
chrono_legionai
LQ Newbie
 
Registered: Jul 2004
Posts: 14

Rep: Reputation: 0
hmn...thanks for the tip, I'll give it a shot now
 
Old 07-18-2004, 06:54 AM   #18
chrono_legionai
LQ Newbie
 
Registered: Jul 2004
Posts: 14

Rep: Reputation: 0
thanks mate, it works now
 
Old 07-18-2004, 07:15 AM   #19
chrono_legionai
LQ Newbie
 
Registered: Jul 2004
Posts: 14

Rep: Reputation: 0
One question, is the read-only part of the lilo.conf a must?
 
Old 07-18-2004, 07:25 AM   #20
munkie_poo
Member
 
Registered: Apr 2004
Location: Newcastle, UK
Distribution: Slackware 10.2
Posts: 134

Rep: Reputation: 15
Ive absolutly no idea, it was there already...

I think its for the /boot directory only ... and since I never write files to there it didnt bother me....

I might be totally wrong though.
 
Old 07-18-2004, 07:27 AM   #21
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
I know that two of these three lines are optional, because I added them from my 9.2 lilo.conf, but I dont remember which ones so cant be 100% that it's read-only.

read-only
optional
vga=788

Just wondering, do you guys not have the bootsplash screen, and instead just a lot of white on black text with the [OK]s in green?
 
Old 07-18-2004, 09:35 AM   #22
glennb0665
LQ Newbie
 
Registered: Sep 2003
Location: Virginia
Distribution: Ubuntu
Posts: 14

Rep: Reputation: 0
I'm setting up a Dell Inspiron 1000 laptop for my wife and I was having the same problem.

I found that when the graphical shutdown hangs, I can hit escape, then <CTRL><ALT><DEL> to force a reboot. When the reboot starts, I can then hit the power button to shut the system off.

My system hangs when it attempts to power down the system. I went through Control Center -> Boot -> Boot Loader and selected the "Enable ACPI" checkbox. The other ACPI checkboxes are not selected.

From www.acpi.info ...

Quote:
ACPI (Advanced Configuration and Power Interface) is an open industry specification co-developed by Hewlett-Packard, Intel, Microsoft, Phoenix, and Toshiba.

ACPI establishes industry-standard interfaces for OS-directed configuration and power management on laptops, desktops, and servers.

ACPI evolves the existing collection of power management BIOS code, Advanced Power Management (APM) application programming interfaces (APIs, PNPBIOS APIs, Multiprocessor Specification (MPS) tables and so on into a well-defined power management and configuration interface specification.

The specification enables new power management technology to evolve independently in operating systems and hardware while ensuring that they continue to work together.
I suspect the problem is between the kernel apm and the BIOS. Since there are several system BIOSs available, your specific settings will vary from system to system. This explains why some people have the problem while others don't.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Root User freezes on logout or shutdown grizzlyaka Linux - Laptop and Netbook 2 04-27-2005 08:20 AM
Mandrake 10.0 freezes during Shutdown GOPS Mandriva 1 09-15-2004 01:38 PM
Mandrake 10 freezes on shutdown breider565 Linux - Newbie 1 06-04-2004 08:48 PM
Linux Freezes at Shutdown Snabber Linux - General 1 07-08-2003 12:41 PM
System Shutdown/Reboot freezes ?? Zander Linux - General 1 12-07-2002 10:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration