-   Mandriva (
-   -   Mandrake 10 Freezes at Shutdown (

spaaarky21 06-27-2004 12:16 AM

Mandrake 10 Freezes at Shutdown
On Mandrake 10, with "launch the graphical environment when your system starts" disabled, Mandrake seems to completely freeze once I end my KDE session and try to "reboot" or "shutdown -h now". This never happens with the "launch the graphical environment..." option selected though. Has anybody else had this problem? With the exception of "just leave it enabled," does anyone have any idea how to fix this? My system specs are as follows:

-Pentium 4 w/ HyperThreading (one of my worst computer purchases to date)
-512 MB DDR400
-GeForce4 Ti4200 (latest nVidia drivers installed)
-NEC ND-2500A DVD burner
-Sony 24x/10x/40x CD-RW burner
-2x 60 GB Seagate hard drives (one with a Linux partition, Linux swap, and NTFS partition. The other with only NTFS.)
-SoundBlaster PCI512
-3Com 10/100/1000 ethernet
-3-port FireWire card
-Pinnacle AV/DV capture card (analog and FireWire in's and out's)

AndyX 06-27-2004 04:55 AM

That's interesting... On my Linux-Box I have the "launch the graphical environment when your system starts"-option enabled and my system freezes too at shutdown and reboot.
I'll try it the other way around (disabling the "launch the graphical environment when your system starts"-option) and see if my box keeps crashing or shuts down normally.

Did you upgrade from Mandrake 9.1 to Mandrake 10.0?
Because that's what I did. The system shut down normally with 9.1.

I'll report back soon...


AndyX 06-27-2004 05:23 AM

Allright. After turning off the "launch the graphical environment when your system starts"-option my system still freezes at logout.
What I found out is that it looks like the graphics card does no longer send any signals to the monitor (my monitor goes into standby the second I logout).

That's the hardware I use:
- Epox 8K5A2+
- AMD XP 2400
- 512 MB RAM
- ATi Radeon 9800 Pro (no other drivers than supplied with MDK 10.0)
- 40 GB Maxtor HD (Linux)
- 120 GB IBM HD (NTFS)
- NEC 2500A DVD Recorder
- Toshiba DVD Drive
- SB Audigy Soundcard
- 3 Port Firewire Card

Mandrake 10.0 is patched to the last level via the Update option in Mandrake Control Center.
KDE is started automatically, but no Autologin.

Maybe someone got an idea...? :rolleyes:

spaaarky21 06-27-2004 03:45 PM

No, I did not upgrade. My system has a clean Mandrake 10 install.

And I misspoke earlier. The system freezes when shutting down but not when rebooting.

So what exactly happens when things freeze up? I forgot to add that to my post. My computer goes to the blue Mandrake shutdown screen with the progress bar but freezes before the system makes any progress. In the past, I've waited a while to make sure that it's not just in the middle of a long process but nothing ever happens and I have to resort to pressing the power button. :mad: Pressing escape for verbose mode doesn't work either. It's pretty well locked up.

Oh, and by the way, what is the best command to use to shutdown a Linux machine when not logged in as root? In Slackware, I always just used "shutdown -h now" but that is not available in Mandrake unless you are logged in as root.

spaaarky21 06-27-2004 03:54 PM

And I couldn't help but notice that we both have similar FireWire cards and the same NEC DVD burner. Have either of these been known to cause problems with Mandrake in the past? I did a search for NEC 2500A but didn't find anything. FireWire maybe? Do you know what brand and chipset you FireWire card is?

AndyX 06-28-2004 02:10 PM

The NEC Burner and the Firewire Card caught my attention too, though I don't think that on of those is the source...
Unfortunately I don't have the time today, but I'll try removing the NEC Burner and also the Firewire Addon Card as soon as possible.
Maybe this helps...

For my part - I don't even get to the shutdown screen. The moment I click "Logout" or "Turn off" the monitor goes blank and into standby.
I also tried to enable and disable ACPI in the Mandrake Control center but that didn't help either.

About the command: I kept trying with "shutdown -h now" too after su => root.
Didn't help... same result... :(

My Firewire Card is pretty much noname... It says "OHCI Compliant IEEE 1394 Host Controller" but that's about it.

I hope I can give you an answer tomorrow.
Stay tuned!


AndyX 06-30-2004 12:38 AM

Okay, that's what I have found out so far:

o) I've installed all of the available drak-Updates available through Mandrake-Control-Center>Updates
o) disabled Autologin (startup into commandline)
o) start X via startx command
o) After "logout" the screen goes blank again and switches to standby, the monitor goes on again and I am on the commandline

After this logout there is an error message displayed concerning an older nVidia driver (I switched to ATi a while back - maybe after the upgrade to Mandrake 10.0 something got mixed up).
I'll try to remove it somehow - maybe the shutdown works clean then.

Btw. the "shutdown -h now" works fine now once I can drop to the commandline...


reidar094 07-15-2004 03:59 PM

Mandrake 10 Freezes at Startup and Shutdown
Did either of you figure out a resove to this issue?
I seem to be having a very similiar problem with my laptop.
After a clean install (and sucessful to my knowledge) I try to shutdown my computer, it all seems to go well until it goes to a blue screen (and my curser still is able to move around) and it will stay their for hours if i let it. I end up doing a hard shutdown, and try ti bring it back up again. It does that scan thing where the hard drive has not been cleanly shutdown, then i'tll restart again. Once it trys to go back into the KDE environment (it looks like it's sucessful) it will get to where it's almost done then just hang again. At the same place, blue screen and the curser is still able to move around.
I'm very much a Linux Newbie. I've probalby installed Linux a good dozen times the last 5 or so years. Some sucessful and some unsucessful. I've installed before RedHat, Debian, and Mandrake. Knoppix does work fine on this laptop (I heard word from that on the linux-on-laptop site) but I don't like how it runs off the CD.
I like Mandrakes install, it's slick, and it doesn't load so much crap on your machine that you don't like. I'm trying to get away from M$ (Microsoft) and i'm trying to get a workable solution for both myself and my company. Any help would be appreciated.

Sony VAIO PCG-FXA53 Laptop
Hitachi 30gig harddrive
ATI RAGE P/M Mobility AGP 2X
Digital Flat Panel (1024x768)
Realtek RTL8139(A) Fast Eithernet
D-LINK AirPlus DWL-650+ Wirless Eithernet
VIA AC'97 Sound Card
VIA USB contollers
and Firewire, but I'm not sure what it is.
I'm currently running dual OS. XP Home

spaaarky21 07-16-2004 03:24 AM

Re: Mandrake 10 Freezes at Startup and Shutdown
I didn't find a solution but lately Slackware has been all around unstable (freezes at shutdown, slow booting, weird behavior in GTK programs, crashes when right clicking on virtual desktops in the task bar, etc.) so I'm thinking about just starting all over now that I know more about the whole process - setup, configuration, etc. But, to answer your question, no I haven't found a solution. Herhaps AndyX has found a solution. However, I did notice that your laptop has FireWire. Me and AndyX both have FireWire. Kind of makes me wonder if there's a connection. But then again, FireWire is becoming so common now that it might be as much of a coincidence as the fact that we all have ethernet and USB. ;)


munkie_poo 07-17-2004 08:35 PM

I also have a similar problem to this. I used mandrake 9.2 and now use 10 offical. Reboot works fine, but halt/shutdown the screen flickers a bit and then freezes on a dark background, maybe blue (I'll have to verify and write back) with a white distorted box which seems to be the mouse cursor, then after a while its time to press the power button. When I press the power button though I get a split second glimpse of consoley type stuff, and can just manage to read something along the lines of 'powered down'.

Its such a trivial thing but I miss the computer not turning its self off. Both versions of mandrake did this.

My thoughts were it was something to do with my graphics card or kdm or something...........

ps. I didnt upgrade from 9.2 I installed from scratch, keeping my home directory.

PIII 600
256 MB PC100
40GB maxtor+ 4 GB seagate Hard drives
intel 815 mobo with diabled onboard sound +vga
Voodoo 3
S/blaster live
mitsumi cdrw
56k diamond supra

NO fire wire

Proud 07-18-2004 02:40 AM

Try Ctrl +Alt + F1 during the shutdown to see if you're not just looking at the remains of the X session on Ctrl + Alt +F7.

chrono_legionai 07-18-2004 03:19 AM

So does anyone have a solution to this? I have done some searching in the forum and most of the solutions are to do with acpi and I have changed the acpi setting in my lilo.conf to


still does not work. when I shut down and turn on the verbos mode, it gets to this Power Off and hangs, Caps Lock wont turn on the light, etc....

As the previous posts have said, it is able to reboot, shut down through MandrakeMove (I think it does, may need to varify), but freezes when I shut down through Mandrake 10.0.

And it is a clean install. One other thing, not sure if it is the same issue, I pressed the power off button to shut down my computer, but after about 5 -10 minutes, it turns itself back on again.

Any help is appreciated

munkie_poo 07-18-2004 04:46 AM

After shutting down I noticed that the screen is black with a distorted white box, not blue.

I tried the ctrl + alt + F1 thu F7 .... nothing at all.

like chrono said, caps lock and everything doesnt work either.

Does anyones mandrake shutdown? or is it just a select fews.

chrono_legionai 07-18-2004 05:24 AM

I am now downloading SUSE 9.1, if I can get this fixed, maybe I'll try out SUSE (it has been a tough choice for me and I picked Mandrake)...

Proud 07-18-2004 05:38 AM

FYI my Mdk 10 install has the X server start for me, and it shuts down fine. I think it's the minority with this problem. Hope you get it sorted.

Edit: Oh and I changed the Display Manager to KDM, from the MdkDM that's default.

All times are GMT -5. The time now is 01:11 PM.