-   Mandriva (
-   -   Mandrake 10 does not install bootloader (

rje_NC 03-07-2004 03:12 PM

Mandrake 10 does not install bootloader
I just finished downloading the new Mandrake 10 Community and I am having the same problem installing this that I had with the beta 2 version. When the installer goes to write my lilo.conf file, I get an error "mkinitrd failed" and nothing is written to the file. When I try to add the Linux boot entry manually on the next screen, I am presented all the prompts, but the file will not write to the disk.

I have the same problem no matter if I select lilo or grub as the bootloader. It appears that the mkinitrd program is bad?

Can anyone suggest how I could manuuly install the bootloader so I can see if I can get this distro booted. I tried booting with the resue disk and reinstalling the bootloader, but it also fails.



iainr 03-07-2004 04:17 PM

I had a similar problem (not sure if it was quite the same). I booted up from Damn Small Linux, did a chroot /mnt/hdax and was able to sort things out. Turns out the /boot/vmlinuz file wasn't correctly linked. Lilo failed because it couldn't see a valid kernel file. I manually linked it correctly and ran lilo; that seemed to do the trick.

jschiwal 03-07-2004 05:25 PM

At that phase of the install, press <ctrl><alt><f3>. Is there a message about losing interupts. If so try a different setting for acpi in the boot loader dialog. Might help. You could also boot up with the first disk in rescue mode. Mount your partitions on /mnt. Load the drivers. Then enter the console and "chroot /mnt". Try to execute lilo and see what the response is. If a particular part of lilo.conf is bad, or if there is a problem with one of the devices in lilo.conf, then lilo will not write the loader to the boot= device.

jschiwal 03-07-2004 05:35 PM

Sorry, I missed the later part of the question. I guess you already tried the CD1 Rescue system part.
You could go back into the rescue system, chroot as before and try the command "mkrescue --iso". You will need a way to burn the resulting rescue.iso file to cd. Manually running cdrecord from the console may do it, it enough of the system is install.
But if mkinitrd failed before, mkrescue may not work if there is no initrd file for it to grab.

Knowing why mkinitrd failed might be helpful in determining the problem.
You might want to supply the output of lspci or lspcidrake. Initrd contains a filesystem, saved as an image and compressed. It will contain modules that the kernel loads in when booting. Such as scsi drivers needed for the booting process to continue.

Knowing more about you system may help us get at the problem sooner.
Is there an initrd link in the /boot partition? Sometimes there is more than one. If you have more than one kernel installed, there will be one for each kernel version, it a symbolic link from /boot/initrd to the default initrd-<version>.

santigua 03-19-2004 12:03 PM

same here
I have the exact same problem.

install went FINE on a DELL Optiplex. PII 350//128MB ram.

But whent trying to install the server....
(Supermicro 370DER 2x1GHZ P3//512MB// 2400A IDE RAID) install seems to run through, one error tough at the beginning.... after accepting the license, it's complaining that the kernel module for aic7xxx cant beloaded... (assuming it's trying to enable the 2400a)

Anyway, when reaching the "install bootloader"-stage (lilo or grub) the exact same error message appears. "mkinitrd failed"

Any advice will be appreaciated...
Hope that helps in regards to get some more info on the machine specs.
If more is needed, let me know what and where to get it from. (since nothig is installed yet.)

thanx in advance

rje_NC 03-19-2004 11:34 PM

I have not found any answer at all on this.

At this point I am just giving up on Mandrake. This is junk when it cannot install properly on a very basic Athlon system that has installed RH, Fedora, Slackware, and SuSE ( a few challenges) with essentially no problems.

At least I won't have to spend to renew my Mandrake Club membership (what a waste)...


santigua 03-21-2004 12:18 PM

exact error from the log (alt+f3)
i just wrote down the exact error message from the log (alt+f3)

here we go:

"error: mkinitrd failed at /usr/bin/perl-install/ line 69"

maybe that is of any help for one of the cranks. I dont wanna give up so quickly, so I'll keep in touch.

PS: tryed already several things on the server:
- installing in text mode
- installing with the old kernel 2.4 (in text and graphical mode)

nothing helped. the erroro persists.

hopefully someone has an idea on what to do....


maiorino 04-07-2004 09:42 AM

I'm facing the very same problem of rje_NC and I get the very same error code reported by santigua.
My machine is an old Celeron 667 with 256 Mb RAM, Win98, 6Gb HDD free, and an Initio SCSI card (it was for a SCSI ZIP disk I don't use anymore).
I comment this out because, by looking on other forums, somebody points out it could be some problem with SCSI devices (although my SCSI device is correctly acknowledged during the bootup from the CD-ROM).
Somebody else is telling that there could be a problem in the first CD-ROM and one should start with the second CD, then use the first when asked to do so. Can anyone confirm this?
I have to say that I installed whatever distro in the past (Debian, RedHat, Slackware, Mandrake itself, you name it, from Linux 2.0) and OK, not all my peripherals were correctly acknowledged on the spot (Win printers by HP, ZIP drives, my motherboard is based on a SiS 630), but I always managed to have my Linux system running. Now, I simply cannot add my linux distro to the lilo bootup list. What the hell?
Interestingly, at boot up, lilo starts, but only allows me to go for Windows... too bad!
I won't give up neither: this Mandrake 10.0 distro seems to be very nice, and I don't want to miss it for a stupid configuration whatever!
Moreover, if we're quite a few persons facing the same problem, it's perhaps a serious bug, and it is good to make fuss around it!

rje_NC 04-07-2004 04:48 PM

I think I found the answer to this problem. On the computer I was having problems with, I removed the Tekram SCSI card that runs my old HP scanner. I then ran the installation program again and everything worked OK this time.

I think I can install MDK10 without the card and then install and configure the SCSI card and scanner after the initial install (I haven't tried this yet, the scanner is not that important to me).

The good news is that I was able to install the software. It seems that MDK is assuming a SCSI card is driving a hard drive and is trying to write to that first (just a guess on my part).


maiorino 04-13-2004 06:58 AM

I shall try!
More determined than ever!
These Easter holidays I spent three days in trying to get my linux system running, and something :mad: worked.
First, I reinstalled my old, 8.2 MDK, then I upgraded to 10.0.
What a surprise, here comes the error again (mkinitrd failed), but this time I was allowed to choose the 2.4.18 image and initrd (phew!).
Everything was fine (ar, at least, looked like so) but I wasn't able to start the Xserver correctly (SiS 630 graphical chipset on board and CORNEA LCD 17" monitor not acknowledged and out of sync... grrrr)!
Another upgrade (fake: 10.0 to 10.0) just in order to avoid Xserver to start automatically and set up X from the console.
No way! I'm using both drakconf and XF86configurator: the first one is giving me only headaches (doesn't work fine), while the second is correctly writing an XF86config file but... Xserver is using a darn XF86config-4 file :cry:
I want to try to rename XF86config to XF86config-4, I didn't do it before for two very good reasons: I didn't think this silly solution before AND I was supposed to be on holidays!
You know what? Mandrake Move can do eveything in a finger-snip: this is unfair! It correctly acknowledges, configures and uses my HP710C printer, my Initio 910 SCSI board, my SiS630 chipset, my Cornea CT1710 at 1280x1024, my CT83something audio card, my Canon LiDE 30 USB scanner, my Creative USB-radio wheel optical mouse, and I only have to say that I'm using a spanish keyboard... Why can't I have 10.0 as easy as Move? Just a running system as a base (because of course I believe that Move is not much more than that), then I'll fine tune-it later, but why I have with 10.0 problems I don't have with Move?
I'll go back to installing without the SCSI board and keep you informed.
:study: Marino

maiorino 04-13-2004 10:44 AM

Found out!
Finally I found on a mirror site ( is the filename) that mkinitrd was buggy. Here comes the comment about our bug:

%package mkinitrd
Updated: Thu Apr 08 09:40:48 2004
Importance: bugfix

A problem in mkinitrd would cause it to fail when devfs is not in use.
This problem, while still creating an initrd, would cause the system
to attempt to create device files if booted without devfs, which would
lead to segfault due to bug in dietlibc.

The updated packages have been patched to correct the problem.

Mkinitrd creates filesystem images for use as initial ramdisk (initrd)
images. These ramdisk images are often used to preload the block
device modules (SCSI or RAID) needed to access the root filesystem.

In other words, generic kernels can be built without drivers for any
SCSI adapters which load the SCSI driver as a module. Since the
kernel needs to read those modules, but in this case it isn't able to
address the SCSI adapter, an initial ramdisk is used. The initial
ramdisk is loaded by the operating system loader (normally LILO) and
is available to the kernel as soon as the ramdisk is loaded. The
ramdisk image loads the proper SCSI adapter and allows the kernel to
mount the root filesystem. The mkinitrd program creates such a
ramdisk using information found in the /etc/modules.conf file.

So, it's from April the 8th that a few things were fixed! This is impressive! Now I don't know what to do: download 9.2, upgrade to 10.0 and patch with the bugfixes or simply wait 10.0 Final (only a few days missing...)? I believe a mix of the two: download 9.2 and wait for 10.0 Final. But who knows: appetite grows by eating (as we say in Italy).;)
:study: Marino

santigua 04-13-2004 10:56 AM

interesting information
interesting information in deed.

actually I thought, well I desperately hoped, that the 10 final arrives soon and it'll be fixed.... ;)
But maybe we are able to find an updated packet somewhere....wouldn't itbe possible somehow to install with an updated packet?

Sorry if this sounds silly, but I do remember that the installer askes whether he shall check online (?) for updated packets...

wouldn't there be a workaround using this offer?

as already said..... "appetite grows by eating"

....and waiting for 10final takes longer and longer each day... :(

maiorino 04-19-2004 10:45 AM

MDK 10.0 Installed!
Sorry to resurrect an old thread, but something was left hanging here!
So, I finally made it! I took out the Initio 9something SCSI card and installed everything: it was really a breeze.
Everything is very responsive, I only have to solve the mixer issues in order to have the sound working, but I really cannot complain: I believe I'll go and subscribe for silver, I think it's worth doin'it!
Just for the sake of the complexity issues automatically solved:
I'm italian, but living in Spain, and my PC also features a spanish keyboard (so, first two languages), but for my job I want english to be used (so three languages) and also french and german are necessary every now and then and will be even more in the future (5 languages used and no prob for the distro to understand what keyboard layout or what language to use or what currency or what time format...)
I decided to go for a tricky thing: /root and swap on hdb; /usr and /home on hda. I decided to go for this solution in order to allow mechanical independence between the two HDD (perhaps faster swap access? Just a trucky trial!)
Creative USB optical cordless mouse with wheel acknowledged with no prob at all:D : that's a feat!
My CORNEA (Custom) LCD monitor 1280x1024 driven by my SiS 630 chipset works much better under XFree than with Windows98 with proper (i.e.: released by the manufacturer himself) drivers! I mean: I was really tired of my windows being dragged in pieces along the desktop, and now I got rid of this shit, thx MDK!
My USB CANON LiDE 30 scanner is perfectly acknowledged.
My USB port expansion bay (U know: one of those used to plug digital camera memory cards of every kind) is perfectly acknowledged.
The SCSI card I was using is not a main issue: I used it once upon a time to drive a SCSI ZIP drive, but that one died long ago, so...
So, right now I believe I have a rather powerful Celeron 667 machine with 256 Mb RAM and 8 Gb disk (14 Gb being left for Win98 unavoidable things: my beloved wife runs AutoCAD), and I want to unleash this power!

Greetings and thanks to LQ for your support!

cluebyfour 05-13-2004 04:09 PM

tekram install isue resolved
I managed to fix this problem (still present in mandrake 10 downloaded last week).

This is what I did:

1) start the install and get to the message mkinird failed
2) launch a console and mount the new root on mnt
mount /dev/hda3 /mnt/
make sure to put your partition in instead of 3 above
3) chroot /mnt
4) edit these files: /etc/modules.conf

#probeall scsi_hostadapter dc395x_trm
probeall scsi_hostadapter dc395x

#install scsi_hostadapter /sbin/modprobe dc395x_trm; /bin/true
install scsi_hostadapter /sbin/modprobe dc395x; /bin/true

now go back to the bootloader screen and it should allow you to go to the add screen
the available boot options will pop into the window and you can go on.

cluebyfour 05-13-2004 04:13 PM

update to last post
I tried installing the updated rpm referenced in a post above:
this did not fix the problem.

upen bug still not address today:

cgtueno 06-01-2004 12:24 AM

Tekram 305IE
Hi Guys

Linux Format Mandrake Community 10 3CD set

Dell Optiplex GX1 PIII 450
Tekram 305IE SCSI card

mkinitrd failure on install
system not bootable.

removed SCSI card

Install completes ok.
system now bootable.

Problem: starting up eth0 interface fails.

Note unit works ok with RH8.0 and RH9

Anyone know of a patch that will allow eth0 to work ?



cheors 06-08-2004 03:59 PM

I had the same problem "Mkinitrd failed" and solved it with the following actions :
- remove my Initio Scsi adapter
- completely reinstall the system (mandrake community 10)
- plug theScsi card in place and add line in 2 files :
In file /etc/modprobe.conf add :

install scsi_hostadapter /sbin/modprobe initio; /sbin/modprobe imm; /sbin/modprobe ppa; /bin/true
In file /etc/modules.conf add :

probeall scsi_hostadapter initio imm ppa

Now disks and scanner connected to this adapter are working fine.

May be this can help you.:)

cgtueno 06-08-2004 08:33 PM


The eth0 was an own goal problem !

I'll try yor suggestions when I get around to
setting the SCSI devices back up again.

I hope that Mandrake will fix the problem.
I hate pulling working machines apart just
to do an OS installation !

It is the 21st century after all.

There is word on the www that there is a CD
of Mandarake 10 Community ED patches.
Have you seen one ?



cheors 06-09-2004 03:27 PM

I got the Mkinitrd failed problem because of my Initio SCSI.
I removed this adapted and succeeded installing MDK 10 community.
To use my 2 scsi disk and my scanner later on, i added line in :
/etc/modules.conf :

probeall scsi_hostadapter initio imm ppa

in /etc/modprobe.conf :

install scsi_hostadapter /sbin/modprobe initio; /sbin/modprobe imm; /sbin/modprobe ppa; /bin/true

Everything worksd fine now


cgtueno 11-12-2004 02:05 AM

Hi Guys

I had the same problem.

MDK 10c correcly detected the presence of my
Tekram DC305 SCSI adapter, but the MDK
installer wouldn't write a boot loader to the HDD.

I stumbled across my solution out of frustration.
I pulled the card. The install worked ok.
Then I reinstalled the SCSI card.



All times are GMT -5. The time now is 02:33 AM.