LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Mandrake 10 Does Not Boot After Install (https://www.linuxquestions.org/questions/mandriva-30/mandrake-10-does-not-boot-after-install-255924/)

stpopoola 11-17-2004 06:52 AM

Mandrake 10 Does Not Boot After Install
 
I installed Mandrake 10 (Community Edition) on my AMD Desktop and my Laptop.

It installed smoothly on both but on reboot, the screen goes black on the laptop but on the desktop, the PC just restarts again.

Both Pcs are AMD. Does Mandrake have an issue with AMD that would not let it run? I have installed Redhat on my desktop and it ran without issues but i would love to install Mandrake.

Please help.

Thanks

My Laptop config

Hp Athlon Ze4400 AMD Athlon XP
Sound: Conexant AC-Link Audio
Display: Radeon IGP 320M
Modem: Conexant 56K ACLink Modem
Network: National Semiconductor Corp
HDD: 40GB
Memory 256MB
Processor: 2.2GHZ

Maintech 11-17-2004 10:09 AM

On most AMD computers you have to make sure ACPI is turned off. This has to be set in "boot" before the computer is re-booted for the first time. Also some AMD computers require that IPMI be installed. I have the joy of administering 3 AMD computers (no laptops though) and all require ACPI to be turned off. 2 require IPMI or they will not run.

opjose 11-17-2004 05:48 PM

Lack of ACPI support on Laptops is pretty bad news though, and even for desktop units causes Linux to be unable to handle IRQ and device routings.

The latter will mean user difficulty with installed devices which Linux may not be able to detect and initialize.

stpopoola 11-18-2004 01:26 AM

Thanks guys for your prompt response. I decided to install Mandrake 9.0 on my laptop and it installed and ran perfectly.

I need to understand how to turn ACPI off (I don't know how since I am a newbie). I still want to install Mandrake 10 on my desktop at home. I'd like to know what the IPMI is too and how this can be installed as adviced.

Thanks!

opjose 11-18-2004 04:02 AM

ACPI is turned off via a kernel parameter.

On 10.x kernels ACPI is set to HT

e.g.

ACPI=HT

Which effectively turns it off but leave some Hyperthreading support.

ACPI=OFF

turns it off altogether.

stpopoola 11-18-2004 06:43 AM

Sorry for troubling you further. How do I run a kernel command? Mandrake does not even load before it restarts. Do I do this via Grub? I need to do this and get back to you guys on the result.
Thanks!

opjose 11-18-2004 04:26 PM

You can specify this at the Lilo command line...

e.g.

vmlinuz acpi=ht

(Note my syntax is not correct...)

You will probably have to specify additional parameters as well.

Google....

cupples 11-19-2004 09:24 AM

Hi, I'm having exactly the same problem with my AMD setup. Mandrake 9.0 works, but 10.1 reboots, and goes to a black screen when trying to log in. Let me know if the ACPI fix works! I'm going to try it too, just as soon as work out how to do it...
Andrew

caladbolg 11-19-2004 03:31 PM

When you install mdk 10.0 or 10.1, make sure you choose to configure the boot loader and uncheck all of the boxes (ACPI, APIC) because I've toyed around with those checkboxes and found out (the long way) that having them all unchecked is the best.

opjose 11-19-2004 11:04 PM

For those watching, the above post applies only to those systems which have problems with ACPI and APIC support.

You REALLY do NOT want to disable ACPI if possible as this prevents a lot of things from working correctly, not the least of which is battery state detection on Laptops, and IRQ routing on both desktops and laptops.

cupples 11-20-2004 04:01 AM

Thanks caladbolg, that did the trick for me!
Andrew

caladbolg 11-20-2004 08:38 AM

You're welcome :)

And yes, I know turning off ACPI isn't recommended for laptops, but I have not figured out a way to boot the machine with ACPI on. I've recompiled the kernel as well to no avail. I run my laptop off AC so it's not a huge thing for me to puzzle out.

opjose 11-20-2004 08:51 AM

Yeah, that is a problem and all the more so because it seems that for some people the noacpi option seems to have not effect.

As if the kernel is disreguarding this parameter.

fleischi 11-23-2004 09:11 AM

Possible other boot Problems with mdk
 
Hello

Unfortunately there is more than just the acpi problem with Mandrakes default
kernel. In my experience there are actually others much
more important things than turning off acpi (which is not really a nice
idea with newer laptops since they usually have no working APM Bios
anymore).

Possible other solutions:

noapic (Has nothing to do with ACPI, it's just a similar abrev.)

pnpbios=off (This helps quite often, since in the early boot stage the bios is quite often called)

pci=biosirq (I sometimes had a hanging laptops after rebooting if this was not set)

Finally I often had problems with the - per default - activated virtual framebuffer in the
2.6 kernels from Mandrake. They always activated a special fb device for the
ATI Rage Mobility. This was leading to completely black displays, though the system was
booting. You just never saw anything on the screen. I always had to manually
switch back to the standard svga frame buffer for this card.
I have to admit that all this was neccerssary for 9.1 or 9.2 and the first 2.6 kernel
packages from Mandrake. I dont know wether it is similar for 10 but maybe it is.

opjose 11-23-2004 11:42 PM

The PCI=biosIRQ parameter is only needed if IRQ routing is not being properly handled.

The prime reason for needing this is if you have disabled ACPI which handles the IRQ routing.


All times are GMT -5. The time now is 06:04 PM.