LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 03-24-2004, 05:50 AM   #1
maddog
Member
 
Registered: Dec 2001
Location: Tasmania
Distribution: mandrake 10 community
Posts: 42

Rep: Reputation: 15
Mandrake 10 community and wine/winex problems


I hav erecently setup a box with mandrake 10 community release and so far I am very pleased with the distribution so far and am looking forward to the final release.
After the initial problems with network and ICS (now sorted out and working fine). I moved onto setting up my favorite games. First I installed point2play and winex3 they installed with out any errors or complaints. But when I go to install any games the computer just sits there like a stunned mullet. If I try to launch Gnome monitor to see what is running it wont launch.
If I try to stop winex via the point2play interface it crashes, if I try a console to kill it the console hangs. Then If I try a reboot the system hangs on shutting down smb and it just sits there.
I have got Savage to install (linux installer) and it runs fine. Quake3 (again Linux version) it launches but hangs on loading libGL.so which causes the console to become none responsive.
If I try to install something with wine it also has the same effect.
I am using the NVIDIA 5336 driver as earlier versions even though they install, glxinfo shows direct rendering =no where as the 5336 driver has it set to yes.
I have recieved back an e-mail from transgaiming and they are aware of some problems with winex and MDK 10, new version of alsa, kde 3.2 and the 2.6 kernel.
I have been and grabbed all the latest updates for mdk 10 and some problems have been fixed with my install like annoying squeeling from sound card (soundblaster live)
Has any one else experienced similar problems and if so have they been able to resolve them.
I am running the 2.4 kernel as I chose lsb on install. I really dont know what else to look at. Have been on MDK club forum looking for answers, and have been able to fix other problems. But it seems that at the moment on my system at least that wine and winex are pretty much broken.
 
Old 03-26-2004, 05:25 AM   #2
maddog
Member
 
Registered: Dec 2001
Location: Tasmania
Distribution: mandrake 10 community
Posts: 42

Original Poster
Rep: Reputation: 15
Quick update. Winex is still broke and so is wine. but I have several games running, Quake3, Savage, ut2004demo al Linux versions. The sound is horrible in all games, with significant lag in that area. So my system is capable of running 3D games.
 
Old 03-26-2004, 03:47 PM   #3
vr6stress
Member
 
Registered: Jan 2004
Location: Utah
Posts: 54

Rep: Reputation: 15
i had that exact same problem...

but don't ask me what i did to correct it, i beleive i said "N" to loading the windows registry (i have a dual boot with windows) ....

but i think i dropped the hard lock in the command line (but when i rebooted it would lock up smb)

and i actually had wine working right for a bit, but then i made changes to my fstab trying to do some sort of quiet mount....and haven't bothered with it since...

though i couldn't get the game to install i was trying (which gave me those vfat quiet mount things)

i'm gonna try crossover office i think...
 
Old 03-26-2004, 05:49 PM   #4
vi0lat0r
Member
 
Registered: Aug 2003
Location: Lewisville, TX
Distribution: Kubuntu
Posts: 295

Rep: Reputation: 30
1) Uninstall wine
(If it installed a fake windows in /home/YOUR USER ACCOUNT/.fake, be sure to delete the whole ".fake" directory. If it installed it in .c_drive, remove all the .c_drive (etc.)

2) In terminal, type:
$ urpmi xwine

3) It will say it needs xwine-BLAH and wine-BLAH
Choose Yes - install them

4) Install WineSetupTK (you will probably have to look on the internet - I am using version .74 I believe)

5) Go to Menu -> More Applications -> Emulators -> XWine
Click Start -> Parameters -> Wine Config -> WineSetupTK

6) Use the default directories it gives you

Everything should be up and working. Seems XWine has support for DirectX as I have been playing some DirectX 6 games (haven't installed any 8 or 9)

Last edited by vi0lat0r; 03-26-2004 at 05:50 PM.
 
Old 03-26-2004, 11:43 PM   #5
TuxLives
Member
 
Registered: Sep 2003
Location: Tacoma, WA
Distribution: Mandriva all the way
Posts: 145

Rep: Reputation: 15
Yeah, I had the sqealing too. Change your sound card driver until it stops.
 
Old 03-30-2004, 05:39 AM   #6
maddog
Member
 
Registered: Dec 2001
Location: Tasmania
Distribution: mandrake 10 community
Posts: 42

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by vi0lat0r
1) Uninstall wine
(If it installed a fake windows in /home/YOUR USER ACCOUNT/.fake, be sure to delete the whole ".fake" directory. If it installed it in .c_drive, remove all the .c_drive (etc.)

2) In terminal, type:
$ urpmi xwine

3) It will say it needs xwine-BLAH and wine-BLAH
Choose Yes - install them

4) Install WineSetupTK (you will probably have to look on the internet - I am using version .74 I believe)

5) Go to Menu -> More Applications -> Emulators -> XWine
Click Start -> Parameters -> Wine Config -> WineSetupTK

6) Use the default directories it gives you

Everything should be up and working. Seems XWine has support for DirectX as I have been playing some DirectX 6 games (haven't installed any 8 or 9)
hey Violator
Uninstalled wine and the directories it had created, when I did urpmi xwine it says "no packege named xwine" what repository would i need to add to get this package?

thanks for all your help so far.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with e2fsprogs library - Mandrake 10.1 Community Clived Mandriva 3 06-18-2005 10:12 AM
Dual boot problems with mandrake 10 community JoeBar301 Mandriva 0 09-08-2004 06:04 PM
wine/winex uninstalling problems IvanT Linux - Software 1 10-22-2003 07:30 AM
wine and winex problems jammers Linux - Software 4 08-25-2003 03:25 PM
Problems with WINE on Mandrake 9.1 Miyamoto Linux - Software 15 06-23-2003 10:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 10:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration