LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Mandrake 10 CE tinkers with BIOS (https://www.linuxquestions.org/questions/mandriva-30/mandrake-10-ce-tinkers-with-bios-185999/)

SoHum 05-26-2004 07:14 AM

Mandrake 10 CE tinkers with BIOS
 
Hi everybody!

So, the story.
I installed this "pretty looking baby" a couple of days ago.
Dreamt of trying a mandrake for quite a long by now.
I was going to dual boot with XP and the installation went quite
smoothly (as usually). I was pleasantly amazed at its speed (comparing
to my previous experience with Red Hat 9).
But after reboot (at 4 am) the moment of truth came.

I was presented with a text "menu" of boot options. It was "text"
to such an extent that I had to key in my choice - "mandrake" or "windows". My feeble attempt to give numbers was rejected outright.
I guessed and the guess was right that maybe something was wrong,
that maybe it wants to get access to things that are restricted. So,
I went to BIOS and disabled boot sector virus protection. After
this it became more friendly and LILO showed a nice looking menu
with blue colours.

It loaded very speedily and here we are - KDE.
Inet connection - modem (serial) detected but had to change the device,
with "dev/modem" it didn't work at all, yeah.
Sound (Live)- yes (XMMS froze: Inet says - remove "soundwrapper") - done.
Though I checked at install both Russian and English, it didn't want
to show filenames with Russian symbols, only (???), but I can type in OO with Russian. Will work on this later.

I was really thrilled that it worked, finally. Well, almost.

And the most funny thing - XP didn't boot. Only colourful squares
all around the screen. I had a look at its partition. It was intact.
So I went to bed.

The next day. Inet said - something was wrong in BIOS. Set LBA instead of
AUTO. I didn't take it seriously at first. Just gathered info about setting
boot up process in dual-boot config.

When I checked the BIOS though I was GREATLY surprised to find out
that my little compy (rock stable) had really tough times.
The settings for the hard drive in standard section of BIOS are so
that its size is slightly more than 2GB, though it is 40 in fact.
Not that much the difference but...

No LBA-AUTO issue at all though.

So, I get it right, checked the other settings - OK, set the boot sector virus protection back to enabled, save, reboot.
Again that already well known "text" boot menu.... after keying "windows" got coloured squares again. Back to BIOS. Standard section again corrupted. I wonder what mandrake wants from this poor BIOS again (BIOS lock option is ON!!!).
Why does it write to it again and again as though nothing more worthy to do.

IMHO that it's LILO problem.

As I see it now there are two options - try GRUB, or go for XP dual-boot
capabilities (there is the 3rd - kill XP. But this is a bit later, when I have Corel and Photoshop for Linux and probably DSL).

Or maybe there's a less intrusive way out. Could somebody give a hint, please.

And by the way. Had anybody tried VMWare for Linux with Corel/Photoshop? Will it work in MDK 10 CE.

SoHum


All times are GMT -5. The time now is 02:04 AM.