LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 08-17-2004, 11:16 PM   #1
ryland22
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Rep: Reputation: 0
Mandrake 10 can't connect to net


I have tried everything I can and can't get mandrake 10 to connect to the internet. I have a Linksys router connected to a cable modem, a soyo kv7me motherboard with onboard ethernet and I recently installed a linksys nic b/c I thought maybe mandrake wasn't working properly with the motherboard.

I have tried several different configurations and I'm stumped. When the computer initializes, it says eth0 fails. Everything else works fine. It fails under both the motherboard lan, and the linksys nic.

I'm running it under standard security. When I tried to run under linux-secure, it would say inetd failed.

During the install I setup my internet connection automatically detect dhcp settings, and did not assign a hostname. Can anybody help me?
 
Old 08-18-2004, 02:35 AM   #2
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,350

Rep: Reputation: 127Reputation: 127
Quote:
When the computer initializes, it says eth0 fails
Unfortunately, in Mandrake 10 you get this error even when the nic works fine but there's nothing in the other end. Really stupid (and one reason for why I'm leaving Mandrake).
Since you have 2 nic's, both don't work I believe it's a connection-problem.
Check the router: what IP-range is it using for DHCP? Let's say it's 192.168.1.0, router has 192.168.1.1.
Assign a valid static IP on your computer, like
#ifconfig eth0 192.168.1.10
then try to access internet.
Also check firewall in router.
 
Old 08-18-2004, 09:36 AM   #3
ryland22
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Mandrake 10 internet problem

No, it's not the router or the nic. I have three computers on the router, all work fine except for mandrake. I have win xp on another partition on this computer and it will connect to the internet through the onboard lan.

I did a search on this forum and found several posts where mandrake 10 users are having problems connecting to the net. I'm going to assume mandrake doesn't like my hardware.

I guess I can switch distro's unless anybody has suggestions.
 
Old 08-18-2004, 03:35 PM   #4
snt
Member
 
Registered: May 2004
Posts: 53

Rep: Reputation: 15
Try going to MCC, select Boot, then Boot loader. Check Force no APIC. Hit finish then next. Reboot.
 
Old 08-18-2004, 03:51 PM   #5
nat2k4us
LQ Newbie
 
Registered: Jul 2004
Posts: 11

Rep: Reputation: 0
I use a hub/switch connected to the mandrake pc to connect to internet.

I have a dynamic ip so I connect through PPPoe.

1.Go to network connections
2. Add new connection
3. Say LAN connecton and assign an ip (192.168.0.xx) to the mandrake PC.
4. Restart the network.

5. Go back to network and do a add connection again.
6. This time choose PPPoe(Or which ever is appropriate for you internet connection).
7. Enter ur user name and password for the connection.
8. Restart the network connections when prompted.

9. Open Network connections --> monitor connections.
10. Verify that both upstream and downstream are looking good.

This is how I set it up and it works for me
 
Old 11-19-2004, 11:43 PM   #6
Mateo1041
Member
 
Registered: Nov 2004
Location: New Prague, MN
Posts: 80

Rep: Reputation: 15
I'm a new Linux user of Mandrake 10.0 and here I thought it was just me having internet problems. Guess I'll be moving to Fedora or something else tomorrow. I've been working on my internet connection for three days now with no luck. Grrr...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hw to connect net on Mandrake 10.1 vishalsharmait Linux - Networking 5 10-23-2005 07:21 AM
hw to connect net on Mandrake 10.1 vishalsharmait Linux - Distributions 1 10-21-2005 12:55 PM
Cannot connect in net in Mandrake linux 9.0 cogeek Linux - Software 11 09-16-2004 03:52 AM
Can't connect to the net in Mandrake w/ VIA Rhine DannyW Linux - Networking 34 04-17-2004 02:41 AM
Can't connect to the net via speedtouch 330 under mandrake 9.2 Mint Sauce Linux - General 4 03-28-2004 06:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 10:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration