LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 12-07-2004, 03:11 PM   #1
smudge|lala
Member
 
Registered: Jan 2004
Location: New Zealand
Distribution: Mint | Sabayon
Posts: 155

Rep: Reputation: 15
Question Mandrake 10.1 Shutdown Problem


When shutting down my tuxbox the system never actually 'turns off'. I can't figure out why. I am running Mandrake 10.1 Community on a Sony PCG-581M Vaio Laptop (rather well I might add to anyone interested). Default is KDE 3.2. These are the final lines of the verbose shutdown:

Stuff.. [Ok]
Stuff.. [Ok]
Stuff.. [Ok]
Stuff.. [Ok]
Halting System... [Ok]
md: stopping all md devices.
md: md0 switched to read-only mode.
Shutdown: hda
Power down.
acpi_power_off called
_

('_' is the command prompt)

To turn off the laptop I have to press and hold the power button for a few seconds. Had this problem with an old SGI machine as well. This reads to me like everything has dis-mounted and halted. Do I need to add a script or something to finally power-down?
 
Old 12-07-2004, 03:53 PM   #2
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
I don't currently use a laptop, but I do know that Linux often is quirky on laptops.

You might want to look at the information on

http://www.linux-on-laptops.com/

where many makers of laptops are categorized, and your machine may well be discussed there.

If not, at least maybe you'll get a lead.
 
Old 12-07-2004, 03:57 PM   #3
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
hey, I have the same problem running 10.1 CE on my HP laptop. It hangs at "power off" and doesn't power off. I think there is a bug for 10.1 CE but I cannot find it.
 
Old 12-07-2004, 04:10 PM   #4
smudge|lala
Member
 
Registered: Jan 2004
Location: New Zealand
Distribution: Mint | Sabayon
Posts: 155

Original Poster
Rep: Reputation: 15
Thanks guys. See what I can find out and will post here. Don't think the power down on halt is harmful to the system, just a bit of a drag.

If you are using laptops, have you had any problem with media cards?

I have to login as root and mount sda1 located in /mnt/memory_stick. This is also a nuisance. Just wondered if anyone had had problems with this as well?
 
Old 12-08-2004, 07:44 AM   #5
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
I have had no problem with USB Flash drives. I plug it in, and I don't have to mess with fstab, it loads automatically into /mnt/removable. My flash drive is a SanDisk Mini Cruzer.
 
Old 12-08-2004, 02:43 PM   #6
shea1roh
Member
 
Registered: Jul 2003
Location: Grand Meadow MN
Distribution: Mandrake 2010.2 & Fedora 14
Posts: 99

Rep: Reputation: 17
My desktop does this as well except the 'Power Down' is the last line. I had MDK 9.2, 10 ce, 10 Official, which all shut my tower down just fine. This started with 10.1 ce & is still doing it in 10.1 Official.
 
Old 12-08-2004, 02:52 PM   #7
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
I googled this (found from www.linuxforums.org)

Quote:
I have this problem with my desktop. THe solution was to change the ACPI option in lilo.conf to ACPI=force. If you use ACPI rather then APM, this shouldn't be a problem, however I don't know how it would affect APM if you use that instead.
 
Old 12-08-2004, 03:15 PM   #8
caladbolg
Member
 
Registered: Jul 2004
Distribution: Mandrake 10.x, Fedora Core 3, Archlinux 0.7, Ubuntu 5.04
Posts: 303

Rep: Reputation: 31
ACPI is involved with turning off laptops. I've messed around with it on my Compaq Presario and it worked fine with mdk 10.0 official when I recompiled my kernel, but for 10.1 official, recompiling the kernel doesn't help at all. I have yet to figure out the problem, but don't be suprised if your laptop won't boot anymore.

I suggest you envoke ACPI though the lilo bootloader:
linux acpi=on
for example.

If your laptop doesn't boot, don't mess with ACPI any further or you'll probably end up reinstalling mandrake. Simply turning the machine off and then back on will reset the boot option and you'll be safe. If it does boot, try shutting down. If the laptop turns off, you can safely modify the boot options in lilo perminantly.
 
Old 12-08-2004, 03:29 PM   #9
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
ok, question. these cures all have to do with lilo. I'm running Grub.

I assume that I edit everything the same except in grub.conf instead of lilo.conf.
 
Old 12-09-2004, 06:17 PM   #10
caladbolg
Member
 
Registered: Jul 2004
Distribution: Mandrake 10.x, Fedora Core 3, Archlinux 0.7, Ubuntu 5.04
Posts: 303

Rep: Reputation: 31
Hit the escape key when grub comes up. (I think that works)

linux acpi=on
 
Old 12-10-2004, 06:34 AM   #11
smudge|lala
Member
 
Registered: Jan 2004
Location: New Zealand
Distribution: Mint | Sabayon
Posts: 155

Original Poster
Rep: Reputation: 15
Thanks for the input guys.

I have installed the same distro on 3 machines now and only my laptop still won't shut-off. I have checked and confimed that ACPI is enabled. Quite odd! Has anyone else had any success remedying this problem? I would not like to compile a new kernel because of one little thing like this. To be honest, I am so impressed with my Mandrake 10.1 on my Vaio PCG-Z1RSP laptop that I no longer have a dual boot. Simply everything works well, only the darn thing won't shut off!

#shutdown -h now --now I said now goddammit!
 
Old 12-10-2004, 10:43 AM   #12
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
read this thread. I haven't tried to mess around with my grub.conf, yet all the answers you need should be in this thread already.
 
Old 12-10-2004, 04:40 PM   #13
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
BTW: Sometimes the SMP kernels will have problems with ACPI functions and prevent a shutdown.

Also the system tries to unmount the file systems before it calls the halt process.

If something is maintaining open files then halt/poweroff never gets called.

I've seen instances wherein the user has configured the system in such a way that it was unmounting drives in the wrong order.

This caused a higher level drive to be unmounted first...

e.g.

/ - umounted first before

/var - which is a second drive or partiton that is mounted under root.

Of course this doesn't work so the shutdown proceedure barfs...
 
Old 12-10-2004, 06:13 PM   #14
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
Quote:
Originally posted by caladbolg
ACPI is involved with turning off laptops. I've messed around with it on my Compaq Presario and it worked fine with mdk 10.0 official when I recompiled my kernel, but for 10.1 official, recompiling the kernel doesn't help at all. I have yet to figure out the problem, but don't be suprised if your laptop won't boot anymore.

I suggest you envoke ACPI though the lilo bootloader:
linux acpi=on
for example.

If your laptop doesn't boot, don't mess with ACPI any further or you'll probably end up reinstalling mandrake. Simply turning the machine off and then back on will reset the boot option and you'll be safe. If it does boot, try shutting down. If the laptop turns off, you can safely modify the boot options in lilo perminantly.
thanks a ton!! that worked and now my linux box shuts down properly!!!!

(phew. editing ACPIwas the scariest thing I ever have done to a computer)
 
Old 12-10-2004, 07:22 PM   #15
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Rep: Reputation: 30
frustration upon frustration.

I changed acpi to on from ht, and my kernel defaults at =ht. I can change it to =on and it will shut down properly once. after that it resets itself back to =ht and once again refuses to shut down. (why didn't they turn acpi on in the first place if they knew the majority of Mandrake 10.1 users used laptops?)

How can I get acpi to always be on?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to shutdown on Mandrake 10? Spyiish Mandriva 13 11-09-2004 05:31 AM
Mandrake 10.0 freezes during Shutdown GOPS Mandriva 1 09-15-2004 01:38 PM
Mandrake 10 freezes on shutdown breider565 Linux - Newbie 1 06-04-2004 08:48 PM
Mandrake shutdown nudeatom Linux - Newbie 3 10-14-2003 10:51 AM
Mandrake 9.1 shutdown problem thumper Linux - Newbie 2 07-16-2003 10:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 03:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration