LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Mandrake 10.1 Internet Problem (https://www.linuxquestions.org/questions/mandriva-30/mandrake-10-1-internet-problem-263449/)

al_feth 12-14-2004 05:10 PM

Quote:

Originally posted by Junior41180
doesn't DSL usually require you to login to the network? ........ entered in my registry.
Yes, you're right about that. I logged in and configured the modem/router internet connection in WinXP Pro.

I don't know much about routers, maybe the user config is stored in the device, certainly the Linux OS won't be reading any data from the Windows registry.

The only internet configuration I needed for Mandrake 10.1 was to choose Cable Connection, and then the ethernet device - all other fields were left blank.

Alastair

romeonation 12-19-2004 11:01 PM

hey

I got the problem sorted. After a fresh install, all I had to do was choose "ADSL" type and choose PPPOE. After this step, the wizard automatically detects my Realtek etherned card and configures it.

After this step, on restarting, internet works fine. But, it works best only if I set both the network and the ADSL to start up on boot. Otherwise, i had to remove the eth0 connection everytime and add a new ADSL connection again, and then internet would work fine.

To fix this, i installed Shorewall from the distro, and it does a clean job.

Now this is my setup:
In the wizard for configuring network connections:
1. I chose ADSL
2. Then the wizard picked up the eth0 on its own. (I didn't have to fiddle with setting the IP address etc. I think it set the IP to 10.1.1.1 or something)
3. I set the ADSL and LAN to start up on boot
4. I set up Shorewall (a firewall)

Now, when my machine boots, and I enter KDE, internet wouldn't work, due to shorewall's default settings.

All I do to connect to the internet, is enter Konsole and enter:

>> su (login as superuser)
>> shorewall stop

now, I can connect to the internet cleanly. When Im done, I do this:

>> shorewall start


THAT's it!!!

Thanks for all your help:

PS: Configuring it as a CABLE connection wont work, as ADSL requires Login name and Password.

2. In another forum, some guy suggested that first the LAN is configured with IP etc... then add a new ADSL connection. THIS WAS WHAT SCREWED UP FROM MAKING ME CONNECT TO THE INTERNET. Dont do this.

If anyone has a similar issue, just go to control center and remove all existing connections. Then add a new connection and do the steps to add a new ADSL connection as mentioned above.

Thanks again.

Bye
Romeonation
India

jonny bravo 01-14-2005 09:51 AM

I had the same problem with fedora core. I could't connect to the Internet through a speedstream 5200 using the usb. I called my provider and they told me to try a ethernet card, and fedora picked it right up works great.

raysr 01-15-2005 12:23 AM

I set up my verizon DSL on XP and then went to my Mandrake 9.2 and it had already set itself up. It recognized the ethernet connection and was waiting for me when I got there!

PDR60 01-15-2005 10:25 PM

Quote:

Originally posted by Junior41180
doesn't DSL usually require you to login to the network? I know some DSL providers automatically connect, but that's because of a registry entry. I think cable does it the same way, because i have found my master email address entered in my registry.
Having buit a few dsl provider isp's I have a unique outlook. Most cable providers and some dsl providers use the mac address of their provided modem to authenticate to their network. The dsl pppoe is a protocol that uses a username and password to log you into their network. This is usually based on Radius entry and is mostly a hold over from the per/minute days of the internet. The combination of the two is what most up-to-date dsl providers use. This combined with your vpi/vci of your circuit identify your connection to the dsl network of your provider. The reason for the username/password combination is for accounting purposes mostly.

P.S. I have a Cable connection that is 6M down and 1.5 up. DSL can't touch that with any kind of reliability.

PDR60

hehbert 01-20-2005 09:43 AM

Hello everyone, I am here in need of some help for getting my adsl connection up and running. The distro that I am currently using is Mandrake 10.1 which I just installed last night. I am using INTEL's gigabit ethernet card with a SpeedStream 5200 router/external modem. It seems that mandrake has been able to identify the ethernet easily. I have used the "NETWORK AND INTERNET" configuration options with no avail. I have provided hostname, dns servers, etc... but my computer just won't connect. Whenever I try the connection and I stare at the SpeedStream router/external modem I do not see any lights blinking. Now I've done some research and have found that Mandrake 10.1 should be able to connect fairly easily even with the hardware that I am using, therefore I know that they aren't the problem. What I believe is that it might have something to do with the settings, but like I said I have tried to configure with no avail. Will someone please share me their expertise? Do I need to set the default gateway box to the IP address of my modem or what?

PLS provide me with some answers and thank you in advance. =)

hehbert 01-20-2005 03:10 PM

One small mistake... I am actually using INTEL's Pro 1000 MT NIC, which is still compatible with Mandrake 10.1

hehbert 01-20-2005 03:27 PM

Oh and I just found out that my external adsl modem: SpeedStream 5200, is not originally a router, but can be turned into one by simple firmware. I am hoping that I won't have to do this so please if someone can tell me what to do to get my internet up and working in linux, do tell.

romeonation 02-03-2005 08:06 AM

Hey HEBBERT!!!!

Please follow the steps I have mentioned above explaining the steps you need to do to setup your ADSL internet connection on Mandrake. It worked for me on Mandrake 10.0 and should work on your Mandrake 10.1 I guess.
Just to re-explain to you:
1. Remove whatever internet connections you already have configured using the Mandrake control center ->> Network and internet
2. Then Add a new connection => Choose your type as ADSL...follow the wizard that follows...dont enter any value you dont know...eg..DNS name or anything.
3. The interface over which this ADSL is to be used must be selected. In your case, the ethernet interface...eg.. eth0 will be shown.you should select it.

Good luck.
Just try it a few times. You will get it working definitely.
=Romeonation


All times are GMT -5. The time now is 03:46 AM.