-   Mandriva (
-   -   Mandrake 10.1 and WinXP NTFS Partition (

Mr. Kinky 10-13-2004 02:41 PM

Mandrake 10.1 and WinXP NTFS Partition
Okey, this is my problem.

I have:
* Mandrake 10.1 Community
* A 160 gig HD with only Linux on it
* A 80 gig HD with only Windows XP on it in a removable bracket

The 80 HD is from school, with 2 partitions (2x 40 gig). It's in a removable bracket because I also have to use that HD at school. It's using NTFS.

The problem:

I can't read the 2 WinXP NTFS partitons in Mandrake.

Can somebody please help me?

NOTE: I'm a newbie in Linux

Micro420 10-13-2004 03:04 PM

so if you type


ls /mnt/windows
Nothing happens?

Gary987 10-14-2004 09:46 PM

Mandrake is a beginner distro, and may not have support for NTFS in the kernel...
If you do manage to recompile the kernel to supprot NTFS... please note that WRITING to an NTFS filesytem is still EXPERIMENTAL..

If you need to write to your XP partitions... why not change them to fat32 partions?
Microsoft probably doesn't want you to know... that Windows XP has no problem running on the win98 partition format.

Hope the following link will help?!




cranky 10-14-2004 10:41 PM

just create a small FAT32 partition on the removable and swap files around using that :)

opjose 10-15-2004 04:07 AM

Out of the box Linux can READ NTFS partitions but it cannot write to them.

If you want to be able to read and write safely check this out:

It's truely amazing, in that it utilizes Windows XP or 2000's own drivers in LINUX to provide safe access to your NTFS partitions.

I've moved huge files back and forth without problems and even performed diagnostics on Windows XP drives with this.

Note: You'll need access to either the XP install CD or a partition onto which XP is installed.

The installation mounts the NTFS drive in read only mode then looks for the Windows NTFS drivers.

It copies them into Linux and utilizes them to provide access from there on, to your NTFS partition.

Great stuff!

Mr. Kinky 10-15-2004 07:34 AM

Okey, i have now the 2 NTFS partitions mounted. Still, it's stupid I didn't look further then my nose but okey.

There was a option in the Mandrake config centre (translation from dutch) to mount the partitions. I also have a extern USB HD bracket with a partition with NTFS. That is also mounted with no problems.

But then, a other problem. I can't acces the partitions with my normal users account. I do can read and write with the root account. I just can't set my user permissions to those partitions. I tried and tried, but I can't fixed it.

So can anybody help me with this problem? I already tryed information from the internet but no go for me.

BTW: After one week I already say: Linux is better than Windows... Byebye Blue Screens!

BTW: Thanks for the help people!!!

opjose 10-15-2004 08:12 AM

Go back into the Mandrake Control Center as root.

In there at the place you created the mount points, there is an advanced tab.

Turn on "Advanced Options"

Now you'll be given a check mark option to permit users to mount the volume.

There is also another one to prevent the volume/partition from being mounted automatically, which you'll probably want to use.

mjjzf 10-15-2004 09:14 AM

Also, whereas other systems mount Windows partitions at /mnt/windows/ or the like, Mandrake has placed it at /windows/ on my system. I could access it as user from the start.

All times are GMT -5. The time now is 06:06 AM.