LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Mandrake 10.0 "Freezes" (https://www.linuxquestions.org/questions/mandriva-30/mandrake-10-0-freezes-193486/)

UmneyDurak 06-14-2004 04:06 PM

Mandrake 10.0 "Freezes"
 
Hi.
Whenever I try to use Mandrake Control Pannel it freezes. What I mean by that is my mouse will freeze, the window will stop responding, and if I close it and open another one it freezes too. The rest of the programs seem uneffected. After that happens I can't shut down my computer. It goes to black screen with cursor still visible and just hangs there.
Relevant info I think:
I had to install in text mode because it would freeze in gui, I had to restart computer during setup. After I installed all the packages and was configuring it, I made a mistake of trying to change resolution and clicked on Test. It froze.
My Specs:
1.33 GHZ Athlon T-bird, PC2100 RAM 512 MB, Nvidia gforce 2 ultra (Unhialator 2 ultra), ASUS A7M266 MB with 1005 bios. Two HD 20 gig and 80 GIG with win98se on both. I have Explorer 3.0 USB Mouse.
Also I did manage to configure the mouse as someone sudgested. I selected Explorer mouse from the list.
I'm Linux niewby, but when I used Mandrake 8.1 I had less problems then with 10.0. :(

Any help would be greatly appreciated.
Thx.

jschiwal 06-14-2004 05:13 PM

One thing worth trying is creating a rescue cd and booting to it. There is a dianostic script that makes suggestions on which booting options may be neccesary for your system. You can create a rescue cd with the command "mkrescue --iso" and then burn the disk to cd.

UmneyDurak 06-14-2004 07:00 PM

Ok. I booted up from rescue there were two diagnostics programs.
I ran the first one and it sudjested running lilo with "'lba32' global option or -L ". What exactly does that mean?
I ran the second diagnostic tool and it just tested memory and registers, wasn't sure what to look for there.

Could the nvidia drivers cause the freezing of the control pannel?
Thx.

jschiwal 06-15-2004 04:14 AM

LBA stands for Logical Block Address. It is used for larger drives. I'm not sure if it would be the video driver, but you could try downloading and installing a new driver from Nvidia.
I was expecting the diagnostic program to suggest something like a apci= or noapic option.

Try the LBA32 option. If it can't read from the drive above a certain address for example, KDE may stall because it can't update some file.

UmneyDurak 06-15-2004 12:43 PM

Where do I go to add this option? I remember modifying lilo config file long time ago, but I don't think thats where I should add it.
Thx.

otish1000c 06-15-2004 04:01 PM

since you're using the Nvidia drivers, especially witha geforce board, try adding the following option Option "NvAGP" "1" under the device section of your xf86config-4 file. here's what mine looks like..........

Code:

Section "Device"
    Identifier "device1"
    VendorName "NVidia"
    BoardName "NVIDIA GeForce4 (generic)"
    Driver "nvidia"
  Option "NvAGP" "1"
    Option "NoLogo" "1"
    Option "DPMS"
EndSection

the "1" tells it to use nvidia's agp module. other options you can use are..........

"0" (disables all agp)
"2" (uses the kernel agpgart)
"3" (tries kernel agpgart first, the tries nvidia agp if that fails)

i had random freezing probs with a geforceti4600 board & the "1" option fixed it.

otis

UmneyDurak 06-16-2004 12:16 PM

I can't find that file. All I found is xf86config in /usr/X11R6/bin, which is an executable
I also found and archive file, and a compressed file.

otish1000c 06-16-2004 12:53 PM

Quote:

I can't find that file. All I found is xf86config in /usr/X11R6/bin, which is an executable
I also found and archive file, and a compressed file.
the file is in /etc/x11/........... xf86config-4. it's a config file (text). but, before you edit that, did you indeed install the nvidia drivers? i was under the assumption you did, but after rereading your earlier post, i'm not sure now. if you did already install the nvidia drivers, then proceed with editing your xf86config-4 file as i suggested. if you haven't installed the nvidia drivers, then do so first. instructions to install them can be found in my post HERE

otis

UmneyDurak 06-16-2004 01:48 PM

I didn't install them explicitly, but I thought they were installed during the install.
this is what I have under xf86config-4
Code:


Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nv"
    Option "DPMS"
EndSection

Do I still need to install the drivers? Looks to me like they are already installed.
Also you said I need to have a kernel code installed. How can I check if I do or not?
Also I have load "glx" in module, but it's commented out.
Thx.

otish1000c 06-16-2004 01:59 PM

yes, you need to install the nividia drivers. go to that link i put in my last post for where to get them & follow my instructions on how to install. DO NOT edit your xf86config-4 file until you install the drivers. the "nv" driver listed in that file right now is the generic linux driver for nvidia, without the full acceleration or agp capabilities. the official nvidia drivers are not part of the MDK installation, nor are they on the MDK CD's.

otis

otish1000c 06-16-2004 02:14 PM

sorry. didn't answer your question about the kernel source. look in your /usr/src directory. there should be a directory called linux-2.X.X (X=kernel version number). if you have that, you have the kernel source. if you don't, use MCC->software installer, type kernel in the search, get the kernel-source that matches your kernel version. if you don't know what kernel version you are running, in terminal as root type uname -a, hit enter. that will tell you.

otis

UmneyDurak 06-16-2004 06:19 PM

OK... I installed the source code, upgraded the driver and changed the xf86config-4
I have couple of questions.
One I installed another kernel by accident. It's same version but I guess it's for greater then 1 gig of memory. 2.6.3-7-i686-up-4gb.
It added as another option in lilo when I boot.
Also now it only boots to text mode, even thought the default run level is set to 5. It even says INIT Entering runlevel 5, when it boots. I checked /etc/inittab, and it still has id:5:initdefault:
Above where it asks for login and password it says
"Linux release 10.0 (Official) for i586
kernel 2.6.3-7mdk-up-4gb on an i686"
Just how badly did I messed up my linux installation? :(
How can I fix this.
P.S. It boots to same kernel when I select linux and up-4gb one during startup.
Thx.

otish1000c 06-16-2004 06:32 PM

the kerenl needs to match the source, & vice versa. the up4gb-i686 kernel is not what you want. here's what you need to do.........

when it boots in text mode & drops you at the login prompt, type your user name to login, hit enter.
type your password, hit enter. type su (to get you to root), hit enter. type password, hit enter. type..........

urpmi kernel

hit enter

choose the 2.6.X kernel that's on your discs. (it should be the only 2.6 kernel available). "y" to install it. do urpmi kernel again (enter). get the kernel-source that matches the kernel you just installed. after that's done. type lilo -v (enter). that will put you back to the stock MDK10.0 kernel & source. type reboot (enter). then choose "failsafe" & proceed with the nvidia installation.

EDIT: also, please post your xf86config-4 file if you have any more troubles. to do so from a login prompt, as root type

cat /etc/X11/XF86Config-4 (enter) (it's Cap SensiTIve)

right click->copy->paste

otis

UmneyDurak 06-16-2004 11:05 PM

Well tried that after urpmi kernel it displayed 3 kernels
1. kernel-2.6.3.7mdk-1-1mdk.i586
2. kernel-i686-up-4gb-2.6.3.7mdk-1-1mdk.i586
3. kernel-2.4....
Selected the first one and got the messege saying everything is already installed.

otish1000c 06-17-2004 03:50 AM

please do the following...........

urpmi kernel-source

that will get you the sources if you don't have them installed.

please post the contents of XF86Config-4 & lsmod.

otis


All times are GMT -5. The time now is 01:06 AM.