Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.


  Search this Thread
Old 12-23-2006, 01:34 PM   #1
LQ Newbie
Registered: Nov 2006
Posts: 5

Rep: Reputation: 0
Exclamation Mand. 2007: Screen found but none have usable config; fatal error


I run a PC with ECS Mainboard K7SEM and chipset SIS730S for video. PC is a Duron 1,8MHZ , 768Mb of RAM

Installing many times the last 2007 version of Mandriva (full pack), I end up with a screen freeze.

In the display configuration, there is only SIS630 as a choice, not SIS730S. So that's what I used; I tried also other configs / resolutions of screens but with no success.

When starting KDE or StartX, I am getting:
Error given color depth (15) is not supported by this driver. Screen found but none have a usable configuration. Fatal server no screen found.
Xwindows 7.1.1 Xprotocole version 11
Operating linux 2.6.17-4mdv i686

I also tried to install with and without ACPI, without success. By the way what is ACPI ?

MAny thanks in advance for your time !
Old 12-23-2006, 02:01 PM   #2
Registered: Oct 2002
Location: Miami, FL
Distribution: Ubuntu
Posts: 184

Rep: Reputation: 30
Please post your xorg.conf so I can check it.
Old 12-23-2006, 05:20 PM   #3
LQ Newbie
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0
This is the file requested:
# File generated by XFdrake (rev 57713)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# font server independent of the X server to render fonts.
FontPath "unix/:-1"

# minimal fonts to allow X to run without xfs
FontPath "/usr/share/fonts/misc:unscaled"

Section "Extensions"
Option "Composite"

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "ca"
Option "XkbOptions" "compose:rwin"

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"

Section "Monitor"
Identifier "monitor1"
VendorName "Daytek"
ModelName "Daytek DT-1531D"
HorizSync 30.0-70.0
VertRefresh 50.0-120.0

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

Section "Device"
Identifier "device1"
VendorName "Silicon Integrated Systems [SiS]"
BoardName "SiS 630"
Driver "sis"
Option "DPMS"

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 8

Subsection "Display"
Depth 8
Modes "640x480" "480x360" "320x240"

Subsection "Display"
Depth 15
Modes "640x480" "480x360" "320x240"

Subsection "Display"
Depth 16
Modes "640x480" "480x360" "320x240"

Subsection "Display"
Depth 24
Modes "640x480" "480x360" "320x240"

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"

Thank you for your help
Old 12-23-2006, 07:42 PM   #4
LQ Guru
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Try configuring the graphics card manually using the xorgconfig command.
Old 12-24-2006, 11:37 AM   #5
LQ Newbie
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you for info; didn't help but I found out that the Xwindows library for display (SIS630/730) provided by Mandriva is not correct and dated May 2006. The name of this library is and can be found in /usr/lib/xorg/modules/drivers. It should be replaced by a new version compatible with Xwindows 7.1.1 and can be found on the site (redirection). This version of binary file is dated as August 2006. I did it and it solved the problem; KDE could appear finally. The SIS company was bought by another company and does not support drivers for XWin.
Hope it can help others, since it took me quite a while to figure out , as a novice Linux adept. Merry Xmas and Xwindows !


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fatal Server error: no screen found!!! AzNsnake666 Linux - Newbie 2 01-30-2006 12:17 AM
Fatal server error: No Screen found prasath Linux - Enterprise 7 05-11-2005 12:39 PM
fatal error : NO SCREEN FOUND kaly182 Slackware 22 10-21-2004 12:50 PM
Fatal server error: No screen found hakiko Linux - Newbie 1 03-09-2004 02:05 PM

All times are GMT -5. The time now is 06:47 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration