-   Mandriva (
-   -   Make Mandrake use a different drive for installing packages (

Foxy 07-17-2004 08:00 AM

Make Mandrake use a different drive for installing packages

My DVD drive doesn't like Mandrake, so installed it with my CD-RW drive instead. But when Mandrake wants to install packages it doesn't give me the option of using another drive.

So, how can I tell it to use the CD-RW drive as standard? It's very annoying not being able to install packages because of my DVD drive. (Last time I buy an Aopen, that's for sure.

Also: Why won't the file browsers display the .cda files on an audio CD? When I look at the /cdrom contents it's just blank when an audio CD is in the drive. Data CDs work fine, so what's the problem? (The CD is not at fault, since ksCD comes up and plays the CD perfectly when I put it in the drive).

doug_s 07-17-2004 01:14 PM

It's probably the same problem as this.

If you need more help post your /etc/fstab and /etc/urpmi/urpmi.cfg files

Foxy 07-18-2004 12:12 PM

Thanks for the guidance, but I don't think it is the same problem.

I have succeeded in getting urpmi at least to use my CD-RW instead of my DVD-Drive by editing /etc/urpmi/urpmi.cfg. I replaced all refences to 'cdrom' with 'cdrom2'. This worked! Urpmi ejected the right drive and requested the disc on 'hdd' (which is correct). But it still won't read the disc. I put it in and press enter as requested, but it just ejects the disc and tells me to put the disc in! I've made sure I waited until the drive finished doing it's initial spin-process.

Now I've got a bigger problem: CDs won't read at all, from either drive! If I put a CD-R, or a commercial disc in either drive and browse to them in Konqueror I get a blank screen. I did swap round hdd and hdc in fstab earlier, but I swapped them back, restored the edit back again (dumn) and then finally put it back as it was. I don't know if this would have affected it. The only other thing of mention is that I did mount -a while trying to get urpmi to read the Installation disc (I thought maybe the drive wasn't mounted). (I did this in a seperate Konsole instance/session mind). I have restarted since then and tried again: same problem: blank screen in Konqueror.

Files: fstab:

/dev/hda5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,exec,--,umask=0,user,iocharset=iso8859-15,codepage=850,noauto 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,exec,--,umask=0,user,iocharset=iso8859-15,codepage=850,noauto 0 0
none /mnt/floppy supermount dev=/dev/hdb,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
/dev/hda1 /mnt/windows vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda7 /usr ext3 defaults 1 2
/dev/hda6 swap swap defaults 0 0

File: /etc/urpmi/urpmi.cfg:

Installation\ CD\ 1\ (x86)\ (cdrom1) removable://mnt/cdrom2/Mandrake/RPMS {
  hdlist: hdlist.Installation CD 1 (x86) (cdrom1).cz
  with_hdlist: ../../Mandrake/base/
  key-ids: 70771ff3
  removable: /dev/cdrom2

Installation\ CD\ 2\ (x86)\ (cdrom2) removable://mnt/cdrom2/Mandrake/RPMS2 {
  hdlist: hdlist.Installation CD 2 (x86) (cdrom2).cz
  with_hdlist: ../../Mandrake/base/
  key-ids: 70771ff3
  removable: /dev/cdrom2

Installation\ CD\ 3\ (x86)\ (cdrom3) removable://mnt/cdrom2/Mandrake/RPMS3 {
  hdlist: hdlist.Installation CD 3 (x86) (cdrom3).cz
  with_hdlist: ../../Mandrake/base/
  key-ids: 70771ff3
  removable: /dev/cdrom2

Installation\ CD\ 4\ (x86)\ (cdrom4) removable://mnt/cdrom2/Mandrake/RPMS4 {
  hdlist: hdlist.Installation CD 4 (x86) (cdrom4).cz
  with_hdlist: ../../Mandrake/base/
  key-ids: 70771ff3
  removable: /dev/cdrom2

(You can see where I changed cdrom to cdrom 2 in urpmi.cfg).

Can anyone offer any guidance as to what do next to try and fix this problem?

doug_s 07-18-2004 12:50 PM

Try using urpmi.removemedia -a followed by urpmi.addmedia with appropriate parameters. The reason for this is that urpmi uses more than just urpmi.cfg, for example, the files in /var/lib/urpmi (the hdlists) may need to be updated too.

For your other problem, what worked for me was to get rid of supermount and magicdev and just do things the old fashioned way. You need to manually mount and configure stuff like xine and grip on your own but it works and its very consistent. If you really want automatic mounting like in windows maybe someone else has some ideas.

reddazz 07-18-2004 01:30 PM

If you use Mandrake Control Center, you can delete your package sources and then put your insallation media in the drive you want to use and then create new sources and urpmi will as for the path of the source and just point it to the right folder e.g. If your cdrw is in /mnt/cdrom 2, point urpmi to that path and hdlists and you system should now use the drive that you want to be your default for installing packages.

XJNick 07-18-2004 02:25 PM


You can use the software media manager (under system > configuration > packaging) to edit the paths of the installation cds. So you could change the paths for the CDs from /mnt/cdrom to /mnt/cdrom2 to switch CD drives. :D


Foxy 07-19-2004 12:13 PM

Thanks. After getting supermount to seemingly work again I tried editing the packages in Mandrake CC, and it didn't like certain discs for some reason. (Can't remember exactly which). So I torched all the entries and started adding them again. It was fine with CD 3 and 4, but with CD 1 and 2 it complains again... (sigh)...:


Errors encountered:
No RPM files found from [/mnt/cdrom2]
No hdlist file found for medium "Installation CD X (x86) (cdromX)"
Problem reading synthesis file of medium "Installation CD X (x86) (cdromX)"

Using different names for the disc makes no difference.

I can read the discs fine in Windows, so they themselves are not at fault.

If I try with a relative path set manually (Mandrake/RPM) I get the following error instead (joy!):

Unable to access medium "Installation CD X (x86) (cdromX)".

 this could be because you mounted manually the directory when creating the medium


I can't read the two Install CDs in Konqueror either. I get a blank screen. If I try another CD (Halo CD :P) I get taken to the 'Goodies' subdir on the CD for some strange reason. :confused:

I tried also to 'urpmi kernel' after this and got the following:

umount: [/mnt/cdrom2] device is busy
umount: [/mnt/cdrom2] device is busy
Please insert "Installation CD 4      " on device /a/long/systemish/thing/including/ide0/or/something

(Note: "Installation CD 4 " is roughly what it said. It DID NOT say the full "Installation CD 4 (x86) (cdrom4)")

I put in the CD as requested, and it started installing a strange kernel version (aaaargh!) When I rebooted a weird kernel version appeared in LILO, so I guess it succeeded. (Oops.)

I also tried to mount /mnt/cdrom2 from Konsole. (With one of the not-liked Install CDs in the drive) It said nothing. I still couldn't see anything on the CD by cd'ing and dir'ing before and after. I tried to unmount /mnt/cdrom2 and it said the following:


umount: it seems /mnt/cdrom2 is mounted multiple times
What should I do next to try and fix this? I have a feeling I've unwittingly screwed up the system with my rash editing of urpmi.cfg and fstab... :( So therefore I'm tempted to wipe Mandrake and start again... (a Windows hangover :rolleyes: ). Good idea?


Foxy 07-20-2004 09:28 AM

I reinstalled Mandrake 10, and I managed to change CD 1 to use 'cdrom2' via the 'Edit' option in the Package Manager. After that one it started having a fit over me changing it (again), giving me this error:

Unable to access medium "Installation CD X (x86) (cdromX)".   

this could be because you mounted manually the directory when creating the medium

Even when I change one from cdrom2 back to cdrom it STILL has a fit and produces the same error.

I find this hard to believe! A new install and still this problem occurs! :mad:

All times are GMT -5. The time now is 09:06 PM.