LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 07-31-2005, 04:06 PM   #1
fabre
Member
 
Registered: Aug 2003
Location: Vancouver
Distribution: Debian Sid Amd64
Posts: 87

Rep: Reputation: 15
localhost kernel: Disabling IRQ #7 ?


After booting 10.1 after a few minutes I get this message:


Kwrited - Listening on Device dev/pts/0
[Message from syslogd@localhost at Sun Jul 31 12:51:46 2005 ...
localhost kernel: Disabling IRQ #7


What does it mean?
 
Old 07-31-2005, 07:20 PM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 126Reputation: 126
Type 'dmesg' and see what it shows towards the end when that occurs.
 
Old 08-30-2005, 07:10 PM   #3
felipeps
LQ Newbie
 
Registered: Aug 2005
Posts: 1

Rep: Reputation: 0
Post Force IRQ

Hey fabre,

I was having the same problem as you and many people using kernel 2.6
are having.
I found a document telling something about kernel parameters to make kernel set IDE on a determinate IRQ, and it made me think how to solve this issue.

During boot, kernel has to set some IRQ to IDE, and depending on hardware,
usually it is 14. But sometimes, otherwise to set the 14 to it, it set the 7,
making appear this message on your console. I'm saying this because to me
was kind of randomly. Sometimes everything was fine, and other times I couldn't
do anything. My xmms and mplayer used to stuck each 5 seconds.
Playing, stuck, playing, stuck,... veeery annoying!

The idea is to force kernel to always choose IRQ 14.
If you're using grub, force ide0 having IRQ 14 passing to kernel what you want trough kopt option:
kopt=ide0=0x1f0,0x3f6,14

If you're using lilo use the append option:
append="ide0=0x1f0,0x3f6,14"

If you do "cat /proc/interrupts" you can know wich IRQ your IDE took.
And after set those parameters accordingly to your hardware and boot it up,
give another cat on interrupts to check if your IDE was set fine.

To find out about other configurations to other IDE numbers, have a look on:
http://www.ibiblio.org/peanut/Kernel-2.6.12.2/ide.txt

Cheers,

Felipe Saraiva.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling IRQ#5 fails Janneman Linux - Software 1 11-08-2005 09:20 AM
kernel: Disabling IRQ specman Mandriva 2 10-21-2005 08:35 AM
Message from syslogd@localhost localhost kernel: Disabling IRQ #21 ylts Linux - Hardware 0 02-26-2005 09:01 AM
Disabling IRQ #11 keripukki Linux - Hardware 4 09-18-2004 06:54 PM
Disabling IRQ #7? rjerina Linux - Hardware 4 07-30-2004 01:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration