LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Linux wont run anymore! (https://www.linuxquestions.org/questions/mandriva-30/linux-wont-run-anymore-91260/)

mausie 09-10-2003 10:34 AM

Linux wont run anymore!
 
LINUX WONT RUN ANYMORE :(((
i installed ati drivers and worked fine for 1 day.. but yesterday i turned pc on again and all i get is terminal
when i login and typ: startx
i get error: no screens
i tried running XFdrake and set everything to right settings for display etc
but nothing works linux just wont run anymore :(

some1 help??

jpbarto 09-10-2003 11:30 AM

the ati drivers (fglrx) is the module loaded into the kernel after rebooting?

mausie 09-10-2003 02:08 PM

no idea... im a big newbie
but well it worked fine after rebooting for 1 day
till yesterday
and well at installing ati drivers i had some error i couldnt use 3d because of something but the rest should work fine

jpbarto 09-10-2003 02:22 PM

so you have X working? just not with DRI (AGP). from a console when you execute 'lsmod' do you see 'fglrx' anywhere in the mix? you should. that fglrx is what provides you with access to ATI's AGP card.

mausie 09-10-2003 02:55 PM

i typed lsmod
but couldn't find fglrx in the list :/
( gone to bed.. bb tommorow i hope some1 know hows to fix this because this is no fun linux in black screen :P )
thnx for the help i already got
night night

jpbarto 09-10-2003 06:26 PM

turn on your box, from the console type as root 'modprobe fglrx'. this should load the ATI driver ... then as a user try loading X.

mausie 09-11-2003 07:49 AM

Can't locate module fglrx :(

mausie 09-11-2003 08:50 AM

btw this is 9.1
i also got 9.2 RC2
is it good idea to try that 1 or it's not stable?

jpbarto 09-11-2003 09:22 AM

Not sure about which is better 9.1 vs 9.2.

if you execute as root 'updatedb && locate fglrx'
do you see a directory '/lib/modules/fgrlx'? You should after installing the ATI drivers. If the fglrx module is installed on your system you should also see an fglrx.o in /lib/modules/<kernel version>/kernel/drivers/char/...

if not then you will need to 'cd /lib/modules/fglrx/build_module' and build the module yourself using the make.sh script in that directory.

then install the newly built module with 'cd .. ; make_install.sh'.

then if all goes well you should be able to modprobe fglrx and you will be on your way.

best of luck,
jpbarto

mausie 09-11-2003 09:53 AM

er, i have no idea how to run files etc
i did /make.sh but i got message: no such file
but i KNOW it's there because ive seen that file when i tried fixing 3d in linux itself

can u maybe explain stuff more.. because im big newbie :P

jpbarto 09-11-2003 10:24 AM

sure no problem. if as root you are in the /lib/modules/fglrx/build_module directory there will be a file make.sh. the '.sh' means its a shell script (like a batch file in windows). make sure it is executable ... 'ls -l make.sh' ... on the left you should see a 9 character string of assorted 'r', 'w', and 'x' characters. It should look something like this rwxr-xr-x ... if that's all settled then you execute the script like this

'./make.sh' ... the current working directory (whatever directory you're in) is typically not in root's PATH variable. as such you have to specify ( with the './') that you want to execute the make.sh script that is in the current directory.

let me know how it goes, we'll take it one step at a time.

mausie 09-11-2003 10:37 AM

i was root #
-bash: .make.sh: Permission denied
:(

jpbarto 09-11-2003 10:45 AM

well you're root so you can change the permissions (unless there's a REALLY wierd error)

'chown root.root make.sh'
'chmod 755 make.sh'
'./make.sh'

mausie 09-11-2003 11:02 AM

ATI module generator v 2.0

kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h

jpbarto 09-11-2003 11:51 AM

Ah! well that's a simple one. You have mandrake, means your kernel was precompiled. Mandrake probably installed the kernel from some rpm named kernel-2.4.20_3-i386.rpm or something like that. You'll need to rummage around on your Mandrake CD and install the kernel source rpm as well. Should look something like kernel-2.4.20_02-src.rpm or kernel-2.4.20_03-source.rpm ... once that is installed you should be able to build the module.

jpbarto

( the other solution is to download the kernel source from kernel.org and build a new kernel but that's probably going a little far )


All times are GMT -5. The time now is 12:49 PM.