-   Mandriva (
-   -   launching firefox help (

simcox1 03-16-2005 04:55 AM

launching firefox help
I've just installed mandrake on a new computer and I'm a bit lost. I was using windows xp and so this is a little different. The first thing I did was to download firefox, which worked, and then followed instructions on a thread here to install it through the konsole which also worked. However now I've closed firefox down I can't find it. I can find the file but don't know how to launch it. I'm finding this all a little difficult to get used to. Advice greatly appreciated. Thanks.
I'm using mandrake 10.1.
Also some advice has been given here about using easyurpmi but the page I'm taken to to set it up asks questions I don't know the answer to. About core distributions and architecture etc. I'm just quite lost right now.

reddazz 03-16-2005 05:12 AM

Do you know which directory you installed it into? If you do, you can create a menu entry for Firefox using Menudrake or you can create a desktop shortcut.

TxLonghorn 03-16-2005 05:21 AM

One way to find files is to choose Find/Find Files in the main menu
Just enter "firefox*" (without the quotes), and make sure you are searching all directories - erase the "file:/home/user" and make it "file:/"
Firefox is probably in /usr/local/firefox
Once you find the directory firefox is in, add firefox to your menu by rightclicking on the main start menu icon and choose "Menu Editor" then "add application.
Give it any title you like, and as Command enter:

simcox1 03-16-2005 05:23 AM

Well the file is listed as file:/home/simon/.mozilla/firefox if that helps.

reddazz 03-16-2005 05:38 AM

Thats a directory that stores Mozill and Firefox settings. I am sure there is another directory somewhere.

simcox1 03-16-2005 05:43 AM

Searching under file:/ causes an error. So I search using file:/home/simon and as I say it comes up with the above. I've found the menu editor and add application. So I'll try typing what you said.

simcox1 03-16-2005 05:49 AM

I'm not sure what to do. I didn't realise changing to linux would be so tricky. In reply yo longhorntx it doesn't like searching using just file:/ , I have to use file:/home.

reddazz 03-16-2005 06:54 AM

Did you install it in your home directory? If you did, you can find out exactly where it is by starting a console and doing

find /home/username -name 'firefox'
Substitute "username" above with your own. Post the paths that are printed to your screen and hopefully we can help out from there.

simcox1 03-16-2005 07:12 AM

Thanks. That just brings up /home/simon/.mozilla/firefox. I tried a search using firefox* and that did bring up quite a few file names but mostly for the firefox-installer. The file search doesn't like file:/ so it appears it must be in file:/home.

bunnadik 03-16-2005 07:32 AM

As root do a 'find / -name firefox-bin' . If you find that you can run firefox from that directory.
The firefox file is just a shell script that launches firefox-bin after setting up a few variables and paths.

If you don't find it you probably haven't installed firefox.

- Peder

simcox1 03-16-2005 07:48 AM

Yes I tried it and no such file exists. When I launched the installer through console it definately seemed to install to something like home/simon/firefox. So if it's not installed I don't know why.

bunnadik 03-16-2005 08:09 AM

This is how I did:
Downloaded the firefox installer from Started a terminal and untarred the installer.
Changed to that directory and ran ./firefox-installer. At the "Setup Type" screen chose to change
"Destination Directory" to /home/myuser/FFOX-1.01 .

Now I can start it with '/home/myuser/FFOX-1.01/firefox'

I bet you forgot to change the installation directory. It defaults to the directory the installer is untarred to
(in my case /home/myuser/firefox-installer).
You can probably start it by running '/home/simon/firefox-installer/firefox' (if you untarred it in your home directory).

- Peder

simcox1 03-16-2005 08:27 AM

Thanks, I ran the installer from the console and firefox appeared. Now, do I need to save it somehow so it's easier to start. Also, java isn't working.

Just to add to this. It is asking me to install java manually either by Linux RPM (self extracting file) or Linux (self extracting file).

crnchyfrog 05-31-2005 10:11 PM

I found this thread using the Search as I am having a similar problem.

Using Mandrake 10.1, I pretty much had the same problem at first. I untarred it and forgot to change the installation directory. It installed to /home/buda/firefox-installer.
After resolving the GTK_IM_MODULE=xim ./firefox issue, i can now run it from the command line by [buda@192 firefox-installer]$ ./firefox

My question is how add a Firefox icon to the kicker menu, so that i can just double click it and open it as you would the terminal window or mozilla?
I can run it fine from terminal, but would prefer not to. Firefox is already set as my default browser.


simcox1 06-01-2005 02:46 AM

Right click on desktop - create new - file - link to application - click on icon to choose firefox logo - click on application tab - give a description if liked - under command write in what you do to launch it from the console ie the path to the file - click OK. You should then have the icon on your desktop which you can drag onto the taskbar. Is that what your asking?

All times are GMT -5. The time now is 12:30 PM.