LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 08-21-2004, 06:17 PM   #16
james91911
Member
 
Registered: Jul 2004
Location: Chickasaw, Alabama
Distribution: Linspire; Mepis; Ubuntu.
Posts: 37

Rep: Reputation: 15
Additional pppk log information


Hello to all. For Proud: Have not seen a post in reference to the modem specs you wanted that I provided on the 17th, so I thought I would update what my pppk log and dialer log have to say for further amplification. Here is the ppp Log verbatim:
localhost pppd(2743) pppd 2.4.1 started by jim uid 50l
" :Using interface ppp0
" :Connect ppp0<->/dev/tts/0
" :Couldn't set pass-filter in kernel:Invalid argument
" :LCP terminated by peer
" :Connection terminated
" :Exit
kppp's diagnosis:
Unable to provide help.
Dialer log follows:
Connecting:
ATZ
OK
ATMOLO
OK
ATX3
OK
ATDT (number)
CONNECT 115200
Connecting to NetHere

Then the following box appears:
The pppd daemon died unexpectedly
Exit status 10.
I think the key to this entire string is the statement "Couldn't set pass-filter in kernel:Invalid argument" seems like I am missing a link from the root directory to the usr directory, but that is just an educated guess. Hope this helps. Thanks again for the assist. james91911.

Last edited by james91911; 08-21-2004 at 06:23 PM.
 
Old 08-22-2004, 05:24 AM   #17
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
firstly sorry I've been so long to reply, been busy at work.

Ok basically I'm sure that the problem is a variation between how the Mdk 10.0 MCC connects and how kppp does. The fact that it connected first time with a different ISP leads me to believe that is a ppp authentication issue, but I've known connection issues where the first attempt fails because a driver isn't loaded, but the second does because the first prompted the kernel to find and load the necessary driver. I'm sorry I dont know many more ideas as to how to find and fix this problem.

You could try running as root tail -f -n 30 /var/log/messages before you try connecting to see if any errors are generated as you do so. Use Ctrl+c to quit it.
Also you could try running MCC from a console, or with the Display logs enabled so some trace of its actions are reported.
 
Old 08-22-2004, 11:36 AM   #18
james91911
Member
 
Registered: Jul 2004
Location: Chickasaw, Alabama
Distribution: Linspire; Mepis; Ubuntu.
Posts: 37

Rep: Reputation: 15
Hi Proud: Thanks so much for the suggestion. I think I have found the solution having checked the FAQ's on the kppp kde development site. If this does work, it will be a very big help for folks having this same problem. Here is what the FAQ says: One of the causes for this problem is /etc/ppp/options contains the auth option. Simply put a # comment character in front and try again. Please walk me through the steps needed to try this fix please? Example would be "Open a terminal window, su to root and enter the following commands:
Then what? Again, thanks so much for your time, I know how hard it is to try and fit something like this in. Have a great day james91911.
 
Old 08-22-2004, 04:02 PM   #19
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Ok, try:
su -
root password
kwrite /etc/ppp/options
add # to auth line
save file and close kwrite

 
Old 08-23-2004, 04:35 PM   #20
james91911
Member
 
Registered: Jul 2004
Location: Chickasaw, Alabama
Distribution: Linspire; Mepis; Ubuntu.
Posts: 37

Rep: Reputation: 15
Thank You Proud

Hello Proud: First - thank you so much for staying with me on this "project" . Your directions for konsole/K-Edit were first rate and just what I needed. Putting the # in front of "noauth" did nothing to help the situation and removing the "no" making the argument "auth" changed the error to exit code 11. I put it back the way it was and will rely on the dialer in MCC which works just fine. Chapter 10 of the KDE Man pages show some other things that can be done, but at this point I will just pass and maybe MDK 10.1 will have addressed the kppp /usr issue by then. Again, your patience and wisdom has been very much appreciated. Have a great day. james91911.
 
Old 08-23-2004, 06:12 PM   #21
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Hmm, the man pppd entry for exit code 11 is still vague
Quote:
11 The peer system failed (or refused) to authenticate itself.
It's a shame this problem doesnt seem to be able to be resolved but be sure to inform Mandrake of this problem so they can hopefully set someone to track how this error is occuring and fix it asap.
 
Old 08-24-2004, 06:24 AM   #22
joshy
LQ Newbie
 
Registered: Aug 2004
Location: South Africa
Distribution: -=Mandrake 10=- -=Fedcora Core 2=- -=Knoppix 3.4=-
Posts: 23

Original Poster
Rep: Reputation: 15
Hi Proud, im not sure if ya posts were aimed at james or me...did ya post any suggestions for me regarding my post on page 1.

Thanks
 
Old 08-24-2004, 08:06 AM   #23
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Hey joshy. I think you've got the same problem as James (unless I've forgotten something) so I'm sorry to say I think you'll have to stick with the connect via MCC method until Mandrake can resolve this quirk.
 
Old 08-24-2004, 11:45 AM   #24
james91911
Member
 
Registered: Jul 2004
Location: Chickasaw, Alabama
Distribution: Linspire; Mepis; Ubuntu.
Posts: 37

Rep: Reputation: 15
Hello joshy and Proud. For joshy: I have located what I think finally is the problem which I found late yesterday in the Man pages of pppk - chapter 10 by clicking on the help button on the pppk dialer down toward the bottom of the chapter in trouble shooting. It says that you should not use the lock option and if it is showing in the etc/ppp/options file you should remove it and also remove that option from the /.ppprc file as well. It also says "if in doubt, remove all entries from the etc/ppp/options file" - and there you have it. If the pppk system is "locked" you can't use the pppd dialer! Now, if Proud has taught me correctly (and I know he has :-)) here are the steps you should take to resolve this situation:
In the bottom left hand bar by the "star" start button, click on the terminal window.
In the terminal window at the end of your user name type "su" without the quotes.
This changes users and at the end of that line type your root password and hit the enter key.
On the next line type kwrite /etc/ppp/options and hit the enter key.
This will bring up a whole bunch of scrolling lines of code and then the kwrite screen appears in a separate screen with, in my case the following four entries:

lock
noauth
noipdefault
usepeerdns

Following the guide in the pppk man pages, for starters, remove (delete) the word lock, then file save and file exit. This will pop you back into the terminal window. Type "exit" without the quotes and close the terminal window. Then try to dial using the kppp dialer. If it works, great. If not follow the above process and when you get to the line after root password, type kwrite /.ppprc and hit the enter key. when the kwrite window opens, find and remove the "lock" entry, save and exit. Then try the dialer one more time. If it still won't connect, then we need to confer with Proud before removing all entries in the etc/ppp/options file.

For Proud: Have I missed anything? or could you please add suggestions/corrections for joshy? I will not be able to try this myself until much later this afternoon, but did want to give joshy what I think is the answer so he can try now and not wait for my results. For Proud: Thanks again in advance, for joshy: hang in there, we will find a fix for this - I hope . james91911
 
Old 08-24-2004, 12:54 PM   #25
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
I dont think you have a /.ppprc file, maybe a ~/.ppprc (~ is your home directory, eg /home/james), or maybe /etc/.ppprc. Otherwise good work James.

It's definately worth trying changing the ppp configuration, but keep backups of the files you're editing coz atm you have a working way to connect and dont want to mess that up too.
 
Old 08-24-2004, 03:07 PM   #26
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
From http://www.mandrakelinux.com/en/101beta.php3
Quote:
Bug fixes:

- Everything related to modem connection, ppp, pppoe, pppoa, ppptp.
 
Old 08-24-2004, 03:36 PM   #27
james91911
Member
 
Registered: Jul 2004
Location: Chickasaw, Alabama
Distribution: Linspire; Mepis; Ubuntu.
Posts: 37

Rep: Reputation: 15
Hello Proud: Thanks for the link, I just checked it out. Think the safe bet is just hold off for the 10.1 version and use that one to update my current 10.0 Official version. As you say, no sense taking a chance messing up my MCC connection, even with backups, you could be taking a real chance there. Your observation in reference to the /.ppprc file was correct. I checked for it in my home directory and root directory and it was not there. Thanks for the kind word, thought I had that walk through just about right. For joshy: Disregard the suggestion in reference to the /.ppprc file, that must refer to a different distribution - maybe Red Hat. Have a great day. james91911.

Last edited by james91911; 08-24-2004 at 04:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KPPP dials and then dies after connecting Dreamcast Debian 5 06-04-2005 12:28 PM
kppp dies after trying to connect. chriskar Linux - Newbie 4 10-05-2004 07:22 PM
KPPP spontaneously dies AMMullan Linux - Software 4 02-26-2004 12:51 PM
Login as user kppp dies gmichel Linux - Newbie 0 02-15-2004 02:11 AM
kppp - exit code 1 grim1234 Slackware 3 09-02-2003 09:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 01:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration