LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 05-28-2005, 02:07 AM   #76
abattoir
Member
 
Registered: Feb 2005
Distribution: Kubuntu 6.10
Posts: 313

Rep: Reputation: 30

try uninstalling īperl-URPM ī and install it from the cd or from a īmainī source.
post back what happens
 
Old 05-28-2005, 05:38 AM   #77
jkw119
LQ Newbie
 
Registered: Feb 2005
Location: Pittsburgh
Distribution: SuSE Linux 9.1 Professional
Posts: 5

Rep: Reputation: 0
why use kopete anyways? Just go to http://www.e-messenger.net/ and you don't need the software.
 
Old 05-28-2005, 07:39 AM   #78
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 34
Abattoir, how do I uninstall it? I can't open up up mandrake control center. I don't even know how this happened.

d-1


Quote:
Originally posted by abattoir
try uninstalling īperl-URPM ī and install it from the cd or from a īmainī source.
post back what happens
 
Old 05-28-2005, 07:45 AM   #79
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 34
I get Segmentation fault when I run "mcc". I never fully got to install kopete 10.0, I just deleted it and tried running a urpmi kopete then my problems started.

d-1

[stan@localhost stan]$ mcc
Segmentation fault
[stan@localhost stan]$ su
Password:
[root@localhost stan]# mcc
Segmentation fault
[root@localhost stan]#




Quote:
Originally posted by abattoir
I just saw your other post. To run MCC from console just type
Code:
mcc
 
Old 05-28-2005, 09:26 AM   #80
abattoir
Member
 
Registered: Feb 2005
Distribution: Kubuntu 6.10
Posts: 313

Rep: Reputation: 30
I did some googling and found the mcc error was related to the urpmi perl stuff.
Do you have the original CD, or can you download certain packages manually?
We may have to uninstall perl-URPM, and its dependencies(including urpmi) and reinstall them.

Last edited by abattoir; 05-28-2005 at 09:29 AM.
 
Old 05-28-2005, 09:38 AM   #81
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 34
I am not sure I still have the 10.1 community CD's, I can look for them. How do you uninstall perl-URPM?

I tried downloading a perl RPM file and was able to, but when I double clicked on the RPM file and asked for my password, and I entered the password, the hour glass went and went, but nothing ever happened. So I am not even sure if I can even install the RPM.

I do not know what is happening. It's the strangest thing I have experienced yet with mandrake. I have spent all morning googling for a solution and nothing.

d-1



Quote:
Originally posted by abattoir
I did some googling and found the mcc error was related to the urpmi perl stuff.
Do you have the original CD, or can you download certain packages manually?
We may have to uninstall perl-URPM, and its dependencies(including urpmi) and reinstall them.
 
Old 05-28-2005, 10:07 AM   #82
abattoir
Member
 
Registered: Feb 2005
Distribution: Kubuntu 6.10
Posts: 313

Rep: Reputation: 30
These are the related packages
rpmtools-5.0.20-1mdk
urpmi-4.6.24-3mdk
rpmdrake-2.10-4.1.102mdk.......
and of course perl-URPM

the commands are
Code:
rpm -e <package name> \\ e is for erase and substitute<p...> with the package name
rpm -i <package name> \\ i is for install
try removing urpmi and all its dependencies. See if
Code:
urpme urpmi
works, or you can do
Code:
rpm -e urpmi
to remove urpmi and install using rpm -i.

If you have the time, you could Install LE 2005
You would have the latest version of kopete(w/ the fix) and would have the best the world of Mandriva has to offer
 
Old 05-28-2005, 01:59 PM   #83
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
aMSN is the key
 
Old 05-28-2005, 10:02 PM   #84
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 34
abattoir,

Sorry did not respond sooner, I was at work. I feel like I am in the space shuttle and everything I try does not work and things do not look good. I tried these commands below and did not have any success. What do you recommend?

[root@localhost stan]# urpme urpmi
Can't locate URPM.pm in @INC (@INC contains: /usr/lib/perl5/5.8.6/i386-linux /usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.6/i386-linux /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.6/i386-linux/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/vendor_perl/5.8.5/urpm.pm line 16.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.5/urpm.pm line 16.
Compilation failed in require at /usr/sbin/urpme line 24.
BEGIN failed--compilation aborted at /usr/sbin/urpme line 24.

[root@localhost stan]# rpm -e urpmi
error: Failed dependencies:
urpmi >= 4.4-23mdk is needed by (installed) drakxtools-newt-10.1-9mdk
urpmi >= 4.5-25mdk is needed by (installed) gurpmi-4.5-25mdk
urpmi >= 4.5-11mdk is needed by (installed) rpmdrake-2.1.5-8mdk
[root@localhost stan]#

d-1




Quote:
Originally posted by abattoir
These are the related packages
rpmtools-5.0.20-1mdk
urpmi-4.6.24-3mdk
rpmdrake-2.10-4.1.102mdk.......
and of course perl-URPM

the commands are
Code:
rpm -e <package name> \\ e is for erase and substitute<p...> with the package name
rpm -i <package name> \\ i is for install
try removing urpmi and all its dependencies. See if
Code:
urpme urpmi
works, or you can do
Code:
rpm -e urpmi
to remove urpmi and install using rpm -i.

If you have the time, you could Install LE 2005
You would have the latest version of kopete(w/ the fix) and would have the best the world of Mandriva has to offer
 
Old 05-28-2005, 10:21 PM   #85
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 34
I ran this command:

[root@localhost stan]# rpm -i ActivePerl-5.8.6.811-i686-linux.rpm
Configuring Perl installation at /usr/local/ActivePerl-5.8
[root@localhost stan]#

I assume this package installed, I went to /usr/local and it is there. Now I must find the other packages and run this command for install.

d-1
 
Old 05-28-2005, 10:38 PM   #86
abattoir
Member
 
Registered: Feb 2005
Distribution: Kubuntu 6.10
Posts: 313

Rep: Reputation: 30
Since you get failed dependencies, you must uninstall all those packages separately, either dīl them manually or install from cd.
As I said, since you can devote so much time to get kopete working(and its side effects!!). You can consider installing LE 2005 without formatting your home folder, all your data will be intact too.
 
Old 05-28-2005, 11:40 PM   #87
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 34
abattoir,

I never knew I would get this far deep into my head. I have never encountered a problem that I could not resolve. This by far to me is my most difficult problem encountered with Mandrake.

Can you connect with me using gaim, or amsn or kopete? My user name is dolphans1@msn.com

d-1


Quote:
Originally posted by abattoir
Since you get failed dependencies, you must uninstall all those packages separately, either dīl them manually or install from cd.
As I said, since you can devote so much time to get kopete working(and its side effects!!). You can consider installing LE 2005 without formatting your home folder, all your data will be intact too.
 
Old 05-29-2005, 01:13 AM   #88
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 34
abbaitor,

You are correct, no matter what I try to do when removing or installing packages, singularly, I always get a failed dependency error. Example below and it is only half of what it really says, it is too long to list them all here.

[root@localhost Documents]# rpm -e perl-base-5.8.6-6.1.102mdk
error: Failed dependencies:
perl(constant) is needed by (installed) automake1.6-1.6.3-2mdk
perl(strict) is needed by (installed) perl-TimeDate-1.16-3mdk
perl(strict) is needed by (installed) perl-Digest-HMAC-1.01-11mdk
perl(strict) is needed by (installed) perl-HTML-Tagset-3.03-7mdk
perl(strict) is needed by (installed) frozen-bubble-1.0.0-6mdk
perl(strict) is needed by (installed) perl-String-ShellQuote-1.00-7mdk
perl(strict) is needed by (installed) automake1.6-1.6.3-2mdk
perl(strict) is needed by (installed) perl-Tie-Watch-1.1-1mdk
perl(utf8) is needed by (installed) perl-TimeDate-1.16-3mdk
perl(vars) is needed by (installed) perl-TimeDate-1.16-3mdk
perl(vars) is needed by (installed) perl-Digest-HMAC-1.01-11mdk
perl(vars) is needed by (installed) perl-HTML-Tagset-3.03-7mdk
perl(vars) is needed by (installed) frozen-bubble-1.0.0-6mdk
perl(vars) is needed by (installed) perl-String-ShellQuote-1.00-7mdk
perl(vars) is needed by (installed) automake1.6-1.6.3-2mdk
perl(vars) is needed by (installed) perl-Tie-Watch-1.1-1mdk
perl(Carp::Heavy) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(AutoLoader) is needed by (installed) perl-MailTools-1.62-1mdk
perl(AutoLoader) is needed by (installed) perl-Term-ReadKey-2.21-4mdk
perl(AutoLoader) is needed by (installed) perl-SDL-1.20.0-10mdk
perl(AutoLoader) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(AutoLoader) is needed by (installed) perl-Tk-804.027-4mdk
perl(Config) is needed by (installed) drakxtools-backend-10.1-9mdk
perl(Config) is needed by (installed) makedev-4.1-1mdk
perl(Config) is needed by (installed) perl-Glib-1.054-1mdk
perl(Config) is needed by (installed) drakxtools-newt-10.1-9mdk
perl(Config) is needed by (installed) perl-MailTools-1.62-1mdk
perl(Config) is needed by (installed) drakxtools-10.1-9mdk
perl(Config) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(Config) is needed by (installed) perl-Tk-804.027-4mdk
perl(Config) is needed by (installed) tetex-context-3.0-8mdk
perl(Config) is needed by (installed) kdesdk-3.3.2-11mdk
perl(Cwd) is needed by (installed) perl-Glib-1.054-1mdk
perl(Cwd) is needed by (installed) urpmi-4.5-25mdk
perl(Cwd) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(Cwd) is needed by (installed) autoconf2.5-2.59-6mdk
perl(Cwd) is needed by (installed) cvs-1.11.19-1.1.102mdk
perl(Cwd) is needed by (installed) perl-Tk-804.027-4mdk
perl(Cwd) is needed by (installed) kdesdk-3.3.2-11mdk
perl(Data:umper) is needed by (installed) drakxtools-backend-10.1-9mdk
perl(Data:umper) is needed by (installed) perl-Glib-1.054-1mdk
perl(Data:umper) is needed by (installed) perl-Libconf-0.33-2mdk
perl(Data:umper) is needed by (installed) drakxtools-newt-10.1-9mdk
perl(Data:umper) is needed by (installed) drakxtools-10.1-9mdk
perl(Data:umper) is needed by (installed) hwdb-clients-0.15.2-1mdk
perl(Data:umper) is needed by (installed) frozen-bubble-1.0.0-6mdk
perl(Data:umper) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(Data:umper) is needed by (installed) autoconf2.5-2.59-6mdk
perl(DirHandle) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(DirHandle) is needed by (installed) perl-Tk-804.027-4mdk
perl(Errno) is needed by (installed) autoconf2.5-2.59-6mdk
perl(Exporter) is needed by (installed) perl-Glib-1.054-1mdk
perl(Exporter) is needed by (installed) perl-Gtk2-1.054-1mdk
perl(Exporter) is needed by (installed) perl-Locale-gettext-1.01-13mdk
perl(Exporter) is needed by (installed) urpmi-4.5-25mdk
perl(Exporter) is needed by (installed) perl-TimeDate-1.16-3mdk
perl(Exporter) is needed by (installed) perl-MailTools-1.62-1mdk
perl(Exporter) is needed by (installed) perl-Digest-SHA1-2.10-1mdk
perl(Exporter) is needed by (installed) perl-Digest-HMAC-1.01-11mdk
perl(Exporter) is needed by (installed) perl-URI-1.31-2mdk
perl(Exporter) is needed by (installed) perl-HTML-Parser-3.36-1mdk
perl(Exporter) is needed by (installed) perl-libwww-perl-5.800-1mdk
perl(Exporter) is needed by (installed) perl-XML-Stream-1.21-2mdk
perl(Exporter) is needed by (installed) perl-Net-Jabber-1.30-1mdk
perl(Exporter) is needed by (installed) perl-SOAP-Lite-0.60-0.a.2mdk
perl(Exporter) is needed by (installed) perl-Term-ReadKey-2.21-4mdk
perl(Exporter) is needed by (installed) perl-SDL-1.20.0-10mdk
perl(Exporter) is needed by (installed) perl-String-ShellQuote-1.00-7mdk
perl(Exporter) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(Exporter) is needed by (installed) autoconf2.5-2.59-6mdk
perl(Exporter) is needed by (installed) automake1.6-1.6.3-2mdk
perl(Exporter) is needed by (installed) perl-Tk-804.027-4mdk
perl(Exporter) is needed by (installed) perl-SGMLSpm-1.03ii-7mdk
perl(File::Basename) is needed by (installed) gstreamer-plugins-0.8.4-1mdk
perl(File::Basename) is needed by (installed) mc-4.6.0-12mdk
perl(File::Basename) is needed by (installed) amsn-0.94-3mdk
perl(File::Basename) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(File::Basename) is needed by (installed) autoconf2.5-2.59-6mdk
perl(File::Basename) is needed by (installed) automake1.6-1.6.3-2mdk
perl(File::Basename) is needed by (installed) cvs-1.11.19-1.1.102mdk
perl(File::Basename) is needed by (installed) perl-Tk-804.027-4mdk
perl(File::Basename) is needed by (installed) docbook-style-dsssl-1.79-2mdk
perl(File::Basename) is needed by (installed) kdesdk-3.3.2-11mdk
perl(File::Find) is needed by (installed) rpmtools-4.5-25mdk
perl(File::Find) is needed by (installed) postfix-2.1.4-2mdk
perl(File::Find) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(File::Find) is needed by (installed) autoconf2.5-2.59-6mdk
perl(File::Find) is needed by (installed) cvs-1.11.19-1.1.102mdk
perl(File::Find) is needed by (installed) menu-xdg-0.6-19mdk
perl(File::Find) is needed by (installed) kdesdk-3.3.2-11mdk
perl(File::Glob) is needed by (installed) mozilla-1.7.2-8mdk
perl(File::Glob) is needed by (installed) mozilla-firefox-0.10.1-4mdk
perl(FileHandle) is needed by (installed) gnucash-1.8.9-2mdk
perl(FileHandle) is needed by (installed) perl-XML-Stream-1.21-2mdk
perl(FileHandle) is needed by (installed) perl-MIME-Lite-3.01-5mdk
perl(FileHandle) is needed by (installed) perl-Net-Jabber-1.30-1mdk
perl(FileHandle) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(File::Path) is needed by (installed) rpmtools-4.5-25mdk
perl(File::Path) is needed by (installed) mozilla-1.7.2-8mdk
perl(File::Path) is needed by (installed) mozilla-firefox-0.10.1-4mdk
perl(File::Path) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(File::Path) is needed by (installed) cvs-1.11.19-1.1.102mdk
perl(File::Spec) is needed by (installed) perl-Glib-1.054-1mdk
perl(File::Spec) is needed by (installed) netpbm-9.24-8mdk
perl(File::Spec) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(File::Spec) is needed by (installed) autoconf2.5-2.59-6mdk
perl(File::Spec) is needed by (installed) automake1.6-1.6.3-2mdk
perl(File::Spec) is needed by (installed) perl-Tk-804.027-4mdk
perl(File::Spec::Unix) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(Getopt::Long) is needed by (installed) drakxtools-backend-10.1-9mdk
perl(Getopt::Long) is needed by (installed) vim-common-6.3-5mdk
perl(Getopt::Long) is needed by (installed) libbonobo-2.6.2-1mdk
perl(Getopt::Long) is needed by (installed) rpmtools-4.5-25mdk
perl(Getopt::Long) is needed by (installed) urpmi-4.5-25mdk
perl(Getopt::Long) is needed by (installed) netpbm-9.24-8mdk
perl(Getopt::Long) is needed by (installed) perl-libwww-perl-5.800-1mdk
perl(Getopt::Long) is needed by (installed) emacs-21.3-15mdk
perl(Getopt::Long) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(Getopt::Long) is needed by (installed) autoconf2.5-2.59-6mdk
perl(Getopt::Long) is needed by (installed) automake1.6-1.6.3-2mdk
perl(Getopt::Long) is needed by (installed) perl-Tk-804.027-4mdk
perl(Getopt::Long) >= 2.01 is needed by (installed) docbook-utils-0.6.14-1mdk
perl(Getopt::Long) is needed by (installed) kdesdk-3.3.2-11mdk
perl(Getopt::Std) is needed by (installed) vim-common-6.3-5mdk
perl(Getopt::Std) is needed by (installed) gnupg-1.2.4-1mdk
perl(Getopt::Std) is needed by (installed) oaf-0.6.10-10mdk
perl(Getopt::Std) is needed by (installed) postfix-2.1.4-2mdk
perl(Getopt::Std) is needed by (installed) perl-libwww-perl-5.800-1mdk
perl(Getopt::Std) is needed by (installed) ntp-4.2.0-9mdk
perl(Getopt::Std) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(Getopt::Std) is needed by (installed) perl-Tk-804.027-4mdk
perl(Getopt::Std) is needed by (installed) docbook-style-dsssl-1.79-2mdk
perl(Getopt::Std) is needed by (installed) kdesdk-3.3.2-11mdk
perl(IO::Handle) is needed by (installed) perl-MailTools-1.62-1mdk
perl(IO::Handle) is needed by (installed) perl-SOAP-Lite-0.60-0.a.2mdk
perl(IO::Handle) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(IO::Seekable) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(IO::Select) is needed by (installed) perl-XML-Stream-1.21-2mdk
perl(IO::Select) is needed by (installed) perl-SOAP-Lite-0.60-0.a.2mdk
perl(IO::Select) is needed by (installed) perl-5.8.6-6.1.102mdk
perl(IO::Socket) is needed by (installed) perl-libwww-perl-5.800-1mdk
perl(IO::Socket) is needed by (installed) perl-XML-Stream-1.21-2mdk
perl(IO::Socket) is needed by (installed) perl-SOAP-Lite-0.60-0.a.2mdk
perl(IO::Socket) is needed by (installed) perl-Crypt-SSLeay-0.51-4mdk
perl(IO::Socket) is needed by (installed) perl-5.8.6-6.1.102mdk

Many more listed, but I cut it off short to not clog up the board.

It may be best to upgrade to Mandriva at this point like you said?

I wonder how this all happened? I think somewhere in between installing kopete RPM package 10.0 it deleted one of the perl packages that it needed, I am not sure. Anyway let me know what you think.....

d-1



Quote:
Originally posted by dolphans1
abattoir,

I never knew I would get this far deep into my head. I have never encountered a problem that I could not resolve. This by far to me is my most difficult problem encountered with Mandrake.

Can you connect with me using gaim, or amsn or kopete? My user name is dolphans1@msn.com

d-1
 
Old 05-29-2005, 02:39 AM   #89
abattoir
Member
 
Registered: Feb 2005
Distribution: Kubuntu 6.10
Posts: 313

Rep: Reputation: 30
Yeah, I think while installing kopete certain processes/ changes were not carried out completely. Stuff like this happens when urpmi is abruptly stopped, like when the computer is shutdown(while urpmi is running). maybe the rpm was not compiled properly(????).
Anyways, if you have the time and resources, Iīd say it is best to upgrade/install LE 2005.
 
Old 05-29-2005, 07:23 AM   #90
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 34
Question about possibly upgrading, if I end up doing this, will it affect my CUPS settings and my sharing printer with windows. Also will I lose my emails?

d-1




Quote:
Originally posted by abattoir
Yeah, I think while installing kopete certain processes/ changes were not carried out completely. Stuff like this happens when urpmi is abruptly stopped, like when the computer is shutdown(while urpmi is running). maybe the rpm was not compiled properly(????).
Anyways, if you have the time and resources, Iīd say it is best to upgrade/install LE 2005.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kopete not connecting to MSN Messenger Hubmasterflex Linux - Software 5 03-01-2009 04:03 AM
Kopete can login to MSN messenger neouto Linux - Newbie 8 09-05-2005 02:18 AM
Having problems accessing MSN Messenger through Kopete Hockeyfan Linux - Software 3 06-04-2005 03:42 PM
Kopete X Msn Messenger nightrider Linux - Software 10 05-30-2005 01:05 PM
Instant messenger Chat Kopete mandrake linux yahoo and MSN messenger saurya_s Linux - Software 1 11-22-2003 01:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 05:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration