-   Mandriva (
-   -   Konqueror freezes when I try to access user document directory. (

GlennsPref 02-17-2008 07:30 AM

Konqueror freezes when I try to access user document directory.
Hi, I've been having some trouble browsing my files, Konqueror freezes when I try to access documents in the user document directory.

It does not do it all the time, but when it does, the window grey's out and that is the end of any action.

I usually have to use ksysguard to close the application, and I get a warning that any changes will not be saved.

I thought of using fsck to check the drive, but there isn't any detail about file systems, just checking for bad blocks.

Can anybody give me a direction to go. This is annoying, and I fear losing the data I have stored there.

/home/glenn/Documents is mounted on /dev/sda9 /home

The line in fstab is /dev/sda9 /home ext3 relatime 1 2

It's 35Gb and with 5Gb spare.

Any assistance greatly appreciated,

Regards, Glenn

kilgoretrout 02-17-2008 11:25 AM

Try changing the fstab line to:

/dev/sda9 /home ext3 defaults 1 2

GlennsPref 02-17-2008 05:15 PM

Hi, Thanks for the reply.

I have just changed the home and root directories to "defaults", and rebooted, to no effect.

The screen still greys-out.

I should add that I only have this problem with the documents directory, and all the other files and folders are fine, in the home directory, as well as the rest of the system.

Could it be that something is corrupted there. The documents folder is 570.0 MB (597,689,660) of 21296 files, 1119 sub-folders.

I thought there might be a file-system check, I am not aware of, that might check the file system for (I don know what) errors and or dead entries.

I will try to burn it to dvd and delete the folder reboot and copy it back.

To make things worse, I am just about to move "my documents"from the M$windows file system to my linux system, On the cusp of ridding those wasted (4) M$windows partitions. (80Gb)

Thank you, Glenn

kilgoretrout 02-17-2008 07:45 PM

It could just be a konqueror bug. Have you tried any other file manager like gnome/nautilus or krusader? What happens when you run:

$ ls -la Documents/

from a console? Also, try running konqueror from a console:

$ konqueror --profile filemanagement

and navigate to your Documents folder. See if any error messages appear in the console. It may give some clue as to what's happening. I would suspect one or more corrupt files in your Documents folder.

GlennsPref 02-17-2008 08:01 PM

OK, thanks, I'll Keep this in mind.

No, I haven't tried any other managers.

While I was away, I have burned the folder to dvd, and deleted it form /home/glenn and am now in the process of copying back the most relevant files.

I agree, it is probably either a bug (but no other folders are effected?) or a corrupt file.

I haven't used any of the console access types you suggest yet, but if it recurrs I have a now have a few more way to check and get a message abouyt the error.

Thanks, I'll post back with my successes.

Cheers, Glenn

GlennsPref 02-17-2008 08:04 PM

Ahh, the copy process stalled (too). (while I was posting the last reply)

The cd burned with no errors.

Hmm, I check from a console to see if I can copy from there and maybe get an error massage.

Regards, Glenn

GlennsPref 02-17-2008 10:29 PM

Well, it seems there was one plain-text file that was contributing to the lockups.

After copying the files in small blocks to the drive, 4 or 5 times, I found where it stopped and froze.

I also had some file permissions that seemed to be wrong/ root access, executable (should a .pdf or .wav file be executable) etc.

Any how, it seems to be OK now.

Thanks for the tips, Glenn

PS. when typing ls -la Documents/

I get a long string of files, coloured coded, some dark-blue, most white, one red, one green and one grey.

kilgoretrout 02-18-2008 12:17 PM

If you want to recursively change the file ownerships of all files in your /home/<username>/Documents directory to be owned by your username and groupname, run as root:

# chown -R <username>:<username> Documents/

It's not uncommon to have otherwise non-executable files with rwx permissions, especially if you move files around a lot from one environment to another, like from windows to linux or one linux distro to another. Sometimes it's just a matter of how the application that created the file handled the permissions on the files it created. It's also not uncommon to get screwed up links when you do that because you are pulling a directory out of an environment where it has valid links to other locations into one where those locations are non-existent. This can sometimes screw konqueror up as well.
Permissions can get screwed up when moving files around from one environment to another as well. Normally, in your Documents directory you would want username to have rwx permissions and the usergroup and world to have read only and execute permissions. You can recursively change the permissions on all files in your Documents directory to be that way by running as root:

# chmod -R 755 Documents/

Copying files back and forth off of cd-r or dvd-r can screw up these permissions and running the above will correct that.

All times are GMT -5. The time now is 08:25 AM.