LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Konqueror and Java problem in KDE 3.2 (https://www.linuxquestions.org/questions/mandriva-30/konqueror-and-java-problem-in-kde-3-2-a-173097/)

stonehurstX11 04-21-2004 08:46 PM

Konqueror and Java problem in KDE 3.2
 
Hi, I am running Mandrake 10.0 CE.
I am trying to get Java to work in the Konqueror browser on KDE 3.2. I already configured Konqueror to use Java correctly. However, when I try to start a Java applet on any website, the applet loads, and then complains that it has not been given the required privilege. This is how the error goes on any applet:

----
Applet X has not been given the required privilege:

java.security.AccessControlExemption
---

Any ideas?
Thanks in advance!

MunterMan 04-22-2004 09:50 AM

Quote from the sunsite.
This exception is thrown by the AccessController to indicate that a requested access (to a critical system resource such as the file system or the network) is denied.

Check your permissions on your java dire and applet dire.

stonehurstX11 04-22-2004 07:27 PM

I checked and modified the java and applet directories to have the appropriate permissions, but I still get the same error. Also, I tried java using Netscape 7.1, and the applets worked just fine without any error.

Any ideas?

MunterMan 04-23-2004 08:36 AM

I assume that netscrape is using it's own jre, check the preferences to be sure.

QUOTE I already configured Konqueror to use Java correctly. However... ENDQUOTE
If it isn't working, how do you know it is configured correctly?

Which jre are you trying to use?
9.2 came with blackdown and just typing 'java' into the konqueror settings should have worked, but didn't. I develop in java and have the j2sdk from sun, so I pointed it at that instead.

stonehurstX11 04-24-2004 09:28 AM

Quote:

QUOTE I already configured Konqueror to use Java correctly. However... ENDQUOTE
If it isn't working, how do you know it is configured correctly?
I think I phrased that incorrectly. What I meant to say was that I put the correct location of the 'java' executable in the Konqueror settings. Like I said, that applets load, but I just get that error.

.I'm using j2re1.4.2_04 downloaded off the Sun website as an .rpm.

MunterMan 04-25-2004 06:03 AM

If you used the rpm then you only need to enter the word java into the settings path.
If that doesn't work, make sure the path to the binary is correct. You want it to point at a binary file called java in the bin directory. eg.

/java/j2sdk/bin/java

stonehurstX11 04-27-2004 07:22 PM

Thanks, it finally works! Typing in just 'java' seemed to do the trick.


All times are GMT -5. The time now is 11:43 AM.