-   Mandriva (
-   -   Keystroke repetitions in the login screen rendering it unusable. (

sidholland 07-06-2007 12:20 AM

Keystroke repetitions in the login screen rendering it unusable.
Hi folks,

I'm relatively new to Linux, especially Mandriva, so be please be gentle.

I'm having a problem with certain keystrokes being repeated seemingly endless times while in the Mandriva 2007 login screen. I'll attempt to login but it is impossible since every few times I hit a key, it displays in the login box hundreds of times. The same also happens to the delete key, so hitting it simply deletes the entire contents of the input box. The error is not consistent to any particular key, or sequence, or position of letter.

I've reinstalled the OS three times now, and tried plugging in two keyboards, since my main one is wireless, but to no avail. The keyboard works fine on the other OS (I'm dual-booting with Windoze XP) on the same machine and it worked fine during the install, so I'm pretty sure it's not a hardware problem.

Has anyone else had this problem? I did a search on the forum but came up with nothing related.

Apologies if this has been answered before, or if I've not provided enough information.

Any help is greatly appreciated.


McBrain 07-06-2007 09:16 AM

I have a similar problem!

Actually when I wait till the letter appears on the screen it is fine, but that takes a time and then I get the mention repetitions!

The problem is reported on several times in other forums as well (e.g. on, but without solution! I start assuming it is kernel (module) bug!

A little bit more of my observations:

I have a Intel P965 based motherboard (Abit AB9Pro) with E6600 on it, the keyboard is connected to one of the onboard USB ports and is a Logitech wired one.

When I change inside the BIOS the setting for the control of USB keyboards from BIOS to OS, it actually works, but then I can not use the keyboard anymore for controlling my boot menu for GRUB (because the OS is not booted yet)!


ernie 07-06-2007 03:15 PM

Does your keyboard connect to a USB or a PS2 port?

Which layout does your keyboard have?

What language?

If your keyboard is a USB keyboard, how is it configured in the system BIOS - BIOS or OS? Try the alternate setting.

If you are using the default Standard US Keyboard configuration, try the US International keyboard configuration.

If none of this helps, and you are unable to log in using the GUI log in screen, try the following steps:

When you get to the GUI log in screen press the CTRL+ALT+F2 keyboard combination. This combination should switch to a text screen.

Enter your user name at the log in prompt.

Enter your password when requested.

Enter the following command:

Enter your root password when requested.

Enter the following command (close Xorg):

telinit 3
Press the CTRL+D keyboard combination to return to your regular user session.

To start a GUI session enter the following command:

All this may seem a bit convoluted, but I have two objectives here:

1). Check to see if you have the same trouble when you try to log in using a text mode log in screen. If not the trouble is in either the Xorg or the GUI login configuration.

2). Check to see if you can start a GUI session after you are logged in. If you have no trouble with the keyboard in a GUI session after you are logged in, the trouble is in the GUI login manager.

If you are able to log in and start the GUI session with no keyboard trouble, the first thing I would suggest would be to listall any available updates for your system.

Open a terminal window and run the following command:

Enter your root password when requested. If you have not used the updater yet, it will guide you through the process of setting up an update source, then it will check for updates and ask to install any it finds.


GlennsPref 07-06-2007 05:55 PM

I had a similar problem a week ago, but I managed to get around it by ctrl+alt+back-space,

and when the login screen rewrites, I could login as normal.

Hope this helps, Glenn

(edit) this didn't fix the problem, just got around it.

McBrain 07-08-2007 04:45 PM

Did not solve the problem yet but did some more research!

Ok, the root cause seems to be that I bought a new computer :scratch: ..... (having so much trouble)..

But honestly:

When I observe the above problem and do then a reboot (warm start) and do a memtest it tells me that my memory is damaged! I guess that this could be the reason for the above mentioned problems. So everybody who has the same problem, check you memory!

In my particular case this only occurs when I do a warm start, a cold start (reset or switch off), and my memory is fine, unfortunatelly i could not verify whether this connection is bullet proven, because I have some more problems....

sidholland 07-09-2007 09:19 PM

Thanks for all the replies, sadly I have yet to figure out why it's happening.

So: my keyboard was running through a 4-port KVM switch, which I have now eliminated from the equation. It was plugged in via the PS/2 port but the same problem occurs when using it in the USB port. The keyboard's layout is the default US layout but I'm not sure how to switch it to another layout without reinstalling, which would be a pain given how many times I've already done that. However, if that is the only way then so be it. The language I selected in the install is UK English (since that's from whence I originate). Again, not sure how to change that without a reinstall.

I set the BIOS to recognise USB keyboards, but I don't seem to have a setting to switch it to OS-configured. The motherboard is a few years old (it's a Gigabyte GA-5SMM) so it's possible that it's too old to have that function (I certainly don't remember it from my hardware engineering days).

Anyway, I went through the steps suggested by Ernie: the keyboard operates fine in the terminal screens; the GUI session starts OK, but the keyboard malfunctions again when I attempt to do anything; the mouse also starts malfunctioning (although it's fine in the GUI login manager) and won't select anything, although the pointer moves around OK. Consequently I can't open a terminal window to run the MandrivaUpdate command.

Oh, and I tried Ctrl-Alt-Backspace at the login screen but the problem remained after the screen was rewritten, so no get-around there.

This is somewhat confusing. I think I might try installing the OS on another machine, and another distribution on the troublesome one to see what happens.

Thanks again for the suggestions so far; keep them coming!


ernie 07-09-2007 11:33 PM


the keyboard operates fine in the terminal screens; the GUI session starts OK, but the keyboard malfunctions again when I attempt to do anything; the mouse also starts malfunctioning (although it's fine in the GUI login manager) and won't select anything, although the pointer moves around OK.
OK, so the keyboard works OK in the text screen, but not in Xorg. The trouble has to be in the Xorg configuration. We should be able to sort it out even if we have to do it in a text screen. Follow my direction from the last post to get to a text screen, but this time just log in as root and run the telinit 3 command to close Xorg. Now execute the following command:

This will open the Mandriva Control Center in text mode.

Use the up arrow key to move the cursor to the tool list, then use the up and down arrow keys to navigate the list. When you have the cursor on the item (keyboard or mouse) you want to configure, press the TAB key to move the cursor to the OK button then press the ENTER key to open the tool. You can configure the keyboard or the mouse, but you will have to do one at a time then open mcc again to continue. These configurations will apply to your Xorg configuration.

If this does not work, post back and we will go to the next step.


GlennsPref 07-11-2007 06:45 AM

Just to clarify, My particular problem was i would type in the user and then tab to the password field and the first key stroke would set of a repartition of *, like this *************, so maybe it's a different bug.

After updating the problem disappeared.

Regards, Glenn

(edit) McBrain, I've always tested my memory with memtest86+, do three reps at least, to be sure, to be sure.

M$ Windows handles memory management differently. And will run on deficient memory modules(easier for everyone to use, if you use that, and most people do,) therefore manufacturers can sell silicon not quite good enough for everyone.

The bottom line is that if you want dependable ram, memtest 86+ will show you.

McBrain, take your computer back for a memory swap. Under waranty. memtest is proof enough for most techs.

Cheers, Glenn

sidholland 07-15-2007 05:15 PM

OK, so I used mcc to change the configuration of mouse and keyboard, which solved the mouse issue and at least allows me to use the GUI. The keyboard issue was not solved even after trying a plethora of different configurations. However, I then changed some of the keyboard preferences from within the GUI and one in particular made a difference: I unselected the option to allow key presses to repeat when the key is held down. Presto! No more key repeats. So I'm at a bit of a loss to explain it. Windoze also has a key repeats function, but it's OK in there.

Having fiddled around with the delay time in the key repeat function, it seems that below a critical level the keys repeat uncontrollably, but above it they function as they should. The critical level seems to be about 40 to 45% along the delay bar. Don't know whether this is due to the machine I'm using or the keyboard, or just a glitch in the OS.

Anyway, I'll class this one as "solved" for now until I have time to investigate further or more people report the same problem.

Thanks very much to everyone for their replies, particularly Ernie.

All times are GMT -5. The time now is 02:39 PM.