LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   kernel 2.6: slow internet (https://www.linuxquestions.org/questions/mandriva-30/kernel-2-6-slow-internet-151046/)

janW 02-27-2004 01:39 AM

kernel 2.6: slow internet
 
Hi all,

I am running Mandrake 10.0 beta 2, Kernel 2.6.2rc3 on a new linux box (athlon 2500+).
First, to all people asking for experiences with 10.0 : all seems fine to me. I have minor issues with my mouse scroll wheel but apart from that all seems fine. I can't compare to 9.2 since I'm new to Mandrake.

Now here's the problem:
When running the kernel 2.6 internet is waaay slow. I am on a highspeed ADSL line, and downloads are fast (300kB/s), but viewing internet pages takes forever. I'll wait seconds for Mozilla "Looking up host www google com"...
The puzzling thing is, if I run the kernel 2.4.25pre7, Internet is blazingly fast (well, I just moved from a K6-2/266...). The reason I don't want to go with the 2.4 kernel is my serial ATA controller. Disk access is slower by a factor of two with kernel 2.4.

I'm using pppoe to connect, have a basic firewall installed. I'm connecting using the on-board gigabit ethernet adapter on my ASUS A7N8X-E Deluxe. I know this is overkill, but the second fast ethernet port was not recognized, and I didn't bother to investigate.

So I'm stuck with either a slow hard drive or a slow internet connection. Any thoughts?

JanW

Iridesce 03-18-2004 08:37 PM

Mandrake 10.0 slow
 
Same here -

Also running on an ASUS A7N8X, only a 1.7 AMD

Know nothing about how the 2.6 kernel would affect the speed, only that with 9.2 it was much faster

Will be looking in other threads

edcutis 03-18-2004 09:03 PM

Use the mandrake configuration and look at your networking connection. I noticed that on mine, it put localhost (127.0.0.1) as my primary DNS lookup, and the DNS servers of my ISP as the second and third choices. I changed the order, put the ISP's DSN addresses first, and it has much faster lookups.

Hope this helps.

Edcutis

Athlon 03-18-2004 09:36 PM

its ur browser cache.

its set by default to 5mb.

change it to like 300mb.

thats all u gotta do.

Iridesce 03-19-2004 02:23 AM

Back again,

Besides the above installation, I loaded Mandrake 10.0 on a different partition and ( hangs head ) the only way I could get it to use 2.4 was to click on the LSB box in the package area of the installer. A box came back and said it would only install 2.4, so I did. After booting up that partition, I ran Mozilla ( by the way, I and still ssslllooowww .....

Just now booted to the 2.6 partition and tried I tried changing the cache in Mozilla 1.6 ( 50 meg is default ) to 150 and while it only took 2 or 3 seconds per page to navigate around the Mozilla site, it took a full ten, that's right 10 seconds to load Google. sorry athlon, nice idea ... Then checked DNS order and my local server was on top. Good idea edcutis, does seem to have something to do with DNS or connecting to the site ....

Once in Google, I could change the search query and got the page almost immediately. It seemed pretty replicable (sp?) throughout most sites.

Also, almost as startling was that I was unable to access webmin from the console or url ..
Other oddities was that although I was able to get a list of update sites, all would not connect ( possibly a timeout on the ftp site end ... )

Got tired of that and came back to my trusty Omnibook 900 ( 450 mhz I think. 128 MB ) with 9.2 and it is 5 times as fast. So am writing this on that

No doubt I am missing something easy at worst or am able to ( in my depths of ignorance about this box before me ) confirm a problem noted by another.

sidenote - Last night, I gave an old box ( AMD 500 ) to a friend my age ( late 40s ) who had never had one or been online - Win 98 so he could run aol :tisk: ( I do have the water ready for the flames ) and have fun with that part of the internet - later after a little confidence, I will introduce him to sliding on ice .... and he will love it -

For me, with Win2K at work, I use Mandrake on my home boxes and the notebook ( I do have Win98 on a partition - for my online space shooter - a whole OS for one game .... ) What I realy love though is finding out about Linux, learning and breaking things and finding out how it should work -

The point being, even as most excellently distros with training wheels ( as I understand Mandrake is ) people like me will keep coming here to search, learn and add my two cents worth. I just got a couple of Gentoo disks, though my first hour or so with it resulted in more questions.

It seems that anyone who doesn't get into the how of the way things work won't be here and probably will still have Windows - the tide is changing however.

Enjoy

/bin/bash 03-19-2004 04:17 AM

There seems to be alot of this going on lately. The consensus seems to be that ipv6 is causing it. If you want to disable ipv6 you just add the following line to either /etc/modules.conf for 2.4 kernel or /etc/modprobe.conf for 2.6 kernel.

alias net-pf-10 off

Iridesce 03-19-2004 03:39 PM

Much better
 
Thanks /bin/bash,

That helped a bunch - with the 2.6 workaround, the response time is about 3 seconds. Now I can free up the 2.4 partition and put Gentoo on it.

This workaround and the ' linux noapic nolapic' one ( for installing Mandrake 10.0 ) are golden to newbs like me.

Happy Equinox all - as of tomorrow enjoy more light than dark for 6 months.

Iridesce 03-19-2004 05:24 PM

Need to reapply workaround after update
 
Back again,

After I was finally able to run rpmdrake ( was only able to use Norway mirror, as US mirrors could not process list ?? ) and updated packages, etc/modprobe.conf had changed so I had to reapply the ' alias net-pf-10 off ' work around

Stil not as fast as I would like - wait about 3 seconds ( whine, whine, whine ) for each domain to load, then pages load almost immediately.

I do like the rest of 10.0, am playing with Kontact now...

wd8brj 03-21-2004 02:38 PM

I had this same problem with 10.0 from 9.1. Just wanted to say thanks to everyone for all the help on this one.

elfoozo 04-26-2004 09:02 PM

I'm having this same problem and about to tweak my modprobe.conf file...

Does anyone know if this issue is properly fixed these days? Like "kernel-xyz" corrects it?


All times are GMT -5. The time now is 05:57 PM.