LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   KDM broken, reboots Xserver, no desktop environmen (https://www.linuxquestions.org/questions/mandriva-30/kdm-broken-reboots-xserver-no-desktop-environmen-184551/)

vdemuth 05-22-2004 01:31 PM

KDM broken, reboots Xserver, no desktop environmen
 
For some reason, my KDM has suddenly stopped working. Where it used to show my
root and user as a choice, and the availability of kde, gnome, fluxbox, icewm
and failsafe, it now shows a session type dropdown box, which contains these
entries, plus an entry for xdcpm?.
But when I click on my user name, and choose anything other than icewm, all
that happens is my Xserver reboots back to the login screen. I can still
successfully use GDM to choose my DE, but would prefer to use KDM. This has
manifested itself since I attempted to add xfce to the dropdown menu. I have
created an entry for xfce in /etc/X11/wmsession.d, and run the chksession -k
command so that xfce appears in the dropdown menu. Trying to chase Mandys boot
process is ridiculously difficult due to the non standard way it happens. No
config files are where you would expect them to be, and the multiple shell
scripts are referenced in a way that is so convaluted that it leaves your head
spinning.
Does anyone have any clear and concise instructions, perhaps suitable for a 6
yr old, on how to get KDM to work once again.
Running genkdmconf --no-old doesn\'t do the trick either. I am at a complete
and utter loss here.
Heeelllllppp

vdemuth 05-28-2004 02:40 PM

Fixed.
I have the solution. Hurrah.
After much experimentation, this is how I did it.
Rename the file /usr/share/config/kdm/kdmrc to kdmrc.old
Rename the file /usr/share/config/kdm/kdmrc~ to kdmrc
Reboot

Don't ask me why this worked as I haven't got a clue. But it now has solved my problem

ReCover 06-28-2004 04:26 PM

you messed it up, you maybe used kate/kwrite to edit the file and then it auto created a backup of the file kdmrc to kdmrc~
and now you restored the backup


All times are GMT -5. The time now is 06:01 PM.