LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   I've broken my mandrakelinux installing perl-base (https://www.linuxquestions.org/questions/mandriva-30/ive-broken-my-mandrakelinux-installing-perl-base-246249/)

ethereal9 10-23-2004 04:04 AM

I've broken my mandrakelinux installing perl-base
 
Thanks for reading this thread. I'm sorry the thread title is a little vague but I don't know exactly what I've done.

Anyway, here is all the information I can give you - I was trying to install spamassassin on to my Mandrake Linux 10.0 using - spamassassin-3.0.0-0.rc4.1mdk.i586.rpm.

I got the following message - unsatisfied perl-Mail-SpamAssassin[== 3.0.0-0.rc4.1mdk].

I then tried to install perl-Mail-SpamAssassin-3.0.0-0.rc4.1mdk.i586.rpm and got this error message - unsatisfied perl-base[>= 2:5.8.5].

I therefore installed perl-base-5.8.5-3mdk.i586.rpm. During installation I got a warning saying that some files had to be removed before the installation could continue. I decided that it must know what it is doing and if the files needed to be removed then they would be replaced during the installation, I therefore hit continue and the installation was completed.

I then went back to install perl-Mail-SpamAssassin-3.0.0-0.rc4.1mdk.i586.rpm and the system wouldn't run the package installer so i went looking for it on the start menu and it wasn't there. There are also lots of links missing e.g. To my mail proram Ximian, to Firefox and openoffice. These are the problems that are immediately apparent I don't know the full scale of my destruction.

I thought if I started a root session everything would be okay over there but the problems are exactly the same.

So my questions are

1. If I finished installing perl-Mail-SpamAssassin-3.0.0-0.rc4.1mdk.i586.rpm and spamassassin-3.0.0-0.rc4.1mdk.i586.rpm do you think it would solve my problems? How can i intall them if I can't open the package installer?

2. I hope that I have "linking" problems and someody here will give me a magic command and everything will be fixed.

3. Where can I find a log file for the perl-base installation? I guess I can find out exactly what is broken with this log (I doubt if I'll understand the log but I could post it here).

If anybody can help at all or can answer one or all of my questions I'll be eternally grateful - please be gentle with any answers or questions because I'm a total Linux newbie (I just hate spam)

Thank you
Ethereal

Eule 10-23-2004 05:02 AM

Which command you had used to install the package?
- urpmi
- rpm
- rpmdrake

?

ethereal9 10-23-2004 05:19 AM

Thanks for replying Eule.

I double clicked on the RPM file and the software installer popped up. I assume it was rpmdrake although I didn't have a clue what it was called until you asked.

Ethereal

Eule 10-23-2004 05:34 AM

Okey. Try this.

go into shell an login as root.

type:

Code:

urpmi perl-Mail-SpamAssassin
If urpmi doesn't work you should configure it.

(If you have broadband connections). Its oft easier to use urpmihttp://easyurpmi.zarb.org

ethereal9 10-23-2004 06:01 AM

Thanks Eule that command worked and I was able to install spamassassin:)

Unfortunately it has not solved my problems:(

It was a good try though, I'll just have to try something else.

Ethereal

Eule 10-23-2004 06:26 AM

Do you know which packages were removed? or is it that your only missing the links in the menu?

please write your problems exactly. So I'll try to help you.

ethereal9 10-23-2004 06:55 AM

I'm not very sure where the files get installed to, so I don't know if they are missing.

I searched for firefox and ximian and I didn't find any but the names may be abbreviated.

I can probably install everything again but I think my main problem is that when I click on Menu-->System-->Configuration there used to be a link to package configuration which is not there now. I don't think this specific problem is not just a link in the menu because previously when I double clicked on a RPM file the software installer automatically loaded. Now when I double click it opens up a Open With dialogue box.

Eule 10-23-2004 07:18 AM

First. I've got a basic question. Have you already restarted your X, KDE/Gnome oder system?

ethereal9 10-23-2004 07:43 AM

Yes. My computer is setup to automatically start X (KDE) and logme in.

Eule 10-23-2004 07:49 AM

Quote:

Originally posted by ethereal9
Yes. My computer is setup to automatically start X (KDE) and logme in.
???. Sometimes you have to restart your X after installing any rpms. Have you already?
A short while ago I'd installed a rpm. Nothing worked until a have restart my KDE.

ethereal9 10-23-2004 07:58 AM

I have rebooted the computer so that should have restarted X I think and I still have the problem

Eule 10-23-2004 08:11 AM

I'm sorry. i can't understand it.
what happends if you type into the shell :

- firefox
- ximian
- ooffice (you was looking for?)
- rpmdrake (root only)

Have you update Mandrake 10.0 ?

In 'drakeconf' under System -> Menu -> you can update you links, you know?

ethereal9 10-23-2004 08:26 AM

Quote:

Originally posted by Eule
I'm sorry. i can't understand it.
what happends if you type into the shell :

- firefox
- ximian
- ooffice (you was looking for?)
- rpmdrake (root only)

Have you update Mandrake 10.0 ?

In 'drakeconf' under System -> Menu -> you can update you links, you know?


I typed firefox, ximian, ooffice and rpmdrake (as root) -

[ethereal@10 ethereal]$ firefox
bash: firefox: command not found
[ethereal@10 ethereal]$ ximian
bash: ximian: command not found
[ethereal@10 ethereal]$ ooffice
bash: ooffice: command not found
[ethereal@10 ethereal]$ su
Password:
[root@10 ethereal]# rpmdrake
bash: rpmdrake: command not found
[root@10 ethereal]#


I opened menudrake but I don't think that this will help as you can see above I am unable to run them from the shell so I don't think I can link to them in the menu.

Thanks for your help.
I appreciate it

Eule 10-23-2004 08:34 AM

ohhhh no. It seems you deinstalled the packages.

You can try to locate the path, but i think they are nowhere.

Code:

whereis firefox
oder somthing else

if you can find the path, check it if it there an executable.

ethereal9 10-23-2004 08:39 AM

I tried what you suggested and whereis did not find a path for firefox or more importantly rpmdrake.

Do you have any idea how to get rpmdrake working again?


All times are GMT -5. The time now is 07:29 AM.