LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   ispell/aspell in Mandriva 2007 + no office (https://www.linuxquestions.org/questions/mandriva-30/ispell-aspell-in-mandriva-2007-no-office-526804/)

High-gain 02-08-2007 01:59 PM

ispell/aspell in Mandriva 2007 + no office
 
Hi There - :)
wonder if anyone can help on this question please.

I have just loaded Mandriva 2007 and everything works great, except the spellcheck in KMail.

It keeps telling me 'not configured or wrong Path'

I have looked in 'Control Centre' and see that ispell and aspell are installed.

My question is where is ispell and aspell in the root system, and how do I configure it to

work in KMail.

I cannot check if it is working in 'openoffice' as that has only partly loaded. The wordprocessor

is not loaded and I can't seem to get that to work either. I did download a .tar from openoffice.org

but that does not work.

Hope someone can enlighten me. Many thanks

;)

-

simcox1 02-08-2007 05:54 PM

I don't use kmail, so can't help a lot, but here's a passage from the kmail handbook.

KMail will automatically check the spelling of your message (in HTML mode this currently does not work) and display unknown words using red color. If there are too many unknown words KMail will disable its checking. To select the language used for checking, select View->Dictionary. You can disable automatic spellchecking in the Options menu.
To check the spelling of your message using a dialog, select Tools->Spelling.... KMail uses KSpell to check spelling, which is the KDE frontend to the ispell or aspell spelling checker. Note that you may first need to configure the spellchecker using Settings->Spellchecker....


I'm sure somebody here uses kmail who can help more.

ernie 02-08-2007 11:46 PM

As a regular user, logged in to your regular user account, open KMail.

Go to the Settings menu and click on 'Configure KMail...'.

Select Identities at the left.

Select the Default identity in the large pane.

Click the Modify button to the right.

If you have not done so, this would be a good time to enter your information in the default identity.

Since your issue is with spell checking, click the Advanced tab.

Click the 'Dictionary:' drop down to select the Dictionary you want to use.

I have used 'ASpell Default' and 'English (United States of America)'. Both work well here.

The ASpell package must be installed for any of this to work.

HTH,

High-gain 02-09-2007 09:25 AM

Aspell
 
Hi Guys - :)

Thanks for your replies to my question on Ispell/Aspell.

Had a dig around in the Control centre and Aspell seems to be loaded ok.

Tried doing as you suggested and then opened spellchecker, it came back with this -

#Ispell/Aspell could not be started. Please make sure you have ispell/aspell properly

#configured and in your PATH.

Bit stuck here as I am not sure how to configure aspell to open in KMail.

Your help would be appreciated. Thanks.

Would be interested to know what most people find the best mail package.

Again thanks your help - Regards



-

simcox1 02-09-2007 09:45 AM

What's the output of:

echo $PATH

High-gain 02-09-2007 10:00 AM

Thanks for the quick reply - here is what I got

/usr/bin:/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/qt3//bin:/home/ user_name/bin:/usr/lib/qt3//bin

ernie 02-10-2007 01:33 AM

The aspell executable should be located in /usr/bin if it was installed from a Mandriva 2007 rpm package. /usr/bin is in your path statement. I do not think that is the problem.

You should have three packages installed:

aspell-0.60.4-3mdv2007.0 (the main aspell package)
aspell-en-6.0.0-2mdk (english language support package)
libaspell15-0.60.4-3mdv2007.0 (aspell library package)

The first listed is the main aspell package, containing the aspell executable files, filters, etc.

The second is the language support package, containing the dictionaries for the specified language.

The third is the aspell library package, containing the library files needed by aspell to run correctly.

You should be able to open the Package Manager (System / Configuration / Packaging / Install, Remove & Update Software), Click the drop-down over the category tree and select 'Installed', then enter 'aspell' (no quotes) in the Find: text entry field and press the 'Search' button. This will display a list of any aspell packages installed on your system. If you do not have the main package, the library package, and at least one language support package listed, that is why spell checking does not work in KMail.

HTH,

High-gain 02-10-2007 04:43 AM

:)

Hi Ernie - many thanks for the help and info. Just been looking at the installed

packages and have not got the #aspell-en-6.0.0-2mdk (en lan support) installed, and

cannot find it anywhere. Will double check again for this package.

Also loaded is this package:- #aspell-or-0.03.1-1mdk - not sure what this is though.

I wonder is it possible to do a urpmi for these packages.

Thanks again for you input, most appreciated.

Regards ;)

ernie 02-10-2007 08:26 PM

If your native language is English, you should install aspell-en-6.0.0-2mdk, but if your native language is any other language, you should install the language support package for your native language.

As for the package you report (aspell-or-0.03.1-1mdk). It is a language support package and the package manager provides the following information:

aspell-or - Oriya files for aspell

A Oriya dictionary for use with aspell, a spelling checker.

If Oriya is your native language, you have the correct package installed. If it is not, inform me of your correct native language (the one your Linux installation is set up to use), and I will try to help further.

Are the other two packages installed?

aspell-0.60.4-3mdv2007.0 (the main aspell package)
libaspell15-0.60.4-3mdv2007.0 (aspell library package)

If they are not install them with urpmi:

urpmi aspell

HTH,

High-gain 02-11-2007 04:24 AM

Hi Ernie :)

All copied on your info, so thanks for that.


These two packages are installed ok -

#aspell-0.60.4-3mdv2007.0 (the main aspell package)
#libaspell15-0.60.4-3mdv2007.0 (aspell library package)


But the following is not installed -

#aspell-en-6.0.0-2mdk

This I think from your info is the English native language package
that I should have.

Not sure where I would get that from. Perhaps one of the RPM sites?

#It does seem to me that the installation CD's 1/2/3/4/ that I downloaded
from one of the mirrors, has a few hic-cups or bits missing. Wonder if you
downloaded your 2007, if so, did you have any problems. Apart from these
few minor things, this has been the best (for me) Mandrake 10 thru Mandriva 2007
distro. This one seems very stable, only had the adsl drop out a couple of times,
and this was soon fixed thru /rc.d/init/ (I am using a modem, not ether cable).

Anyway thanks again for you help, most appreciated. ;)

simcox1 02-11-2007 05:01 AM

What packages are listed when you type:

urpmi aspell

in a console. It's odd that you don't have the aspell-en package, but you do have the aspell-or one.

wildar 02-11-2007 05:39 AM

If you still have trouble getting it via urpmi, then try downloading from here: i586 version, or x86_64 version

Once you get it installed, might want to update your urpmi.conf. Visit http://easyurpmi.zarb.org/ and follow the instructions.

Hope this helps.

High-gain 02-11-2007 10:57 AM

Thanks Simcox/Wildar for your imput -

Yes it does seem a bit odd that aspell-en is not installed. I did think I
might have been using the install/uninstall feature wrong. But tried
several different ways, even searching for it, (as suggested by Ernie).

Have tried #urpmi aspell - it comes up with 'The package is already installed'.

Just tried the link Wildar gave me which worked a treat. I have downloaded and

installed with the 'Software Installer' - will log out now and report back

on whether it installed ok.

Many thanks again, much appreciated - Regards ;)


-

wildar 02-11-2007 01:39 PM

Glad you got it sorted.

Quote:

Originally Posted by High-gain
Have tried #urpmi aspell - it comes up with 'The package is already installed'.

Seems to me reason for this is you "did" have aspell installed, but needed to be a bit more explicit with the package name. My guess if you had to do it again, then 'urpmi aspell-en' might have done the trick.

Cheers

High-gain 02-11-2007 01:54 PM

Hi Guys :)

Sadly #aspell is still not working. After I installed
with the RPM software installer, I did think that everything
would be ok. Tried it again and it is still coming up with

#The package is already installed, please configure the
correct PATH.

So guess I will have to try and work on the PATH again.

This is what I get when I #echo $PATH

/usr/bin:/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/qt3//bin:/home/user_name/bin:/usr/lib/qt3//bin

Any suggestions on what I can do next?

Thanks for you time and attention

Regards ;)


All times are GMT -5. The time now is 05:31 AM.