LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 04-09-2005, 01:33 PM   #1
shocker-z
LQ Newbie
 
Registered: Apr 2005
Location: nottingham
Distribution: Debian 3 & Mandrake 10.1
Posts: 11

Rep: Reputation: 0
internet settings


Hi I have 2 NIC's: ADMtek|ADM983 & Realtek|RTL-8139
and I can't get either to connect to the internet Iím using a router 192.168.1.1 as my gateway and DNS but its still not working and every time i restart, the DNS changes to 127.0.0.1, Iíve tried this with both card and Iíve also tried setting them to DHCP but no luck what so ever! Both cards worked when I had Debian on with a 2.2 kernel but seem to have problems with anything above 2.2 kernels.

setting card IP as 192.168.1.4
running Mandrake 10.1

Any help will be greatly appreciated

Last edited by shocker-z; 04-09-2005 at 02:00 PM.
 
Old 04-09-2005, 02:36 PM   #2
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 69
hi there

when u are not able to connect to the internet then post the output of

ifconfig

and route -n

and the contents of the file

/etc/resolv.conf

regards
 
Old 04-09-2005, 05:57 PM   #3
shocker-z
LQ Newbie
 
Registered: Apr 2005
Location: nottingham
Distribution: Debian 3 & Mandrake 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
ifconfig
lo Link encap:local loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/12/8 Scope:Host
UP LOOPBACK RUNNING MTU:16436 METRIC:1
RX Packets:36241 errors:0 dropped:0 overruns:0 frame:0
TX Packets:36241 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2420670 (2.3 Mb) TX bytes:2420670 (2.3 Mb)

route -n

Kernel IP routing table
Destination Gateway Henmask Glags Metric Ref Use IFace

/etc/resolv.conf

search net local
#search net local net net local net net net net local net net net net net local net net net net net net net net net net net net net net local
nameserver 192.168.1.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1

# PPP temp entry


i take it form ifconfig that ive not done somthing right being as it doesnt list eth0 or eth1 any help will be appriceated

thanx masand
 
Old 04-09-2005, 10:10 PM   #4
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 69
hi there

try this
for one NIC
assign static IP address
with gateway as that of ur router and dns server the same
and they try accessing the internet ,and if it still does not work then again give me the O/P of the above commands

regards
 
Old 04-10-2005, 08:22 AM   #5
shocker-z
LQ Newbie
 
Registered: Apr 2005
Location: nottingham
Distribution: Debian 3 & Mandrake 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
ive tryed that, and thats what messages i get, thats what i donbt undertsand, ive tryed it on both crads, doing it wiht one and removing the other for both static and DHCP and neither ways are working! yet both cards are detected and i know the cable is working because all lights are on both router and card and all works fine in 2.2 kernel. :S
any ideas?

thanx
liam
 
Old 04-10-2005, 02:13 PM   #6
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 69
assign static ip address then run

route add default gw 192.168.1.1

and check that u have 192.168.1.1 in /etc/resolv.conf

and if it still doe snot work then post the O/P of

ifconfig

and route -n

regards
 
Old 04-10-2005, 04:57 PM   #7
shocker-z
LQ Newbie
 
Registered: Apr 2005
Location: nottingham
Distribution: Debian 3 & Mandrake 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
hi, before i do that you should see this erorr that ive just realised i get on boot (dont normaly see becaus eu have to press esc)

Bringing up loopback interface: [OK]
Bringing up interface eth0: interface 'eth0' not found
interface 'eth0' not found
/bin/true
tulip device eth0 does not seem to be present, delaying initialization
[Failed]
Bringing up interface eth1: Failed to bring up eth1.
SIOCSIFFLAGS: Function not implemented
[Failed]


any help?

thanx

liam
 
Old 04-12-2005, 07:04 AM   #8
iwpcs
LQ Newbie
 
Registered: Apr 2005
Location: Isle of Wight (UK)
Distribution: Assorted Mandrake
Posts: 23

Rep: Reputation: 15
Hi

Looks like the modules are not being loaded for your network card(s)

We will try using the realtek card (same as in my desktop)

You can check if the module is loaded with
Code:
lspci | grep 8139too
if it returns nothing, the module is not loaded.

If not, type (as root)
Code:
modprobe 8139too
which will try to load it for you - you should get some feedback.

To make this permanent, stick the following in /etc/modprobe.conf :
Code:
alias eth0 8139too
and comment out anything else with eth0 or eth1 in it by putting a # at the beginning of the line. This should enable the driver module to load on booting. You need to log on as root for this.

You may find it all works after a reboot, but if not check out my Mandrake simple net setup howto at www.iwpcs.co.uk/simple_net_setup.html. If you still have problems, the bottom of the page has a few commands you can post the output of here for further help. Add lspci to this list.

Good luck!
Chris
 
Old 04-12-2005, 05:00 PM   #9
shocker-z
LQ Newbie
 
Registered: Apr 2005
Location: nottingham
Distribution: Debian 3 & Mandrake 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
i did
modprobe 8139too
and received nothing on the screen it just accepted it, reinstalled mandrake to clkear all drivers and everything and followed that site and still not working im now getting
Bringing up interface eth0... failed
i have tryed a bran new network card and that comes up with the same error
ive added 8139too to /etc/modprobe.preload but still not working
now comes up with failed to bring up eth0

any ideas?
 
Old 04-12-2005, 10:58 PM   #10
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 69
post what u have in

/etc/sysconfig/network-scripts/ifcfg-eth0
 
Old 04-13-2005, 01:36 AM   #11
iwpcs
LQ Newbie
 
Registered: Apr 2005
Location: Isle of Wight (UK)
Distribution: Assorted Mandrake
Posts: 23

Rep: Reputation: 15
Ok

One thing at a time...

'failed to bring up eth0' messages at boot time is not uncommon and does not always spell doom.

Not printing anything to the screen is usually a good thing in the Linux world - it usually means it worked!

So type modprobe 8139too again.

Then type lsmod - if there is 8139too listed, then the module is inserted OK. If not, we need to look further in to it.

Put the alias line into /etc/modprobe.conf. I find It best to not put anything in /etc/modprobe.preload

Any chance of removing the second network card, or disabling it in the BIOS if it's onboard?

Don't use any of the Mandrake wizards.

Don't keep re-installing.

You didn't follow the instructions in the link - you haven't posted the list of command results at the end!
Add lsmod to this. We need these to help.

Don't give up!
Chris
 
Old 04-13-2005, 03:51 PM   #12
shocker-z
LQ Newbie
 
Registered: Apr 2005
Location: nottingham
Distribution: Debian 3 & Mandrake 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
ok i have just the realtek card in now.
i did
Code:
modprobe 8139too
then
Code:
 lsmod | grep 8139too
and that returned
Code:
8139too   20928   0
mii   4224   1   8139too
i then went to add line: alias eth0 8139too but it was already there
i then did
Code:
lspci | grep 8139too
and it returned
Code:
00:0c.0 Thernet Controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
restarted the system and still coming up that it failed

any more sugestions?

sorry for being such a pain, i did follow every single instruction on that page, i was very tired and kinda just didnt mention everything, sorry for that.

Last edited by shocker-z; 04-13-2005 at 03:54 PM.
 
Old 04-13-2005, 04:45 PM   #13
iwpcs
LQ Newbie
 
Registered: Apr 2005
Location: Isle of Wight (UK)
Distribution: Assorted Mandrake
Posts: 23

Rep: Reputation: 15
The system can see the card - that's good.

Remember, don't worry too much about the failed message at the moment.

If you do an lsmod | grep 8139too after the reboot, without typing the modprobe command, do you get the same result?

If so, the module is being loaded OK and we just need to check your settings, so post the output of :

ifconfig

route -n

and the contents of /etc/sysconfig/network-scripts/ifcfg-eth0

and we'll see what we can do.

Chris
 
Old 04-14-2005, 02:44 AM   #14
shocker-z
LQ Newbie
 
Registered: Apr 2005
Location: nottingham
Distribution: Debian 3 & Mandrake 10.1
Posts: 11

Original Poster
Rep: Reputation: 0
yep "lsmod | grep 8139too" is returning the same results

IFCONFIG
lo Link encap:Local Loopback
Inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:31366 errors:0 dropped:0 overruns:0 frame:0
TX packets:31366 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2445976 (2.3 Mb) TX bytes:2445976 (2.3 Mb)

/etc/sysconfig/network-scripts/ifcfg-eth0
Code:
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.1.4
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes
MII_NOT_SUPPORTED=yes
"ifup eth0" returns
Code:
SIOCSIFFLAGS: Function not implemented
Failed to bring up eth0.
what next mate? any chance of talking over msn one night or somthing? might be able to get it sorted bit quicker, else we could use irc if your into that? irun a network so that would be fine.

thanx mate
 
Old 04-14-2005, 03:29 AM   #15
iwpcs
LQ Newbie
 
Registered: Apr 2005
Location: Isle of Wight (UK)
Distribution: Assorted Mandrake
Posts: 23

Rep: Reputation: 15
Hello again

I don't have any sort of chat stuff set up, but perhaps I should...

I wonder if the onBOOT in /etc/sysconfig/network-scripts/ifcfg-eth0 needs to be in all UPPER CASE and is causing the SIOCSIFFLAGS problem? Just guessing. Try changing it and rebooting, assuming it was not just a typo in the post.

Quote:
yep "lsmod | grep 8139too" is returning the same results
Sorry, I should have been clearer - I meant the same results as
8139too 20928 0
mii 4224 1 8139too

Is that what you mean too - what you are getting after a reboot, without doing anything else?

If so, the modules are being loaded - the interface should work, so your next step is to try to bring the interface up manually:
Code:
ifconfig eth0 192.168.1.4 up
then type ifconfig to see if it worked - post the output.

If the modules are not being loaded. Have a look in the logs for any messages.

Chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet speed settings? MRDucks Mandriva 9 10-17-2005 04:15 AM
help with Internet connection settings... breezewax Linux - Newbie 6 08-13-2005 10:44 PM
Messed up my internet settings (NO internet connection) :( Almazick Linux - Networking 2 09-08-2004 12:05 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 06:23 PM
Internet Settings in Mandrake 9.1 marvelous Linux - Networking 1 03-03-2004 08:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration