LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 02-03-2004, 03:58 PM   #1
Whatshisface
Member
 
Registered: Aug 2003
Location: Chesapeake Beach, MD
Distribution: Mandrake 9.2
Posts: 58

Rep: Reputation: 15
installing samba from Mandrake 9.2 CDs


I want to install samba from the distribution CDs (Mandrake 9.2).
Which files do I need to install. I have found three files so far: samba-client-2.2.8a-13mdk.i586.rpm samba-server-2.2.8a-13mdk.i586.rpm
samba-common-2.2.8a-13mdk.i586.rpm
I also don't know the correct command for installing, options, etcetera and where to intall to.
I am currently sharing a DSL connection with two Windows 98 machines. Now I want to share files and a printer.

Last edited by Whatshisface; 02-03-2004 at 08:46 PM.
 
Old 02-04-2004, 01:26 AM   #2
di11rod
Member
 
Registered: Jan 2004
Location: Austin, TEXAS
Distribution: CentOS 6.5
Posts: 211

Rep: Reputation: 32
Open a terminal window, cd to the directory containing the rpm files and type --

rpm -i samba-common-2.2.8a-13mdk.i586.rpm
rpm -i samba-server-2.2.8a-13mdk.i586.rpm
rpm -i samba-client-2.2.8a-13mdk.i586.rpm

If you get some complaints about dependencies, type, urpmi -i samba-server-2.2.8a-13mdk.i586.rpm instead.

Good luck,

di11rod
 
Old 02-05-2004, 10:17 PM   #3
Whatshisface
Member
 
Registered: Aug 2003
Location: Chesapeake Beach, MD
Distribution: Mandrake 9.2
Posts: 58

Original Poster
Rep: Reputation: 15
I can't find one of the file dependencies for samba-common. Here's an excerpt:
[jay@141 RPMS]$ rpm -i samba-common-2.2.8a-13mdk.i586.rpm
error: Failed dependencies:
libacl.so.1 is needed by samba-common-2.2.8a-13mdk

Where abouts is this file? I've tried all three disks in the Mandrake/RPMS directories.
 
Old 02-06-2004, 05:55 AM   #4
di11rod
Member
 
Registered: Jan 2004
Location: Austin, TEXAS
Distribution: CentOS 6.5
Posts: 211

Rep: Reputation: 32
I'm a big fan of Mandrake. I've been using it since 8.0.

One thing that bugs me is the default package installation based on whether you choose 'development' or 'multimedia station' or whatever during the upgrade or installation. If you don't choose development, then adding ANY package later on is absolutely impossible without running down a bunch of dependencies....

Now that that rant is over, try typing this:

rpm -i ftp://rpmfind.net/linux/Mandrake/9.2...-2mdk.i586.rpm

Just about everything on the CDs is in this directory:

ftp://rpmfind.net/linux/Mandrake/9.2...Mandrake/RPMS/

rpm will work over ftp or http without a problem. Just type rpm -i <URL> and it'll install from the remote location.

good luck,

di11rod
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing samba server in Mandrake 9.0 StewieG Linux - Networking 3 05-18-2005 03:16 PM
Installing Samba on Mandrake WESS126 Linux - Software 1 02-21-2005 10:41 AM
Installing Slackware 10.0 without the CDs? Makaelin Slackware 2 08-27-2004 05:50 AM
Installing Debian - Which CDs Lucasite Debian 1 03-13-2004 12:15 PM
Which CDs for Mandrake 9? Artamir Linux - Distributions 24 01-23-2003 02:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration