LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Installing .rpm and .tar.gz (https://www.linuxquestions.org/questions/mandriva-30/installing-rpm-and-tar-gz-203939/)

smsmatat 11-24-2005 03:55 PM

I want ask a question:
Why when installing a package one faced with dependency problems?
why the package to be installed doen't contain all it needs and install the missing packages only?

jjmac 11-26-2005 03:28 AM

Because that would be a wast of bandwidth. And it would tend to duplicate various facilities contained in the down load.

Once a particular dependency is available, often it will also be used by other packages. Also, quite a number of the required dependencies will be available anyway -- if the installation involves a complete cd set, or iso image.

It can be difficult for an author to know what just a person will have already installed, so including everything in the one package would eventually lead to complaints on its bloated size. Especially from dialups like myself (grin).

Most dependencies will just consist of the header files and static link libs required for source compilation. While others will relate to libraries that provide special functionality that the program draws on. Particularly if there maintained/developed by a separate project. Such as sound daemons for a media related application, or a compression library for a media/graphics conversion program, but one that may also be used by other programs as well.

As for the header/static link lib type of dependency for source compiles, they will likely have the name "dev" in their package name.

A lot of these packages will likely be found on the installation cd(s) for your distro but arn't always installed as part of the initial install process due to them not necessarily being often used, or immediately necessary to get up and running. So look on the cd(s) first.

And, as has been mentioned before back in this interesting thread -=- check out your distros site repositories first for ... hopefully ... best compatibility.

Admittedly though, dependencies can be a right pain in the butt at times (grin).


jm

PS -=-=-=-

Is it just me, or --- ummm --- why is this submit edit box so incredibly tiny. Weird as :roll:, hope all this wraps ok :)


jm

smsmatat 11-27-2005 01:23 PM

Thanks for these valiable information.

phaserule 12-15-2005 02:02 PM

thank you thank you thank you ... threads like this instill little more tenacity

randell6564 01-12-2006 04:25 PM

Hello everyone!
I was wondering if you, 'Motub' could tell me what it is that i am suppose to "type in" at step 3 of the 'easy urpmi' web sight?

the link seems to be broken or i am doing something wrong.

Cancel That! I was clicking on the wrong tab! alls-well!

Have A Great Day!

bobbelfield 01-24-2006 05:04 PM

gp42 -buy a recent linux magazine ..were up to Mandriva 2006 now
For those using Mandriva the package software update facility in the packages menu seems to avoid all this and give you hasslefree updates

Edit --learning a little more the UrpmI / plf updates are for the stuff the official site cant give you so you need to go there specially if you want the videos to play

randell6564 01-24-2006 09:46 PM

Thanks!! but all is taken care of !

balansero 02-15-2006 10:24 AM

Quote:

Originally Posted by zulfilee
For RPM

rpm -ivh packagename -> TO install package

rpm -qip packagename ->To view package information before install

rpm -e packagename ->To uninstall package

rpm -q package ->To view if package is already inastalled




For tar.gz and tgz Both are same files with different extensions.

less filename ->TO view contents

tar -zxvf filename ->To untar the files

And if it has a READ me follow it for install[Normally ./configure , make and make
install is used .But see READme first before installing]


Cheers
Z


Pleace do you know a good website where can I download software(tgz;rpm) for mandrake 10.1 Thank you.

Padma 02-15-2006 11:26 AM

The absolute best place/method, is http://easyurpmi/zarb.org. Follow the instructions there, and you can get thousands of software packages tailored explicitely for Mandrake 10.1, all through the rpmdrake package manager (menu: Star --> System --> Configure --> Configure Your Computer).

dcliett 05-25-2006 10:33 AM

Hey I tried to get the mirrors added and this is the output.
[root@localhost dcliett]# urpmi.addmedia main ftp://ftp.phys.ttu.edu/pub/mandrakel...Mandrake/RPMS/ with ../base/hdlist.cz
using different removable device [/dev/ide/host0/bus1/target1/lun0/cd] for "Installation CD 1 (x86) (cdrom1)"
using different removable device [/dev/ide/host0/bus1/target1/lun0/cd] for "Installation CD 2 (x86) (cdrom2)"
using different removable device [/dev/ide/host0/bus1/target1/lun0/cd] for "Installation CD 3 (x86) (cdrom3)"
using different removable device [/dev/ide/host0/bus1/target1/lun0/cd] for "Installation CD 4 (x86) (cdrom4)"
added medium main
urpmi database locked
Did I succeed or not please?

Pyrate_02 05-27-2006 08:02 PM

URPMI database
 
I am trying to add a local directory (OpenOffice 2.0) to my media manager, and I keep getting:"urpmi database locked". I checked the permissions on every thing with urpmi in its name. No help. How do I unlock it so I can add some local files?

Emmanuel_uk 06-09-2006 01:46 AM

alternative to easyurpmi (but not a mirror)
 
I saw and heard once of a website equivalent to easyurpmi
It is not a mirror; it is organised very differently, possibly
hosted in germany, not sure (still in English); I think it was claimed
it had added features or easier use than easyurpmi

Can anybody post a link to it?

I have googled with no success (that is the nag sometimes when you know it is
there but one cannot find it). For the life of it I cannot remember the name.

I read the whole sticky, it is not listed
(I do not think I am deluded)

I am asking for completeness of reference in the thread,
not necessarily for personal usage

FOund IT !
http://www.mandrivauser.de/smarturpmi/

foxmuldar 06-13-2006 08:03 PM

I tried to install an RPM and got this...what happen?

matrix:/home/fm# rpm -ivh LimeWireLinuxPro4.10.0.rpm
bash: rpm: command not found

Thanks in advance for the help...
foxmuldar,

randell6564 06-13-2006 08:29 PM

Quote:

Originally Posted by foxmuldar
I tried to install an RPM and got this...what happen?

matrix:/home/fm# rpm -ivh LimeWireLinuxPro4.10.0.rpm
bash: rpm: command not found

Thanks in advance for the help...
foxmuldar,

Not sure about what you are running onyour box. I wiped my mandriva a long time ago!

But try this :http://www.frostwire.com It is the EXACT same thing as 'LimeWire' only it installs alot easier!

Good Luck!

iqbala 06-22-2006 08:36 AM

I thank you everybody for the valuable informations.

Motub, I learnt, thanks to you, how to use rpmdrake, and It has ben a great improvement, but still I would like to understand some more about the system itself. You wrote, in one of the very first posts:

"Mandrake puts its libs or other dependent files in a custom location not referenced by the ./configure or Makefile of the developer of the program, so they are not found, and naturally this user does not have a clue how to fix such a problem. When was the last time you saw a README or INSTALL file in a source tarball that contained specific editing instructions for Mandrake, as opposed to, say Debian?"

Where can I find information about which are exactly the difference between Mandrake and "standard" Linux as for libs locations and so on? How do I learn to edit ./configure or make file in order to adapt it to Mandrake?

RPM repositories does not always contain everything... For example, I really don't find Firefox 1.5 for Mandrake 10.1, so I will have to resort to source...


All times are GMT -5. The time now is 08:37 AM.