LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Installing .rpm and .tar.gz (https://www.linuxquestions.org/questions/mandriva-30/installing-rpm-and-tar-gz-203939/)

motub 11-03-2004 04:50 AM

If you are logged in as root, and you have put the file on the desktop (meaning root's desktop), then the path you are using is wrong (should be /root/desktop/rh9.messenger-1.0.4-1i386.rpm). What your advisor told you is true only if you are logged in as a user (because programs can only be installed by root-- a "$" prompt indicates a user-access terminal, and a "#" prompt indicates a root-access terminal).

Alternatively, you could actually look in your file manager, and find out just where the file is and use the correct path.

As another alternative, you could just install GAIM (if it is not installed), since that also connects to the Yahoo network (as well as ICQ, MSN, and others).

In future, please start a new thread, or search the forums for similar problems; I'm sure this is not the first time this has been asked, and hijacking threads is not good forum etiquette.

I've only answered this because of the 'urgency' of your problem and the fact that it is related in some degree to the title of this thread.

I_wish 11-03-2004 05:10 AM

I want to thank you so much!!! and i'm sorry for the inconvenience, but it's the first time when i post something on this forum, but i promise it will never happen again!! Thank you!!

xbaez 11-05-2004 12:57 PM

Hello

I am trying to install kdemultimedia3.2.3-14mdk package.

However it sais that I need other package in order to install that one

Therefore, I try to install the:
kdemultimedia-kaboodle-3.2.3-14mdk package, and then I see the following error:

"Sorry, the following package can't be selected.................... due to unsatisfied libkdemultimedia1-kaboodle[==1:3.2.3-14mdk]

However, when I try to install the libkdemultimedia1-kaboodle package, the only version that I have is the following:

Name: libkdemultimedia1-kaboodle-3.2.3-13mdk
Size: 0 kb


Did I downloaded the libkdemultimedia1-kaboodle-3.2.3-13mdk wrong?

or is there any other problem?
Regards

motub 11-05-2004 01:19 PM

Would you please go back to the first page of this thread, and read the instructions in the third post for how to set up URPMI on your system. A Mandrake user should never have to manually seek and download any Mandrake packages-- urpmi downloads and installs all packages with their dependencies automatically.

allforcarrie 11-08-2004 02:01 PM

I am in way over my head. I am reading this an it just doesnt click. I tryed to type these commands as root but nothing happens. I am trying to install "alsa-driver-1.0.6a.tar.bz2" to hopefully get my sound going.

thug_poet22 11-19-2004 01:15 AM

Hey, i tried installing gaim, and this is what i got



[thugpoet@ool-18b859d0 thugpoet]$ su
Password:
[root@ool-18b859d0 thugpoet]# rpm -ivh gaim-1.0.3-0mdk10.0.i586.rpm
error: open of gaim-1.0.3-0mdk10.0.i586.rpm failed: No such file or directory


If im not mistaken, you can change directory with cd, but i was unsure how to make it the directory that my current file is in. My file is located at

file:/home/thugpoet/Documents


I know this is such a newbie questions but i just need a little assitance. Thanks in advance.

imagineaxion 11-19-2004 03:59 AM

Quote:

If I'm not mistaken, you can change directory with cd, but i was unsure how to make it the directory that my current file is in.
you need to type:
Code:

[root@ool-18b859d0 thugpoet]#cd Documents
and then the command to install

or you can just use:
Code:

[root@ool-18b859d0 thugpoet]# rpm -ivh /Documents/gaim-1.0.3-0mdk10.0.i586.rpm

thug_poet22 11-19-2004 04:32 AM

Thanks a lot for you help, it really got me over that lil hump, but i've seemed to have run into another bump in the road. And i dont want to always be fed answers, so if u find threads on LQ that can help me... please direct me there. But im still trying to install Gaim and this is how far i've gotten.


[thugpoet@ool-18b859d0 thugpoet]$ su
Password:
[root@ool-18b859d0 thugpoet]# cd Documents
[root@ool-18b859d0 Documents]# rpm -ivh gaim-1.0.3-0mdk10.0.i586.rpm
warning: gaim-1.0.3-0mdk10.0.i586.rpm: V3 DSA signature: NOKEY, key ID 4c292fcc
error: Failed dependencies:
libgtkspell.so.0 is needed by gaim-1.0.3-0mdk10.0
[root@ool-18b859d0 Documents]#

How do i get past these dependencies? Thanks a lot.

imagineaxion 11-19-2004 05:43 AM

try using URPMI
there are instruction on how to do these further back in this thread.

but just to recap...

go to
http://easyurpmi.zarb.org/

follow the instruction and then copy and past the results in the terminal one at a time as root user (su)

then go to the MCC (mandrake control centre) -> software management or something and then install software.
you can do a search to find it in there.

this is the best way and using this method will solve the dependencies and install them for you.

if you go to the MCC there is a version in there already without having to add the urpmi lists. again this is mdk 10.1 and i'm not too sure about the previous versions.

also please specify which distro version etc you are using, this will help us help you :)

mostwanted 11-20-2004 12:06 AM

Quote:

Originally posted by imagineaxion
try using URPMI


go to
http://easyurpmi.zarb.org/

This site is not working for me

thug_poet22 11-20-2004 01:33 AM

nope that site does not work, but im gonna do more research and figure it out. Hey i installed Firefox (im sooooo happy, my first install, by myself, with the help of the board of course) But now im trying to figure out how to run it. Its not in the start menu where the other apps are. If anybody can help, it would be a pleasure.

I think i might have messed up one of my programs, installed Firefox, but i cant figure out how to run it.

fsman 11-20-2004 08:16 AM

easyurpmi.zarb.org
 
is there an alternative site/mirror to easyurpmi.zarb.org.
Looks like its out of actionhttp://images.linuxquestions.org/questions/images/icons/icon9.gif
Unhappy

imagineaxion 11-20-2004 10:48 AM

OK...

this is very strange (easyurpmi) i checked the url before i posted it - i have seen this before though. give it another try tomorrow or Monday


thug_poet22
i had this too when i installed it. you need to cd to the directory that firefox is in and then type ./firefox or you can browse to it in konqurer and click on the firefox icon to run it (but this is a pain in the a$$ to do everytime.

So to solve this i just made a copy of the mozilla icon in the quick launch part of the start panel (i remove some open office thing i think to make space) then i right clicked on it, selected properties and changed the path etc in there.
you can also change the icon by clicking on the icon in the properties window and browsing to the place where you installed firefox and there is an icons folder there :)

xbaez 11-21-2004 08:50 PM

which is a good ftp repository for downloading updated software for Mandrake, such as Gaim?

I want to use Yum in order to have my Mandrake system up2date :)

mostwanted 11-22-2004 10:38 PM

ok, I got the easy urpmi to download, but I have another problem.

I read the instructions for opening a tar file but I keep getting an error for a tar I am trying to uncompress. I havn't tried to untar anythig else yet tho. I have been trying to get macromedia flash player installed first so I can use more of the net first. Anyone have a problem with this? Should I start another thread for better visibility?


All times are GMT -5. The time now is 11:51 AM.