LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Installed nvidia driver, now everything is gigantic (https://www.linuxquestions.org/questions/mandriva-30/installed-nvidia-driver-now-everything-is-gigantic-439136/)

foodhater 04-26-2006 05:37 PM

Installed nvidia driver, now everything is gigantic
 
Hi,
I followed this guy's http://www.linuxloader.com/modules.p...howpage&pid=25 instructions on installing the Nvidia driver (NVIDIA-Linux-x86-1.0-8756-pkg1.run) in Mandriva 2006. Everything seemed to be going fine until I did a startx. X came up and everything is gigantic. My icons are the size of tangerines. So I went to the display settings to change the resolution but it reads 1024 x 768 which is what I normally use but it looks more like 160 X 42 or something. I can tell that the Nvidia driver is installed because when I reboot I get the Nvidia splash screen but then I still get this gigantic resolution. Any help, thanks.

foodhater 04-26-2006 06:08 PM

Oh, I am using kde 3.4.
Also, Gnome is doing the same thing. Everything is huge.

help!!!!

foodhater 04-26-2006 07:31 PM

does anyone know the command to reconfigure x? this doesn't work
dpkg-reconfigure xserver-xfree86

can't do much on this computer right now everything is huge

GlennsPref 04-26-2006 09:04 PM

there is a setting for virtual display in /etc/X11/xorg.conf

anyway, make sure both the display size and the virtual screen size are the same.


Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection

Same size for all colour depths.

Also check your frequencies, and make sure they're within the parameters of your display capabilities.

nvidia readme may give you some clues too

foodhater 04-26-2006 09:29 PM

This is my /etc/X11/xorg.conf


Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "CPD-200ES"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 120.0
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_120" 262.44 1400 1520 1672 1944 1050 1051 1054 1125 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_100" 214.39 1400 1512 1664 1928 1050 1051 1054 1112 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_85" 179.26 1400 1504 1656 1912 1050 1051 1054 1103 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_50" 99.88 1400 1480 1624 1848 1050 1051 1054 1081 -HSync +Vsync
EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Mar 29 14:43:26 PST 2006

# File generated by XFdrake.
# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1" 0 0
EndSection

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)

# allows the server to start up even if the mouse does not work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1400 1050
EndSubsection

Subsection "Display"
Depth 15
Virtual 1400 1050
EndSubsection

Subsection "Display"
Depth 16
Virtual 1400 1050
EndSubsection

Subsection "Display"
Depth 24
Virtual 1400 1050
EndSubsection
Option "DPMS"
EndSection

xi0nic 04-26-2006 11:39 PM

Quote:

Originally Posted by GlennsPref
there is a setting for virtual display in /etc/X11/xorg.conf

anyway, make sure both the display size and the virtual screen size are the same.


I'm having this same issue >< Looking at the xorg.conf, all of my Virtual resolutions are the same. Glenn mentions that one has to make the actual display size match the virtual screen size... but I see no option here to change the actual display size.

Help :(

foodhater 04-27-2006 12:06 AM

I'm not sure if it means anything but one thing the howto says is this:

"In order to ease the install of the new driver we will have to remove the old driver along with the dkms modules. So open the "Remove Software" tool and do a search for Nvidia."

I did that but the remove tool didn't find any of those
things so I went ahead with installing the driver

GlennsPref 04-27-2006 05:54 AM

Make sure dkms is turned off in mdk control center, system window. service start options boot time

GlennsPref 04-27-2006 05:59 AM

Set all of those virtual display sizes to 1024 768,

Not too sure where I read it, it won't hurt

Maybe in one of the 8 or 9 install howto's I read trying to get my

ATI drivers installed.

My other machine (old one) has a gforce4 card and I did all that reading back then too.

Config files are the ones you need, Like a walk through you can print out.

Some things are marked as default, but won't work, you need these docs.

jolphil 04-27-2006 07:59 AM

Hi,
If you can get to the icon of the little TV screen just by the speaker icon near the clock on the bottom right of your screen then you can click on it and select 1024x768 screen resolution like others have suggested..This may be the easy GUI way of setting your resolution..
Goodluck,
jolphil

foodhater 04-27-2006 09:58 AM

I set all the virtual display sizes to 1024x768 but it's still doing the same thing. Normally I would just re-install the whole sysyem but I spent a lot of time getting multimedia to work, etc. If anyone knows how to uninstall the Nvidia driver let me know. I searched for "uninstall nvidia driver" but didn't come up with much. Thanks.

foodhater 04-27-2006 06:18 PM

OK, I got my screen resolution back to normal but I had to uninstall the Nvidia driver. Here's how I did it:

1. Stop X (control-alt-f1, log into root, init3)
2. Uninstall Nvidia driver: $nvidia-installer --uninstall

GlennsPref 04-27-2006 08:23 PM

I can only suggest that you cross reference that doc with some others

You may find discrepancies between that and others, like

http://www.linuxquestions.org/linux/...drivers_on_FC3

http://www.linuxquestions.org/linux/...n_5_EASY_Steps

Also, a search of these forums may uncover similar threads that may help you.

GlennsPref 04-27-2006 08:44 PM

ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616


# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_120" 262.44 1400 1520 1672 1944 1050 1051 1054 1125 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_100" 214.39 1400 1512 1664 1928 1050 1051 1054 1112 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_85" 179.26 1400 1504 1656 1912 1050 1051 1054 1103 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -HSync +Vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1400x1050_50" 99.88 1400 1480 1624 1848 1050 1051 1054 1081 -HSync +Vsync
EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Mar 29 14:43:26 PST 2006

valyo_bg 05-04-2006 03:50 AM

Hi,
To resolve this, I disable all modelines on my xorg.conf:

# modeline generated by gtf(1) [handled by XFdrake]
#ModeLine "1400x1050_50" 99.88 1400 1480 1624 1848 1050 1051 1054 1081 -HSync +Vsync

and change virtual resolution regarding my monitor possibilities - 1024x768. Now everythink work fine for me.
Regards,
Valentin


All times are GMT -5. The time now is 04:49 AM.