LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Install: Error message says CD does not appear to be Mandrake CD, try another one. (https://www.linuxquestions.org/questions/mandriva-30/install-error-message-says-cd-does-not-appear-to-be-mandrake-cd-try-another-one-200541/)

mind2work 07-02-2004 11:08 PM

Install: Error message says CD does not appear to be Mandrake CD, try another one.
 
I downloaded the three iso files from the net and am trying to install Mandrake 10 from those. I extracted the iso files using ISOBuster and burned them and the file cdrom.img to CD to make it bootable. I put the CD in the drive and a splash screen pops up after which I select Install. The system reboots, I hit [Enter] and the system goes through an autodetection process. I can see that it sees my harddisk, CD, SATA controller, etc. It then switches to a screen where it says it is trying to access the CD. It then displays a message saying that the CD does not appear to be a Mandrake CD and do I want to try another one. I have no other one to try so I must abort. I tried extracting the iso files using MagicISO and I got the same results. I can always get the pre-burned CDs but I'm a problem solver and I want to solve this. Can anyone help...

AMD 64 3000+
MSI K8T Neo
Samsung 80G hd
Lite-On CD/DVD
Gainward TI-4200 64 MB graphics card
VIA VT-8237 SATA controller
Promise SATA/378 IDE controller

LittleAngel 07-03-2004 02:55 PM

MD5 sums
 
The first question is: did you run an MD5 checksum to verify your ISO downloads before burning them to CD? That'll probably be the best place to start.
Also, since you're using ISOBuster and MagicISO I assume that you're downloading from a Windoze machine. Try downloading the ISOs with ANY browser but IE as IE has this annoying, inherit ability of corrupting files.

I normally use Firefox if I download anything from a Windows PC. The Mozilla browser also works fine. Both can be downloaded from here: http://www.mozilla.org/download.html

For a How To on MD5 checksums, take a look here:
http://www.linuxiso.org/viewdoc.php/verifyiso.html

Then, to burn the ISO image to CD use a programme like Nero (select "Other CD formats" and then "Create CD from an image file". This will unwrap the ISo file for you).

I hope this helps, otherwise post again.

Terri

mind2work 07-03-2004 05:06 PM

Terri,

I did not run an MD5 checksum upon downloading the files. I believe I downloaded them with Netscape 7.1, but I'm not for certain. I have access to Nero 6.0 at work but have Sonic MyDVD here at home. Do you think Sonic MyDVD would burn them ok? Otherwise I'll have to wait until I get to work on Tuesday. No biggie if I have to. Also, I downloaded them from work since I have a highspeed connection there and, consequently, burned them to CD there. I have the downloaded ISO files on CD here at home. Would the checksum procedure be valid on the files since I have already burned them to CD. Thanks for your help...

LittleAngel 07-03-2004 08:44 PM

I'm not familiar with the Sonic MyDVD programme, sorry. Nero 6 will certainly burn ISO images - I'm still using Nero 5.5 and always had good results, so for the moment I would suggest that you try another burn at work using Nero, rather than producing more coasters.

You need to verify the MD5 sum on the downloaded ISO file before burning it to disk. So again, might be more sensible to wait till you have access to the downloaded files at work, unless you have a good DSL connection at home.

I haven't used Netscape since AOL acquired it, so can't comment on how well it does its job. If you still have the downloaded ISO files on your computer at work, run an MD5 checksum on them. If anything has been corrupted during download, which is pretty much what the description of your problem sounds like, you'll then be certain. If the ISO files are fine, then we have to find a different solution.

You can, of course, always try to run your Mandrake disk on another computer (installation will only start once Drake is writing partitioning info to disk, so up until then you can just play) to see if the same problem occurs.

These are the MD5 sums for Mandrake 10 Official
ad3d50fe12c0672a7e4d32b466ab6851 Mandrakelinux10.0-Official-Download-CD1.i586.iso
a64fbcb98d6aa2cd4ac287e563593678 Mandrakelinux10.0-Official-Download-CD2.i586.iso
bf7a7dad80cf3f41453d572d3ffed09b Mandrakelinux10.0-Official-Download-CD3.i586.iso

Let me know how you're getting on!

Terri

mind2work 07-03-2004 10:02 PM

Thanks again...

I was reminded of something when I read your last reply and you mentioned writing partitioning info to disk. I have an 80 G hd which already has two partitions; one for XP and the other blank. Of course I was trying to install Mandrake on the blank partition. It may have nothing to do with it but I thought I would mention it. I will certainly try your suggestions and post an update next week. Thanks again. In case the partitioning may be a problem I will check back before Tuesday to see if you had any comment...

LittleAngel 07-03-2004 10:25 PM

Your systems seems to be set up correctly to start your Mandrake install. One thing, though, when you say "blank" partition for Mandrake, does that partition show up as a primary or extended partition in Computer Management/Disk Management in WinXP? Or is it "unallocated"?

Your WinXP should be on a primary partition (of 40GB or whatever you've allocated in size) and the rest of the disk should show up as unallocated. Don't create a partition from Windoze to put your Linux distro on - Mandrake will create the necessary extended partition and logical drives when your run install.

I still think that the problem is the ISO image, so check that out first, then we'll get your install going!
:D

mind2work 07-04-2004 02:35 PM

I say the other partition is blank because I had 64-bit Windows installed on it some time ago but never got much use out of it. I had some trouble with files being corrupted and it was getting to be more trouble than it was worth so I reformatted that partition. It shows up as logical drive E: and actually shows to have some 65 Mb worth of something on it, though after reformatting I've not put anything on it yet. The two partitions were created when I first built the system and installed XP. I created the additional partition knowing I was going to try the 64-bit OS. If Mandrake will create its own partitions and logical drives, is it going to partition this E: drive into further partitions or will it abort. Do I need to run a Partition Magic and eliminate E: ?

An hour later:
Terri, I found a checksum program on the web called FASTSUM.EXE. I tried it on the files I have here at home and the checksums match with the checksums you included in an earlier entry. I know you said to check the MD5 sums on the downloaded files before they were first burned to CD. I can still do that but does these sum matching suggest the downloaded ones are fine? Could the ones I downloaded have been corrupted, but now are good through the burning on CD and copying them onto my computer at home?

LittleAngel 07-04-2004 06:23 PM

Okay, so I guess the downloads are okay. Further checking isn't necessary. Let's tackle the installation problem.

First of all, Microsoft ALWAYS uses some space on a partition even just after formatting. That is just normal Windoze behaviour (as is file corruption!). But although you can do this from the Mandrake partitioning menu, since your Mandrake CD is havng trouble, I would suggest that you log into your WinXP system and use the Computer Management console to delete the partition marked as Windows E: . You don't need any third party software to do this, just go to "Administrative Tools" - "Computer Management" - "Disk Management", then right-click partition E: and select "delete".

Partition Magic is a powerful tool, but it can create more problems than you'd bargained for! Normally it's not needed, both Windows and Linux allow you to delete, create and format partitions. And Linux is by far the most powerful tool for partitioning.

You CAN install Mandrake inside a Windows partition, but it is not a preferred way of doing this. It is best to use the expert menu of mandrake to partition your hard drive. It will see your WinXP installation and should mount it as hda1 and display a message saying "Windows C (just a guess!)".
Then you can create partitions (or mount points as they're called in Linux) for your Mandrake system where the Windows E: partition used to reside.

I haven't installed Mandrake for a while now, but as I remember it lets you create a set of Linux partitions as well as the option to create a Windows partition (not needed!).
Go for a partition setup similar to this:

hda1 - Windows C (just a guesss!) this is your WinXP partition
hda2 - /boot - ca 256MB
hda3 - might not show up as it sets up an extended partition for Linux
hda4 - / (root) ca 2GB
hda5 - /usr - 6Gb would be good! If Mandrake also has /usr /local, make this 6GB and /usr 2GB
hda6 - /home - 4GB
hda7 - /var - 6GB
hda8 - /swap - twice the amount of your RAM is good practice, however more than 1Gb is considered wasteful

(Please note this partition table is just an example and may look slightly different on Mandrake)

There might be other options like /opt, /www and /tmp, which are not really necessary. In fact, Linux can run on just two partitions, / (root) and /swap alone, but it is good practice to use several partitions to protect your system (if any one partition gets corrupted, the others remain unaffected and you will only need to rebuild the affected partition).

As far as file systems are concerned, use ReiserFS if available (fast and Windows friendly), XFS or as a minimum EXT3. Swap will not need a file system, this is your virtual memory on the hd.

The partitions that need the most space are /usr (or /usr /local) and /var as these house the essential binary and system information and configurations. /home depends on the size data files you want to store. If you have a lot of multimedia files, this partition needs to be quite big.

I hope with the second Windows parition deleted, Mandrake will install without any trouble. But in case it does, please let me know the following:

At exactly which point does your Mandrake installation start standing around on its own feet/trip over itself? Can you write down the error message exactly how it appears? What does the screen show just before Mandrake decides not to cooperate?

Let's hope it works! Good luck!

mind2work 07-05-2004 12:24 AM

Okay...

I deleted the E: drive uneventfully. I attempted to install with the same results. The sequence of steps went as follows:

1. load cd in drive, get splash screen
2. click to install, system reboots
3. press [Enter] to install
4. auto detection process (i.e., with lots of "hda: lost interrupt")
5. get message screen saying
"loading driver for scsi adapter:
Promise Technology Fastrak 378 Controller"
6. Next screen says
"Please Wait....
Trying to access a cdrom disc (my note: gives correct model of CD/DVD drive)"
7. Next screen is the error message
"Please Answer...
That CDROM disc does not seem to be a Mandrake
Linux Installation CDROM.
Retry with another disc?"
8. I then remove the disc and restart the system to get back to windows.

I had to do this four times to get the correct wording of the error messages. On one occaision I hit ALT-F3 and noted the following three lines of code repeated three times:

* looking for scsi media
* looking for Compaq Smart Array media
* looking for DAC960

There were a couple more lines of info referring to scsi media but I don't recall their content. The final line of code seem to reference the CD disc:

* mounting /dev/hde on /tmp/image as type iso9660

That's everything I can think of that is noteworthy from first attempt.

Several hours later:
Something I thought of that might be important. When I burned the files to CD to boot from using Sonic MyDVD, I used FileType as Microsoft Joliet which was the default. I have no idea which would be the correct filetype. Also, something else I thought of when I remembered the filetype info was that in articles I've read about iso images is that it is important that they must remain in the same order or tree structure or something like that. Is that a function of the burn process, the extraction process or something else. How do I know if the files I burned onto the CD are in the proper tree structure or order. I just extracted them and burned them to CD and made the CD bootable. Thought it might be a possible point of conflict.

LittleAngel 07-05-2004 09:28 PM

Hi again!

Please excuse the late reply.

I must confess that I am a bit at a loss. Considering that the MD5 sums have been verified correctly on your ISO downloads, that step has been eliminated as a problem.
You could try burning the ISOs to CD at work using NERO 6. This would cut out all the transferring of the ISO images and use of extra programs (ISOBuster/MagicISO) before burning and so avoid the problem of corruption of ISO image to CD.

It is obvious that your CD is still the cause of the problem on install. Why I'm not exactly sure. I have never come across a Linux CD that doesn't recognise itself as Linux.

Thanks for the detailed error listing. It seems that the install starts to get into difficulty as soon as it starts to try and detect your SATA media. From what I can see I think Mandrake will support your SATA adapter, but it can't find the correct file on the installation CD for the media - i.e. hard drive. Hence it thinks it is a "non-Linux" CD.

The Joliet mode is what you need to burn ISOs, so that's correct (I guess it's called Micro$oft Joilet because you're on a Windoze machine...). I just checked the settings on Nero for burning ISOs, they're as follows:

File/Directory name length: ISO Level 1 (Max of 11=8+3 chars)
Format: Mode 1
Character Set: ISO 9660

Joliet mode is ticked

And that's where it gets confusing, because on install your CD ROM gets mounted absolutely correctly as an ISO 9660 on /dev/hde. I can't see any fault here!

What I can see from your detailed listing is that Mandrake correctly detects the SATA adapter and loads the driver for it, but then it strangles itself on the SATA media. So it either doesn't like your hard drive or it can't locate the necessary files.

If your burn process using Sonic MyDVD is correct (which I think it is) and the original ISO downloads have been verified, then the ISO image unwrapping using ISOBuster and MagicISO might be the problem. Try burning the images using Nero, which means less steps in between.

Otherwise, I am running out of ideas, sorry!

:cry:

mind2work 07-05-2004 09:42 PM

Thanks for the interest...I will try to burn from original downloaded files using Nero 6 and try that. Thanks for confirming that I need the Joliet filetype. I will try it tomorrow and post again...

mind2work 07-07-2004 03:35 AM

Terri,

Good news and bad news.
The good news is I was able to get a good CD burn that didn't error out as before. I wasn't able to use Nero 5.5 because the CD I was given would only work on the CD drive it was bundled with, which wasn't mine. However, I used the Wizard portion of Sonic MyDVD and it worked perfectly.

The bad news I can't partition my hd. I tried twice and got the same results. The first time I told it to use the free space (not free space on Windows partition) and it seemed to get hung up on hda5 after which it failed. It was trying to use ext3 filesystem. I rebooted the system and tried again, this time using the customization route. I was able to specify the ReiserFS filesystem, the size of the partition, and the mount point (/boot for example). I started with the /boot since that is what you had first on your list when partitioning. I set it up for 256 MB, /boot, ReiserFS and pressed "Format". Mandrake automatically assigned that partition to hda5 and seemed to get hung again. It showed a message saying "Please Wait...Formatting Partition hda5". Literally I got tired of waiting, seemed like 30 minutes and it still wasn't finished. I assumed something was wrong and flipped off the system. Interestingly, the first time I tried partitioning, it actually created four (I think) partitions before it hung up on, you guessed it, hda5. Except the first time hda5 was not assigned to /boot. However, I don't recall what it was assigned to.

It seems like Mandrake sees my hd ok during the autodetection and shows no signs of trouble until you try to partition. I went out www.planetamd64.com and looked for drivers for my sata raid controller and found two, one for each Mandrake 9.1 and 9.2. I didn't install either of them because I wanted to do some research first. Do you think that could be a problem or do I have a more permanent incompatibility issue. One other note of interest, in the release_notes.txt file on the Mandrake CD there is an explanation about the system hanging during the autodetection process. It says that if this happens, reboot the system, and press F1 and type noauto and it would bypass the autodetection process. I wonder if that would allow the partitioning. Doesn't sound like it would but I'm only curious because it hangs similarly as during the autodetection process only much longer.

Does any of this sound familiar? I hope I've explained myself clearly.

LittleAngel 07-07-2004 09:33 PM

Hi again and sorry about the long wait. It's been a long stormy day and I've only just made it back!

I'm glad to know you've now got a good set of installation CDs. Sorry it's still not liking your hard drive. Yes, I have come across something like that once before, but on an IDE drive and with Red Hat.
Then it didn't want to install because I nearly out of available free space and just slowed down during patitioning.

One thing, though, in any case, you don't have to format a partition you created right away like you would on a Windoze machine. When you patition up your hd, first create all the partitions you need. The bare minimum a Linux system needs is:

/swap (2x RAM, but no bigger than 1GB)
/ (root)

Also, Linux might re-arrange the partition mount points once you have created your partition table. That's quite normal, too. My previous partition table is just a guideline. Mandrake might switch the order of the partitions. Once you've set all your partitions, you can click "next" and then Mandrake will inform you that it will now write the information to disk - i.e. format your hd.

Your SATA seems to be insisting on creating a problem and might need extra help. Have a look at this thread as well:
http://www.linuxquestions.org/questi...hreadid=202014

I don't have experience with SATA, so maybe posting a new thread under SATA will be better. Sorry, I'm not trying to quit and as long as you want my help I'll try my best to give it to you, but other Linuxers might have the experience I so sadly lack!

Terri

mind2work 07-12-2004 09:56 AM

Terri,

I'll look at the thread you mentioned and see if it helps. Also, I will post a new thread under the topic of SATA as it's no longer a boot problem. Thanks for your help. If you're curious how it goes, look for mind2work...kevin.

sorcerer01 08-07-2004 04:41 PM

Mod Edit: Advertising removed



All times are GMT -5. The time now is 06:02 AM.