LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   inconsistent X server? (https://www.linuxquestions.org/questions/mandriva-30/inconsistent-x-server-179996/)

rgiggs 05-10-2004 12:55 PM

inconsistent X server?
 
hi,
i tried to open emacs and got this message:

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

emacs: Cannot connect to X server :0.0.
Check the DISPLAY environment variable or use `-d'.
Also use the `xhost' program to verify that it is set to permit
connections from your machine.


about 10 seconds later, i tried again and emacs opened ok.

strange :scratch:

stonehurstX11 05-10-2004 09:38 PM

Something similar happened to me as well.
I attempted to open Totem Movie Player, but it just crashed on me and didn't give any errors. As a matter of fact, no program would start, so I logged out and logged back in. Everything was well after that.
Of all the distros I used, this only happened on Mandrake 10.0 CE, and sometimes on earlier versions. Probably has something to do with X... :rolleyes:

rgiggs 05-10-2004 11:45 PM

i'm using mdk 10 official, so probably not just community. also i opened emacs from the terminal, that's why i saw the error message.

stonehurstX11 05-11-2004 10:32 PM

Also tried from command line
 
After Totem failed to start by using the menu, I tried '/usr/bin/totem' from the command line and Totem managed to open, but closed instantly, without any error messages popping up on the command line. So basically, it went like this:

_______
[mike@genesisx]$ /usr/bin/totem
(Note: Totem now opened, and closed instantly. No errors displayed.)
[mike@genesisx]$
_______

That's rather weird, since it would usually spit back an error or two if something went wrong.


All times are GMT -5. The time now is 02:45 AM.