LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-21-2005, 04:22 PM   #1
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Rep: Reputation: 30
I need help setting up ADSL to start at boot. Please :).


I just got ADSL activated, but I've been having problems installing it.
It's pppoa protocol, and a Dynalink dual ethernet/USB port modem.

I have a built in ethernet port -

So, I plugged everything in and went to Network and Internet(in mcc) to make a new connection. Completed, but no connection! I couldn't ping my router IP either.
So, I spent a while trying to figure that out, but then I went to manage connections and tried putting the modem IP address under the IP address option for eth0.
Magically, it started working.

Anyway, I tried rebooting, expecting a connection to start up(which I had set it to do), but, it didn't...
So, I went back to manage connections, but the settings I had changed earlier had been reset. I noticed the drop down menu had DHCP on it. I tried clicking it and the only other option was static, so I just reclicked DHCP. But, because of that the other options that I had edited earlier were greyed out... hmmm.... Anyway, I just applied the changes and voila.
Maybe DHCP wasn't working? I don't even know what DHCP is...

So, I tried restarting again. Once again, no connection and the settings had been reset.
I don't want to have to reselect DHCP, or reenter some numbers everytime I boot up...
Could someone pleaseee help me to get this working nicely.

Thanks

One more thing I should mention... The very first time I installed it I selected pppoe, but then I found out that was the wrong one so I just removed that connection and made a new one. Once I also seleced DHCP by mistake... I removed the packages that I think pppoe installed, but I thought I'd just mention this incase it created some conflicts in the config files...

Last edited by beejayzed; 09-21-2005 at 04:26 PM.
 
Old 09-21-2005, 05:12 PM   #2
beejayzed
Member
 
Registered: Jan 2004
Location: Auckland, New Zealand
Distribution: Ubuntu
Posts: 686

Original Poster
Rep: Reputation: 30
oooh yay I got it to work! I found out that dhclient activates the connection.
So, I disabled the option to start the connection at boot, and just put dhclient in rc.local.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl-setup or adsl-start not found as user! bnchakraborty Linux - Newbie 2 01-18-2008 10:23 PM
Monitoring ADSL (to keep online), adsl-start michaelsanford Linux - Networking 7 07-12-2006 06:43 PM
setting network start timeout at boot sayantam Linux - Networking 1 06-10-2004 04:20 AM
Help setting up ADSL g4c9z Linux - Networking 2 05-28-2004 07:31 PM
Setting up ADSL cmack Linux - Networking 2 08-13-2003 02:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 02:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration