-   Mandriva (
-   -   HP PS7150: text doesn't print in OOO and Abiword!, but I can print test page & w MzFF (

gabba 08-02-2005 03:59 PM

HP PS7150: text doesn't print in OOO and Abiword!, but I can print test page & w MzFF
Hi, I have a HP Photosmart 7150 printer, which was automatically recognised and installed by Mandriva Linux LE 2005. According to this printer should work perfectly with HPIJS drivers.

However I'm experimenting the weirdest problem I experienced with Linux yet: when printing from OpenOffice 1.1.4, the images print, but not the text. However, the print head does go back and forth on the paper as if it was trying to print the text. I installed Abiword and I have the exact same problem in that program.

What makes things weirder is that I can print a test page without problems, and printing also works from Firefox. But I absolutely need printing to work directly from openoffice, as I'm setting up this computer for people that I'd like to convert from Windows.

On top of that, I now see a weird kernel error when I boot up, about a usb module that cannot load because something is already in the kernel (I'll copy the exact message as soon as I can, I'm typing from another computer). I'm not sure if that error happened before I reconfigured the printer through the Mandrake Control Center to make sure everything was fine.

I experienced almost the exact same thing a week ago when I tried Ubuntu Linux on that computer, except that in that case I was able to print text that I typed into a new OOo document, but not text that I pasted from, say, Firefox. It puzzles me to have the same problem under two very different distributions, especially since it doesn't seem to be a hardware problem (Firefox and test pages print perfectly fine).

Any idea? I'm getting to know Linux quite a bit, but here I'm really lost, and this could jeopardize acceptance of Linux by my friends, which is bad.

The computer is an old IBM PIII (around 500MHz); the printer, a HP Photosmart 7150 plugged though USB. I use no other USB device on that computer (well I did plug in a usb pen drive once, but that's it).

xukosky 08-05-2005 01:48 AM

Well, I don't know anything about the mandrake control center so, are you really sure that your printer is properly installed? If I were you I would try installing the printer again by hand to be really sure that there are not any lost needed packages or something misconfigured... but of course I am thinking in the problem from the debianist point of view.

That would be great if someone with the same distribution and the same printer could tell you about her or his experience. Nobody?

odessawarriors 10-27-2005 03:33 PM

I also have the HP Photosmart 7150 printer and cannot print from applications, but can print "test" pages from the HP Toolbox software and "internal" test pages from the printer. This problem that I am having is only occuring on my Windows XP Home box. With the printer plugged into my Fedora Core 4 box, the printer works normally and can print from any application.

Sorry, but I don't have a solution to your issue, but I stumbled across this POST while trying to find help for my problem. I can't find anything on HP's site that describes this problem. I have uninstalled/reinstalled the HP drivers several times now and nothing seems to be helping. I suppose I'll give HP a call and find out what the heck is going on. I'll repost back if I can get anywhere with them.

gabba 10-27-2005 09:29 PM

I kind of solved my problem (part of it was a cartridge problem), but printing remained very unreliable.

By the way, is there any distro in which you have visual feedback when you print (like the printer icon that appears in the system tray in windows)? Sometimes printing was very slow, and users tried like five times before realizing the print command was really sent.

odessawarriors 10-29-2005 07:36 PM

Glad to hear you were able to solve your problem. I was able to solve mine too, however I took a few measures like using the RESTORE function in WinXP to restore my PC back to an earlier point. I was then able to print successfully. However, I then had trouble with other apps on my PC, so I actually ended up reinstalling Windows. Not fun!

I now have my HP 7150 setup on the WinXp PC and "shared" with a queue of "hp7150". I then used the Printer Configuration app in my distro (in this case Fedora Core 4) and setup my Linux box to use the "hp7150" queue on the XP box (Networked printer).

Here is a snippet from my /etc/cups/printers.conf file:

<DefaultPrinter HP7150>
DeviceURI smb://jeff@darthvader/hp7150
Location Photosmart 7150 on DarthVader
Info Photosmart 7150 on DarthVader
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0

This shows that I am using Samba to connect to my XP box "darthvader" and to the printer queue "hp7150".

You also asked about being able to see what print jobs are currently in progress. You can use the app "lpq" to see the printer queue. Execute the command "lpq -l" to get a long listing of print jobs currently in the queue. Note that if there is nothing printing, then you'll get a "no entries" response back. To test that this would show my print job from Writer, I executed a small Perl script to run the "lpq -l" command every 1 second. I was able to see the print job go through the queue and the job successfully printed on my printer. Here is output along with the perl script I ran to see the queue:

[root@obiwan ~]# perl -e ' for ( ; ; ) { system("lpq -l"); sleep 1; } '
HP7150 is ready
no entries
HP7150 is ready and printing

jeff: active [job 6 localhost]
Untitled1 302080 bytes
HP7150 is ready and printing

jeff: active [job 6 localhost]
Untitled1 302080 bytes
HP7150 is ready and printing

jeff: active [job 6 localhost]
Untitled1 302080 bytes
HP7150 is ready and printing

jeff: active [job 6 localhost]
Untitled1 302080 bytes
HP7150 is ready
no entries
HP7150 is ready
no entries


Hope this helps you out.

gabba 10-30-2005 09:14 PM

I know about the lpq command, but it's not good for people inexperienced in computers.

odessawarriors 10-31-2005 11:10 AM

Yes, Fedora Core 4 does have a printer icon to show queue status similar to Windows in the system tray. The app that executes this appears to be called Print Notifier. The version that is installed is v. 0.18. I am using the CUPS print manager software on this machine. I would assume that most current Linux distros have this as an option for print management. I need to take some time to read the CUPS manual information to know more about it. If you want to access the CUPS administration tool, go to http://localhost:631/admin on your machine and you will see what you can do with it.

As for the Icon, when there are no print jobs in the queue, the printer icon is "grayed" out. When a print job is sent to the printer, the icon then becomes active and flashes. This should alert the user that there print job was sent to their printers. I am including an image of 3 screen shots on top of one another showing the printer icon go from inactive to active. Also, double-clicking the icon brings up the printer-queue.

Hope this helps.

All times are GMT -5. The time now is 06:33 PM.