LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 12-30-2008, 06:33 PM   #16
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,469

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728

You did the entry for /etc/fstab in Opensuse but slight error:

/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 / ext3 acl,user_xattr 1 1

The entry above is for Opensuse, the entry below is for Mandriva

/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part5 / ext3 acl,user_xattr 0 0

The differences above are in red, need a space between zeroes like: 0 0

You didn't indicate whethere you took the entry from Mandriva's menu.lst and put it in Opensuse menu.lst. Without that entry, it won't work

cd /mnt/mandriva
cat menu.lst

Look for the Mandriva stanza and copy it to the Opensuse menu.lst file. Below is my entry for Mandriva, yours won't be the same but similar

title Mandriva
kernel (hd1,4)/boot/vmlinuz BOOT_IMAGE=linux root=/dev/hdb12 splash=silent acpi=ht vga=788
initrd (hd1,4)/boot/initrd.img

(You may need to re-mount again if you have re-booted and the fstab entry is not right)

I'll check back tomorrow. Good Luck!

Last edited by yancek; 12-30-2008 at 06:36 PM.
 
Old 12-31-2008, 02:03 PM   #17
Gins
Senior Member
 
Registered: Jul 2004
Location: Germany
Distribution: open SUSE 11.0, Fedora 7 and Mandriva 2007
Posts: 1,662

Rep: Reputation: 47
Thanks yancek for the latest comments.
I just came home from the gym.

The following is the Mandriva's menu.lst file.


It seems Mandriva gets some strange figures.

You will read (hd0,0) , (hd0,1) , (hd0,2), etc.

Code:
ni@SuseLinux103:/mnt/mandriva> cd boot
ni@SuseLinux103:/mnt/mandriva/boot> cd grub
ni@SuseLinux103:/mnt/mandriva/boot/grub> cat menu.lst
timeout 10
color black/cyan yellow/cyan
gfxmenu (hd0,4)/boot/gfxmenu
default 0

title linux
kernel (hd0,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a  resume=UUID=743165c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
initrd (hd0,4)/boot/initrd.img

title linux-nonfb
kernel (hd0,4)/boot/vmlinuz BOOT_IMAGE=linux-nonfb root=UUID=6460a523-8375-40e3-9958-31c179210b3a  resume=UUID=743165c2-5731-4133-9976-0fc7fd90d02c
initrd (hd0,4)/boot/initrd.img

title failsafe
kernel (hd0,4)/boot/vmlinuz BOOT_IMAGE=failsafe root=UUID=6460a523-8375-40e3-9958-31c179210b3a  failsafe
initrd (hd0,4)/boot/initrd.img

title windows
root (hd0,0)
makeactive
chainloader +1

title windows1
root (hd0,1)
makeactive
chainloader +1

title Ubuntu 8.04
root (hd0,2)
configfile /boot/grub/menu.lst

title openSUSE 10.3 (i586)
VERSION = 10.3
root (hd0,7)
configfile /boot/grub/menu.lst
ni@SuseLinux103:/mnt/mandriva/boot/grub>


I did the minor change in fstab file in open SuSE 10.3. You have noticed an error. I made an silly error.

The following is the corrected file.

Code:
SuseLinux103:/etc # cat fstab



/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 /                    ext3       acl,user_xattr         1 1
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part5 /                    ext3       acl,user_xattr 0 0
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1UP109613-part2 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part1 /windows/D           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part2 /windows/E           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part7 swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/fd0             /media/floppy        auto       noauto,user,sync      0 0
SuseLinux103:/etc #
I don't have to post the menu.ist file from open SuSE 10.3.
It is already here. I posted yesterday.

Please tell me the next step.
I hope you will find time to look at this.


Last edited by Gins; 12-31-2008 at 02:27 PM.
 
Old 12-31-2008, 02:37 PM   #18
Gins
Senior Member
 
Registered: Jul 2004
Location: Germany
Distribution: open SUSE 11.0, Fedora 7 and Mandriva 2007
Posts: 1,662

Rep: Reputation: 47
I think there are some glitches.

I twice rebooted the system.

The following is the Mandriva's menu.lst file.

1] I got the open SuSE 10.3 the screen.

2] I mounted the Mandriva partition.

3] I changed into Mandriva's grub folder.

4] I used the cat command to read Mandriva's menu.lst file.

The following is the file.
It is different from the previous one.
I don't know these things.
Have I made an stupid error?


Code:
SuseLinux103:/mnt/mandriva # ls
bin   dev  home    lib         media  ooobuildtime.log  proc                root  sys  usr
boot  etc  initrd  lost+found  mnt    opt               .readahead_collect  sbin  tmp  var
SuseLinux103:/mnt/mandriva # cd /boot
SuseLinux103:/boot # cd grub
SuseLinux103:/boot/grub # cat menu.lst
# Modified by YaST2. Last modification on Sun Dec 21 17:14:18 CET 2008
default 0
timeout 30
gfxmenu (hd1,7)/boot/message

###Don't change this comment - YaST2 identifier: Original name:  Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)###
title Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)
    root (hd1,2)
    configfile /boot/grub/menu.lst
    configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=0x317 resume=/dev/sdb7 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-bigsmp

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
    rootnoverify (hd1,7)
    chainloader (hd0,1)+1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
    rootnoverify (hd1,7)
    chainloader (hd1,0)+1

###Don't change this comment - YaST2 identifier: Original name: windows 3###
title windows 3
    rootnoverify (hd1,7)
    chainloader (hd1,1)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    rootnoverify (hd1,7)
    chainloader (fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.5-31-bigsmp
SuseLinux103:/boot/grub #

Last edited by Gins; 12-31-2008 at 02:39 PM.
 
Old 12-31-2008, 03:30 PM   #19
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,469

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
I don't know why your Mandriva menu.lst file shows Mandriva as (hd0,4). This is usually a result of changing the boot order in the BIOS during/between installs. The entry below from the Mandriva menu.lst should be copied to the /boot/grub/menu.lst file in OPENSUSE!!

title linux
kernel (hd0,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
initrd (hd0,4)/boot/initrd.img

Quote:
4] I used the cat command to read Mandriva's menu.lst file.
No, actually you didn't. You are looking at the Opensuse menu.lst. Look at your last post, part of which is below. That's Opensuse and you can tell because of the "Modified by YaST2" line. Mandriva doesn't use YaST2!

Quote:
SuseLinux103:/boot/grub # cat menu.lst
# Modified by YaST2. Last modification on Sun Dec 21 17:14:18 CET 2008

Also, if you were in the Mandriva menu.lst the prompt would read:

SuseLinux103:/mnt/mandriva/boot/grub # (here is where you enter cat menu.lst.

The menu.lst in your last post is Opensuse, the post prior is Mandriva. So the Mandriva menu.lst HAS NOT changed. Put the entry above for Mandriva in the Opensuse menu.lst file. Before doing this, I would suggest you again mount Mandriva and look in the /boot directory to be sure you have a "vmlinuz" file and an "initrd.img" file. If the entry aabove does not work, change the (hd0,4) entries to (hd0,1).
 
Old 12-31-2008, 03:53 PM   #20
Gins
Senior Member
 
Registered: Jul 2004
Location: Germany
Distribution: open SUSE 11.0, Fedora 7 and Mandriva 2007
Posts: 1,662

Rep: Reputation: 47
I did the change you suggested in the open SuSE 10.3's menu.lst file.

The following is the file.

Code:
ni@SuseLinux103:~> su root
Password:
SuseLinux103:/home/ni # cd /boot
SuseLinux103:/boot # cd grub
SuseLinux103:/boot/grub # cat menu.lst
# Modified by YaST2. Last modification on Sun Dec 21 17:14:18 CET 2008
default 0
timeout 30
gfxmenu (hd1,7)/boot/message

###Don't change this comment - YaST2 identifier: Original name:  Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)###
title Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)
    root (hd1,2)
    configfile /boot/grub/menu.lst
    configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=0x317 resume=/dev/sdb7 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-bigsmp

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
    rootnoverify (hd1,7)
    chainloader (hd0,1)+1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
    rootnoverify (hd1,7)
    chainloader (hd1,0)+1

###Don't change this comment - YaST2 identifier: Original name: windows 3###
title windows 3
    rootnoverify (hd1,7)
    chainloader (hd1,1)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    rootnoverify (hd1,7)
    chainloader (fd0)+1

title linux suggested by yancek
kernel (hd0,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
initrd (hd0,4)/boot/initrd.img

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.5-31-bigsmp

SuseLinux103:/boot/grub #
I got the following error message when tried to get 'linux suggested by yancek' on to the screen.

kernel (hd0,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
Error:15 file not found
Press any key to ...

What would be the next step?

Last edited by Gins; 12-31-2008 at 04:03 PM.
 
Old 12-31-2008, 04:16 PM   #21
Gins
Senior Member
 
Registered: Jul 2004
Location: Germany
Distribution: open SUSE 11.0, Fedora 7 and Mandriva 2007
Posts: 1,662

Rep: Reputation: 47
You suggested the following:

If the entry aabove does not work, change the (hd0,4) entries to (hd0,1).

I tried the above just now.
Code:
title linux suggested by yancek
kernel (hd0,1)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
initrd (hd0,1)/boot/initrd.img

The following is the output:

kernel (hd1,4)
Filesystem type is ext2f ...
configfile /boot/grub/menu.lst
Error2: Bad file or directory
Press any key to ...
--------------------------------------

I would like to hear from you again.

Another idea crossed my mind.
I have Acronis program. By using it I can selectively remove/format the partition which contains Mandriva 2009.; this is sdb5.

Then I can reinstall Mandriva 2009 again taking little bit more time than before.
I can erase all the entries pertaining to Mandriva 2009 in Ubuntu and open SuSE 10.3. I mean the entries in menu.ist files. Before any reinstallation it is imperative to make sure that there are no traces of Mandriva 2009.

I am a bit unsure about removing entries in fstab files of Ubuntu and open SuSE 10.3. I need your help to carefully edit fstab files.
Your thoughts, on this, are welcome.

Last edited by Gins; 12-31-2008 at 05:48 PM.
 
Old 12-31-2008, 05:27 PM   #22
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,469

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
Quote:
If the entry above does not work, change the (hd0,4) entries to (hd0,1).
Above was my mistake, meant to change to (hd1,4)

I would again suggest you again mount Mandriva and look in its /boot directory to be sure you have a "vmlinuz" file and an "initrd.img" file.
Make sure you are in the Mandriva /boot directory and not Opensuse.

In your last post you indicate you tried the (hd0,1) entry and your output shows the error below, not the "kernel (hd1,4)??

kernel (hd1,4)
Filesystem type is ext2f ...
configfile /boot/grub/menu.lst
Error2: Bad file or directory
Press any key to ...

Do you have an other entry for Mandriva with the configfile /boot/grub/menu.lst? If it's not right, you would get an error message but it would show kernel (hd0,1) not the (hd1,4).
 
Old 01-01-2009, 11:36 AM   #23
Gins
Senior Member
 
Registered: Jul 2004
Location: Germany
Distribution: open SUSE 11.0, Fedora 7 and Mandriva 2007
Posts: 1,662

Rep: Reputation: 47
I changed again the menu.lst file again. You said you made a mistake. I always make mistakes.

The following is the menu.lst file in open SuSE 10.3

Code:
# Modified by YaST2. Last modification on Sun Dec 21 17:14:18 CET 2008
default 0
timeout 30
gfxmenu (hd1,7)/boot/message

###Don't change this comment - YaST2 identifier: Original name:  Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/s
db3)###
title Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)
    root (hd1,2)
    configfile /boot/grub/menu.lst
    configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=
0x317 resume=/dev/sdb7 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-bigsmp

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
    rootnoverify (hd1,7)
    chainloader (hd0,1)+1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
    rootnoverify (hd1,7)
    chainloader (hd1,0)+1

###Don't change this comment - YaST2 identifier: Original name: windows 3###
title windows 3
    rootnoverify (hd1,7)
    chainloader (hd1,1)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    rootnoverify (hd1,7)
    chainloader (fd0)+1

title linux suggested by yancek
kernel (hd1,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165
c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
I got the following error message.

root(hd1,4)
Filesystem type is ext2fs, partiton type 0x83
configfile /boot/grub/menu.lst
Error 2: Bad file or directory type
press any key to continue

Last edited by Gins; 01-01-2009 at 11:58 AM.
 
Old 01-01-2009, 12:16 PM   #24
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,469

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
Gins:

You posted again your menu.lst for Opensuse. Is this the complete menu.lst, you don't need to post anything with a hash mark (#) to the left. Looking through this menu.lst, the only entry you have for Mandriva is:

Quote:
title linux suggested by yancek
kernel (hd1,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165
c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
Yet your error message says:

Quote:
root(hd1,4)
Filesystem type is ext2fs, partiton type 0x83
configfile /boot/grub/menu.lst
Error 2: Bad file or directory type
press any key to continue
The error message should have the kernel line in it from the first entry and not the configfile entry. Your Opensuse menu.lst does not have a Mandriva entry with "configfile"?? I don't know where that's coming from??

Let's see if I understand your setup. When you boot initially, you get the Opensuse menu with different options. Your default is to boot to Ubuntu so if you take no action and make no selection, your system will boot to the Ubuntu menu.lst file and you will get your options again. If you make no choice, it boots to Ubuntu as Ubuntu is default in your Ubuntu menu.lst. Is this correct?

Are you seeing the Mandriva entry on your initial Opensuse menu? You have seven entries, do they all show on the initial screen? Are you letting the default boot from Opensuse go to the Ubuntu menu.lst before selecting Mandriva or do you select Mandriva from the Opensuse menu.lst? Do you have an entry in either Opensuse or Ubuntu menu.lst that has a "configfile" line for Mandriva? Don't know where that's coming from?? You have no entry like that in the Opensuse menu.lst you've posted?
 
Old 01-01-2009, 02:50 PM   #25
Gins
Senior Member
 
Registered: Jul 2004
Location: Germany
Distribution: open SUSE 11.0, Fedora 7 and Mandriva 2007
Posts: 1,662

Rep: Reputation: 47
Let's see if I understand your setup. When you boot initially, you get the Opensuse menu with different options. Your default is to boot to Ubuntu so if you take no action and make no selection, your system will boot to the Ubuntu menu.lst file and you will get your options again. If you make no choice, it boots to Ubuntu as Ubuntu is default in your Ubuntu menu.lst. Is this correct?
[ The above is absolutely correct.]

-----------------------------

Are you seeing the Mandriva entry on your initial Opensuse menu?

No.
-------------------------------

The following are the items on the initial Opensuse menu.

Ubuntu ...
Open SusE ...
Windows 1
Windows 2
Windows 3
Floppy
Linux suggested by yancek
Failsafe open SuSE ...
--------------------------------
So there are 8 entries on the initial Opensuse menu.
If I selected the item 'Linux suggested by yancek', I would get the following message which you have already written here.

Code:
title linux suggested by yancek
kernel (hd1,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165
c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
---------------------------------

The second menu has the following:

Ubuntu ...
Ubuntu ...
Ubuntu ...
Mandriva 2009
Other operating systems:
Windows ...
Windows ...
--------------------------------
If I selected 'Mandriva 2009, I would get the following error message:

Code:
root(hd1,4)
Filesystem type is ext2fs, partiton type 0x83
configfile /boot/grub/menu.lst
Error 2: Bad file or directory type
press any key to continue
[ I have installed Windows Vista and Window 2008 Server; that is the reason to get two Windows on the menu.]

I suggested removing Mandriva 2009 and reinstall again. Did you read it?
If you think it is a good idea, I need help to remove the entries in fstab files.

Last edited by Gins; 01-01-2009 at 02:53 PM.
 
Old 01-01-2009, 04:10 PM   #26
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,469

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
Quote:
Are you seeing the Mandriva entry on your initial Opensuse menu?

No.
That's a YES, you do see the Mandriva entry in Opensuse you just have it labelled "Linux suggested by yancek"

When you select this entry, what happens? Do you see the message below on the screen? Any error message with it?

Quote:
title linux suggested by yancek
kernel (hd1,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165
c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
I believe you should have a line entry below the kernel line with an "initrd" entry. Can you mount your Mandriva and go to the /boot directory and see if there is an "initrd" file there, also a "vmlinuz" file? These files should be in the /boot directory, not the /grub directory.

There is really not much point in booting from Opensuse and then from Ubuntu again. I would suggest you add the Ubuntu entry I suggested in post #17. You can leave the current Ubuntu entries, just put a hash mark (3) to the left of the title line so it is not read. You can always change it back if you want.

If you don't have both the vmlinuz and initrd files in your Mandriva /boot directory that may be the problem. Mandriva definitely won't boot if they are not there.

To see how Grub actually views your partitions run these commands. Log in as root, at the prompt type: grub, you should get the grub prompt which is "grub>". At that prompt type each of these command in sequence and post the output:

find /vmlinuz
find /boot/vmlinuz
geometry (hd0)
geometry (hd1)
 
Old 01-01-2009, 04:22 PM   #27
Gins
Senior Member
 
Registered: Jul 2004
Location: Germany
Distribution: open SUSE 11.0, Fedora 7 and Mandriva 2007
Posts: 1,662

Rep: Reputation: 47
Thanks yancek

I am leaving home around 5 o' clock tomorrow morning. I must sleep now. It is getting late here.
I must work tomorrow. After work I will go to the gym. I will attend this tomorrow evening.

I profoundly appreciate all your help.
Please keep a good watch as usual on the thread.

By the way, where are you based?
I am in Sweden.
I have written the location as Germany. As you know people use fictious names and false identities for Internet forums.
I use the name Gins for a several Internet related activities.

Last edited by Gins; 01-01-2009 at 04:26 PM.
 
Old 01-01-2009, 04:43 PM   #28
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,469

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
Quote:
By the way, where are you based?
Southwestern USA, Arizona. I'll check the post tomorrow.
 
Old 01-03-2009, 04:37 AM   #29
Gins
Senior Member
 
Registered: Jul 2004
Location: Germany
Distribution: open SUSE 11.0, Fedora 7 and Mandriva 2007
Posts: 1,662

Rep: Reputation: 47
yancek wrote the following:

I believe you should have a line entry below the kernel line with an "initrd" entry. Can you mount your Mandriva and go to the /boot directory and see if there is an "initrd" file there, also a "vmlinuz" file? These files should be in the /boot directory, not the /grub directory.
---------------------------------------------------------------------------------------------------------------------------------------
Yes, I started open SuSE 10.3 and mounted Mandriva 2009.
The following is the contents of its boot directory.

Code:
SuseLinux103:/mnt/mandriva/boot # ls
config-2.6.27-server-0.rc8.2mnb      initrd.img                           vmlinuz-2.6.27-server-0.rc8.2mnb
gfxmenu                              initrd-server.img                    vmlinuz-server
grub                                 System.map-2.6.27-server-0.rc8.2mnb
initrd-2.6.27-server-0.rc8.2mnb.img  vmlinuz
SuseLinux103:/mnt/mandriva/boot
So those two files are in place.

------------------------------------------------------------------------------------------
The following are the output of grub.

Code:
SuseLinux103:/mnt/mandriva/boot # cd
SuseLinux103:~ # grub


    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename. ]
grub> find /vmlinuz
find /vmlinuz
 (hd1,2)
grub> /boot/vmlinuz
/boot/vmlinuz

Error 27: Unrecognized command
grub> geometry (hd0)
geometry (hd0)
drive 0x80: C/H/S = 30401/255/63, The number of sectors = 488397168, /dev/sda
   Partition num: 1,  Filesystem type unknown, partition type 0x7
   Partition num: 4,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 5,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 6,  Filesystem type is ext2fs, partition type 0x83
grub> geometry (hd1)
geometry (hd1)
drive 0x81: C/H/S = 60801/255/63, The number of sectors = 976773168, /dev/sdb
   Partition num: 0,  Filesystem type unknown, partition type 0x7
   Partition num: 1,  Filesystem type unknown, partition type 0x7
   Partition num: 2,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 4,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 5,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 6,  Filesystem type unknown, partition type 0x82
   Partition num: 7,  Filesystem type is ext2fs, partition type 0x83
grub>
-------------------------------------------------------------------------------------------------------------
Only the following command was negative.
The message was Error 27.

/boot/vmlinuz

Last edited by Gins; 01-03-2009 at 05:26 AM.
 
Old 01-03-2009, 10:44 AM   #30
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,469

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
Quote:
Only the following command was negative.
The message was Error 27.

/boot/vmlinuz
You forgot the "find", shoud be at grub prompt, grub>find /boot/vmlinuz

It shows with your ls command in Mandriva so it's not needed to run again.
Below is the entry you posted earlier from Mandriva menu.lst. The kernel line has (hd0,4), from information you have given, it should be (hd1,4). I know you changed that so the only other things I could suggest is to put a line "root (hd1,4) between "title linux" and the "kernel..." entry. Also, make sure the line "initrd (hd0,4)/boot/initrd.img" is in the Opensuse menu.lst entry for Mandriva.

title linux
kernel (hd0,4)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6460a523-8375-40e3-9958-31c179210b3a resume=UUID=743165c2-5731-4133-9976-0fc7fd90d02c splash=silent vga=788
initrd (hd0,4)/boot/initrd.img

Not really sure if this will work or what else to suggest?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to restore boot loader on Mandriva 09 dual boot ... pruned parts 2 Javad_Ed Mandriva 8 01-06-2009 04:11 PM
How to restore boot loader on Mandriva 09 dual boot with Suse 11.0 ? dolphans1 Mandriva 10 01-06-2009 03:43 PM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 01:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 12:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration