LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   How to restore boot loader on Mandriva 09 dual boot ... pruned parts 1 (https://www.linuxquestions.org/questions/mandriva-30/how-to-restore-boot-loader-on-mandriva-09-dual-boot-pruned-parts-1-a-687428/)

dolphans1 12-01-2008 04:54 AM

How to restore boot loader on Mandriva 09 dual boot ... pruned parts 1
 
//moderator/note: hijack cleanup. For a clean view of this thread see http://www.linuxquestions.org/questi...e-11.0-695425/. Apologies to the OP for moving *his* posts and related replies, unfortunately it was easier managable this way.

Gins 12-26-2008 01:25 PM

This is an interesting question.

I am going to install Mandriva 2009.

I have a DVD of Mandriva 2009.

I am going to install it on another computer which has the latest Ubuntu. [ Not on this computer]

The default operating system is Ubuntu.

1. I have installed even old 'open SuSE 10.3' and it works fine.

2. I have installed Windows 2008 server on a primary partition and it works fine.

3. I have installed Windows Vista on a primary partition and it works fine.


So Ubuntu, Windows 2008 server and Windows Vista is on 3 separate primary partitions and open SuSE 10.3 is on a logical partiton.

GRUB works fine to recognize all the operating systems.However, it is bit tardy. First comes Ubuntu's GRUB, Afterwards I get the 'open SuSEs' GRUB.


I want to install Mandriva on a logical partition which is 'sdb5'

Where shall I place Mandriva's bootloader?

How shall I install Mandriva's bootloader?

I want Mandriva to be on the system as the fourth operating system.



........................................................
sdb1 for Windows 2008 server {Primary partition}
sdb2 for Windows Vista {Primary partition}
sdb3 for Ubuntu {Primary partition}
sdb5 --- Empty partiton for Linux installations {Logical
sdb6 --- Empty partiton for Linux installations {Logical
sdb7 --- Small partion (8.0GB) {Linux swap
sdb8 for open SuSE 10,3 {Logical
.........................................................
As a matter of fact I wanted to install open SuSE 10.3 on 'sdb5'. I couldn't dictate terms and it forced me to install on 'sdb8'. I don't know why. It may be I don't have sufficient knowledge of those tricky matters.

yancek 12-26-2008 06:04 PM

If you have an entry similar to the one in post #10 above, that is why it goes from the Ubuntu Grub to the Opensuse Grub

This line: configfile /boot/grub/menu.lst, point it to the menu.lst of Opensuse from Ubuntu. To change that you need your entry to point to the kernel in Opensuse. Look at the entries in post #9 with the kernel and initrd options. Find those in your Opensuse 10.3 menu.lst file and copy them to your Ubuntu menu.lst. Or you could post your Opensuse 10.3 menu.lst with the Ubuntu menu.lst (just the parts referring to 10.3) and someone can give you the correct entries.

You can install Mandriva bootloader (Grub) to the sdb5 if that's where you install it. Then you can put the entry from the Mandriva menu.lst file in the Ubuntu menu.lst file. You can also install Grub from Mandriva to the mbr and hope that it detects all other systems?

Gins 12-27-2008 10:13 AM

Thanks yancek for excellent comments.

I installed Mandriva 2009.
I didn't put the bootloader of Mandria 2009 on MBR. I put it on the root folder of Mandriva.
However, I can't put it to the 'menu.lst' file of Ubuntu. So Mandriva is not working or rather it does not appear as it is not on the 'menu.lst' file.

I don't know the stanzas for Mandriva.

I tried in vain the with the following stanzas.
.................................................................................
title Mandriva 2009


root (hd1,4)

configfile /boot/grub/menu.lst


.................................................................................

I successfully installed it on 'sdb5' partition.

I have 'open SuSE' on 'sdb8' partition. It works as it is on the 'menu.lst' file.

Code:


..................................................................................
sdb1 for Windows 2008 server {Primary partition}
sdb2 for Windows Vista {Primary partition}
sdb3 for Ubuntu {Primary partition}
sdb5  for Mandriva 2009 {Logical
sdb6 --- Empty partiton for Linux installations {Logical
sdb7 --- Small partion (8.0GB) {Linux swap
sdb8 for open SuSE 10,3 {Logical
.......................................................................................


The following is the output of the fdisk file.

Code:

root@ni-desktop:/home/ni# fdisk -l



Disk /dev/sda: 250.0 GB, 250059350016 bytes

255 heads, 63 sectors/track, 30401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x24312430



  Device Boot      Start        End      Blocks  Id  System

/dev/sda1              2      26912  216162607+  5  Extended

/dev/sda2  *      26913      30402    28025856    7  HPFS/NTFS

/dev/sda5              2        8955    71922973+  83  Linux

/dev/sda6            8956      18034    72927036  83  Linux

/dev/sda7          18035      26912    71312503+  83  Linux



Disk /dev/sdb: 500.1 GB, 500107862016 bytes

255 heads, 63 sectors/track, 60801 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0xdd98dd98



  Device Boot      Start        End      Blocks  Id  System

/dev/sdb1  *          1      13057  104880321    7  HPFS/NTFS

/dev/sdb2          13058      22724    77650177+  7  HPFS/NTFS

/dev/sdb3          22725      31836    73192140  83  Linux

/dev/sdb4          31837      59748  224203140    5  Extended

/dev/sdb5          40791      49744    71922973+  83  Linux

/dev/sdb6          49745      58698    71922973+  83  Linux

/dev/sdb7          58699      59748    8434093+  82  Linux swap / Solaris

/dev/sdb8          31837      40790    71922942  83  Linux



Partition table entries are not in disk order

root@ni-desktop:/home/ni#


The following is the Ubuntu's menu.ist file.
Code:

root@ni-desktop:/boot/grub# cat menu.lst

# menu.lst - See: grub(8), info grub, update-grub(8)

#            grub-install(8), grub-floppy(8),

#            grub-md5-crypt, /usr/share/doc/grub

#            and /usr/share/doc/grub-doc/.



## default num

# Set the default entry to the entry number NUM. Numbering starts from 0, and

# the entry number 0 is the default if the command is not used.

#

# You can specify 'saved' instead of a number. In this case, the default entry

# is the entry saved with the command 'savedefault'.

# WARNING: If you are using dmraid do not use 'savedefault' or your

# array will desync and will not let you boot your system.

default                0



## timeout sec

# Set a timeout, in SEC seconds, before automatically booting the default entry

# (normally the first entry defined).

timeout                30



## hiddenmenu

# Hides the menu by default (press ESC to see the menu)

#hiddenmenu



# Pretty colours

#color cyan/blue white/blue



## password ['--md5'] passwd

# If used in the first section of a menu file, disable all interactive editing

# control (menu entry editor and command-line)  and entries protected by the

# command 'lock'

# e.g. password topsecret

#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

# password topsecret



#

# examples

#

# title                Windows 95/98/NT/2000

# root                (hd0,0)

# makeactive

# chainloader        +1

#

# title                Linux

# root                (hd0,1)

# kernel        /vmlinuz root=/dev/hda2 ro

#



#

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST



### BEGIN AUTOMAGIC KERNELS LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified

## by the debian update-grub script except for the default options below



## DO NOT UNCOMMENT THEM, Just edit them to your needs



## ## Start Default Options ##

## default kernel options

## default kernel options for automagic boot options

## If you want special options for specific kernels use kopt_x_y_z

## where x.y.z is kernel version. Minor versions can be omitted.

## e.g. kopt=root=/dev/hda1 ro

##      kopt_2_6_8=root=/dev/hdc1 ro

##      kopt_2_6_8_2_686=root=/dev/hdc2 ro

# kopt=root=UUID=c5fb4ab5-6767-44e8-b89a-6383b86e2bad ro



## Setup crashdump menu entries

## e.g. crashdump=1

# crashdump=0



## default grub root device

## e.g. groot=(hd0,0)

# groot=(hd1,2)



## should update-grub create alternative automagic boot options

## e.g. alternative=true

##      alternative=false

# alternative=true



## should update-grub lock alternative automagic boot options

## e.g. lockalternative=true

##      lockalternative=false

# lockalternative=false



## additional options to use with the default boot option, but not with the

## alternatives

## e.g. defoptions=vga=791 resume=/dev/hda5

# defoptions=quiet splash



## should update-grub lock old automagic boot options

## e.g. lockold=false

##      lockold=true

# lockold=false



## Xen hypervisor options to use with the default Xen boot option

# xenhopt=



## Xen Linux kernel options to use with the default Xen boot option

# xenkopt=console=tty0



## altoption boot targets option

## multiple altoptions lines are allowed

## e.g. altoptions=(extra menu suffix) extra boot options

##      altoptions=(recovery) single

# altoptions=(recovery mode) single



## controls how many kernels should be put into the menu.lst

## only counts the first occurence of a kernel, not the

## alternative kernel options

## e.g. howmany=all

##      howmany=7

# howmany=all



## should update-grub create memtest86 boot option

## e.g. memtest86=true

##      memtest86=false

# memtest86=true



## should update-grub adjust the value of the default booted system

## can be true or false

# updatedefaultentry=false



## should update-grub add savedefault to the default options

## can be true or false

# savedefault=false



## ## End Default Options ##



title                Ubuntu 8.04, kernel 2.6.24-16-generic

root                (hd1,2)

kernel                /boot/vmlinuz-2.6.24-16-generic root=UUID=c5fb4ab5-6767-44e8-b89a-6383b86e2bad ro quiet splash

initrd                /boot/initrd.img-2.6.24-16-generic

quiet



title                Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)

root                (hd1,2)

kernel                /boot/vmlinuz-2.6.24-16-generic root=UUID=c5fb4ab5-6767-44e8-b89a-6383b86e2bad ro single

initrd                /boot/initrd.img-2.6.24-16-generic



title                Ubuntu 8.04, memtest86+

root                (hd1,2)

kernel                /boot/memtest86+.bin

quiet






title Mandriva 2009


root (hd1,4)                     

configfile /boot/grub/menu.lst







### END DEBIAN AUTOMAGIC KERNELS LIST



# This is a divider, added to separate the menu items below from the Debian

# ones.

title                Other operating systems:

root





# This entry automatically added by the Debian installer for a non-linux OS

# on /dev/sda2

title                Windows 2008 Server

root                (hd0,1)

savedefault

makeactive

chainloader        +1





title          Windows Vista/Longhorn (loader)

root            (hd0,2)

savedefault

makeactive

chainloader    +1




root@n-desktop:/boot/grub#

The bottom line is the stanzas for attaching Mandriva 2009 which resides on 'sdb5' partition to Ubuntu's meun.lst file.
I appreciate your help again.

yancek 12-27-2008 10:15 PM

title Mandriva 2009
root (hd1,4)
configfile /boot/grub/menu.lst

With Mandriva on sdb5, the above entry is correct and should work. Possible problems, need a space after root - before (hd1,4) and looks like there is. Same after configfile and before /boot..., looks right.

When you boot into Ubuntu and mount Mandriva, go into the /boot/grub/menu.lst file to verify that you have entries for Mandriva and the kernel and initrd entries in menu.lst are showing files that are actually in the /boot directory, i.e. the vmlinuz and initrd files.

The only other thing might be that you should put the entry for Mandriva in your Ubuntu menu.lst below the DEBIAN Magic Kernels line in menu.lst. Seems I read that somewhere but I don't use Ubuntu. I do have version 7.04 of Ubuntu installed and all the other OS's on my machine have entries below that line.

Quote:

However, I can't put it to the 'menu.lst' file of Ubuntu. So Mandriva is not working or rather it does not appear as it is not on the 'menu.lst' file.
I'm not sure what you mean by the above?

Quote:

I have 'open SuSE' on 'sdb8' partition. It works as it is on the 'menu.lst' file.
Don't understand the above quote. The menu.lst you posted for Ubuntu in your last post does not show an entry for Opensuse?? Are you booting from the Ubuntu or Opensuse Grub??


Quote:

The bottom line is the stanzas for attaching Mandriva 2009 which resides on 'sdb5' partition to Ubuntu's meun.lst file.
Am also confused by the above quote as the last line in your posted menu.lst is you vista entry??

Gins 12-28-2008 12:57 PM

Thanks yancek for taking time to reply me.
First I went to work this morning. Afterwards I went to the gym for training and came home about 10 minutes ago. So I was away whole day.


Code:

However, I can't put it to the 'menu.lst' file of Ubuntu. So Mandriva is not working or rather it does not appear as it is not on the 'menu.lst' file.
The above means the problem with Ubuntu's menu.lst file.
If I know the exact stanzas, I can edit the file and Mandriva will definitely work.
-------------------------------------------------------

Code:

I have 'open SuSE' on 'sdb8' partition. It works as it is on the 'menu.lst' file.
The above means my 'open SuSE 10.3 works fine. It is on the 'sdb8' partition. I could go to the Internet too using 'open SuSE 10.3'.


The following is the menu.lst file from Open SuSE 10.3
Code:


SuseLinux103:/boot/boot/grub # cat menu.lst
# Modified by YaST2. Last modification on Sun Dec 21 17:14:18 CET 2008
default 0
timeout 30
gfxmenu (hd1,7)/boot/message

###Don't change this comment - YaST2 identifier: Original name:  Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)###
title Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)
    root (hd1,2)
    configfile /boot/grub/menu.lst
    configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=0x317 resume=/dev/sdb7 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-bigsmp

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
    rootnoverify (hd1,7)
    chainloader (hd0,1)+1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
    rootnoverify (hd1,7)
    chainloader (hd1,0)+1

###Don't change this comment - YaST2 identifier: Original name: windows 3###
title windows 3
    rootnoverify (hd1,7)
    chainloader (hd1,1)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    rootnoverify (hd1,7)
    chainloader (fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.5-31-bigsmp
SuseLinux103:/boot/boot/grub #



When the computer starts, I get the 'open SuSE 10.3' menu.

The default operating system on 'open SuSE 10.3' menu is Ubuntu.

Afterwards it jumps to Ubuntu menu.

The default operating system on Ubuntu menu is also Ubuntu.

If I don't do anything when the computer starts, I get the Ubuntu to the screen.

You have written how to solve the problem of two menus. It is unnecessary to get both menus.

I will try to fix it later. If I ran into problems, I would beg your help on this too.

I am not an expert in these matters though I have been working with Linux for about 10 years.

I may have made an error in the process of installing 'open SuSE 10.3'.

As I wrote this error causes to get the 'open SuSE 10.3's menu first and the Ubuntu's menu second.
[ We can solve this problem later on.]

For the moment, the most important thing is to get Mandriva 2009 working.

I can get Ubuntu, 'open SuSE 10.3', Windows 2008 Server and Windows Vista on to the screen. I can go to the Internet with any one of the above.

Mandriva is hidden

First I must get Mandriva working.

Your thoughts are very welcome.

Gins 12-28-2008 03:09 PM

Here is the latest 'menu.ist' file from Ubuntu.

I am posting only the important lines.

I got the following error message.

root(hd1,4)
Filesystem type is ext2fs, partiton type 0x83
configfile /boot/grub/menu.lst
Error 2: Bad file or directory type
press any key to continue


Code:

## ## End Default Options ##



title          Ubuntu 8.04, kernel 2.6.24-16-generic

root            (hd1,2)

kernel          /boot/vmlinuz-2.6.24-16-generic root=UUID=c5fb4ab5-6767-44e8-b89a-6383b86e2bad ro quiet splash

initrd          /boot/initrd.img-2.6.24-16-generic

quiet



title          Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)

root            (hd1,2)

kernel          /boot/vmlinuz-2.6.24-16-generic root=UUID=c5fb4ab5-6767-44e8-b89a-6383b86e2bad ro single

initrd          /boot/initrd.img-2.6.24-16-generic



title          Ubuntu 8.04, memtest86+

root            (hd1,2)

kernel          /boot/memtest86+.bin

quiet



title Mandriva 2009

root (hd1,4)

configfile /boot/grub/menu.lst





### END DEBIAN AUTOMAGIC KERNELS LIST



# This is a divider, added to separate the menu items below from the Debian


# This is a divider, added to separate the menu items below from the Debian

# ones.

title          Other operating systems:

root





# This entry automatically added by the Debian installer for a non-linux OS

# on /dev/sda2

title          Windows 2008 Server

root            (hd0,1)

savedefault

makeactive

chainloader    +1





title          Windows Vista/Longhorn (loader)

root            (hd0,2)

savedefault

makeactive

chainloader    +1


yancek 12-28-2008 04:59 PM

Quote:

Grub Error 2 : Bad file or directory type
This error is returned if a file requested is not a regular file, but something like a symbolic link, directory, or FIFO.
Quote:

When the computer starts, I get the 'open SuSE 10.3' menu.
Ok, I misunderstood, I thought your Ubuntu menu.lst was first. So, if I understand correctly, you just want to boot these systems and don't necessarily want to have this entry (configfile /boot/grub/menu.lst) to experiment with??

Actually, using the configfile entry is useful if you are constantly changing operating systems on a specific partition for development or experimentation. You can leave that entry and install any OS without changing the entry as long as the OS is using Grub.

If you initially get the Opensuse menu.lst, then it would make sense to put the entry for Mandriva in the Opensuse menu.lst
Check the /boot/grub directory on Mandriva by mounting in Opensuse. First create the directory for Mandriva: mkdir /mnt/mandriva, then mount it: mount /dev/sdb5 /mnt/mandriva, then change to the directory and see if you actually have the menu.lst file there and it has entries pointing to the kernel and initrd files. Copy the entry in the Mandriva menu.lst file (for Mandriva) into the /boot/grub/menu.lst of Opensuse. Don't use the configfile, use the separate kernel and initrd lines.

I'm sure you can see by looking at your Opensuse menu.lst file below why your machine boots the way it does. The Ubuntu stanza is the only one with the 'configfile' entry! You could change that so it didn't display the menu.lst from Ubuntu by simply placing the kernel and initrd lines in that stanza. Replace this entry in the OPENSUSE menu.lst:

title Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)
root (hd1,2)
configfile /boot/grub/menu.lst
configfile /boot/grub/menu.lst

with the following entry in OPENSUSE menu.lst:

title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd1,2)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=c5fb4ab5-6767-44e8-b89a-6383b86e2bad ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic
quiet

Quote:

I may have made an error in the process of installing 'open SuSE 10.3'
Not really, I installed Opensuse 10.3 a year ago and it put similar "configfile" entries for the other OS's on the system during the install.

Further questions or problems, just post.

Gins 12-29-2008 04:49 PM

yancek

I work whole day. Afterwards I went to the gym for circuit training.
I just came home. I will eat something and sleep. It is too late here; almost midnight here.

I will attend this tomorrow evening.
I profoundly appreciate your help.
Please keep a good watch on the thread.

yancek 12-29-2008 07:08 PM

I'll keep watching. I'm curious about the bad file or directory error you get from Grub. Mount that partition and see what is actually there.

Gins 12-30-2008 12:43 PM

yancek

I logged on as a superuser in open SuSE 10.3.

I created a directory mandriva as you suggested.

I tried in different ways.

It seems there is no entry about 'sdb5' in the 'fstab file.




Code:

ni@SuseLinux103:~> su root
Password:
SuseLinux103:/home/ni #
SuseLinux103:/home/ni # cd /mnt
SuseLinux103:/mnt # mkdir mandriva
SuseLinux103:/mnt # mount /dev/sdb5
mount: can't find /dev/sdb5 in /etc/fstab or /etc/mtab
SuseLinux103:/mnt # ls
mandriva
SuseLinux103:/mnt #




SuseLinux103:/mnt # cd mandriva
SuseLinux103:/mnt/mandriva # mount /dev/sdb5/
mount: can't find /dev/sdb5/ in /etc/fstab or /etc/mtab
SuseLinux103:/mnt/mandriva #

..................................................................


The following is the 'fstab' file in open SuSE 10.3

Code:

SuseLinux103:/etc # cat fstab
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 /                    ext3      acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1UP109613-part2 /windows/C          ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part1 /windows/D          ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part2 /windows/E          ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part7 swap                swap      defaults              0 0
proc                /proc                proc      defaults              0 0
sysfs                /sys                sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts              /dev/pts            devpts    mode=0620,gid=5      0 0
/dev/fd0            /media/floppy        auto      noauto,user,sync      0 0
SuseLinux103:/etc #


----------------------------------------------------------------
The following is the 'mtab' file in open SuSE 10.3

Code:

SuseLinux103:/etc # cat mtab
/dev/sdb8 / ext3 rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/sda2 /windows/C fuseblk rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096 0 0
/dev/sdb1 /windows/D fuseblk rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096 0 0
/dev/sdb2 /windows/E fuseblk rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096 0 0
securityfs /sys/kernel/security securityfs rw 0 0
SuseLinux103:/etc #

---------------------------------------------------------------------

The following is the 'fdisk -l' output from open SuSE 10.3.

Code:

SuseLinux103:/ # fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x24312430

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1              2      26912  216162607+  5  Extended
/dev/sda2  *      26913      30402    28025856    7  HPFS/NTFS
/dev/sda5              2        8955    71922973+  83  Linux
/dev/sda6            8956      18034    72927036  83  Linux
/dev/sda7          18035      26912    71312503+  83  Linux

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xdd98dd98

  Device Boot      Start        End      Blocks  Id  System
/dev/sdb1  *          1      13057  104880321    7  HPFS/NTFS
/dev/sdb2          13058      22724    77650177+  7  HPFS/NTFS
/dev/sdb3          22725      31836    73192140  83  Linux
/dev/sdb4          31837      59748  224203140    5  Extended
/dev/sdb5          40791      49744    71922973+  83  Linux
/dev/sdb6          49745      58698    71922973+  83  Linux
/dev/sdb7          58699      59748    8434093+  82  Linux swap / Solaris
/dev/sdb8          31837      40790    71922942  83  Linux

Partition table entries are not in disk order
SuseLinux103:/ #

---------------------------------------------------------------------

The following is the 'open SuSE 10.3s menu.lst file.

Code:

SuseLinux103:/boot/grub # cat menu.lst
# Modified by YaST2. Last modification on Sun Dec 21 17:14:18 CET 2008
default 0
timeout 30
gfxmenu (hd1,7)/boot/message

###Don't change this comment - YaST2 identifier: Original name:  Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)###
title Ubuntu 8.04, kernel 2.6.24-16-generic (/dev/sdb3)
    root (hd1,2)
    configfile /boot/grub/menu.lst
    configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=0x317 resume=/dev/sdb7 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-bigsmp

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
    rootnoverify (hd1,7)
    chainloader (hd0,1)+1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
    rootnoverify (hd1,7)
    chainloader (hd1,0)+1

###Don't change this comment - YaST2 identifier: Original name: windows 3###
title windows 3
    rootnoverify (hd1,7)
    chainloader (hd1,1)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    rootnoverify (hd1,7)
    chainloader (fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3
    root (hd1,7)
    kernel /boot/vmlinuz-2.6.22.5-31-bigsmp root=/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.5-31-bigsmp
SuseLinux103:/boot/grub #

I have two hard disks on this computer. The Samsung disk has 500GB capacity. The system recognizes it as 'sdb'.

As I mentioned before, sdb1 and sdb2 are for Windows 2008 server and Windows Vista. Both of them are primary partitions.

I have Ubuntu on sdb3 and it is also a primary partition.

The above 3 operating systems are working fine. I have no complains about them.

I installed 'open SuSE 10.3' on sdb8. It is a logical partition.
My open SuSE 10.3 works fine.

I installed 'Mandriva 2009' on sdb5 and it is a liability.
The partition sdb5 is a logical partition.
Your thoughts are welcome.

PS
I hope to install some other Linux distros on Maxtor hard disk later on.
The system recognizes it as sda. I think Samsung and Maxtor belongs to one company. Maxtor has 250GB.

yancek 12-30-2008 01:19 PM

You have the mandriva directory under /mnt as seen below.

Quote:

SuseLinux103:/mnt # ls
mandriva
You did the mount command incorrectly, do this:

mount /dev/sdb5 /mnt/mandriva

Should work, if it doesn't you may need filesystem type and I think it is ext3 so do:

mount -t ext3 /dev/sdb5 /mnt/mandriva

Then change directory:

cd /mnt/mandriva

Then do ls -l, you should see the mandriva files. If you see the mandriva files, go to /boot/grub and find the menu.lst file. Copy the entry for mandriva to the bottom of the Opensuse menu.lst file


If you see the mandrivaa files, put this entry in /etc/fstab of Opensuse:


/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part5 / ext3 acl,user_xattr 0 0

This is for the second drive on which you have Opensuse and Mandriva. The only changes you should need from Opensuse are from "part8" to "part5", and changing the "1 1" at the end of Opensuse to "0 0" for mandriva. The above entry includes those changes.

You don't have an fstab entry for mandriva in Opensuse because you installed mandriva after Opensuse.

I'm not sure if this will solve the "bad file or directory" error? Maybe the files arent there? Is sdb set to boot first?

If you get errors or have problems, post again.

Gins 12-30-2008 01:52 PM

Yes, it worked.

I will attend the rest gradually.



Code:

SuseLinux103:/mnt # ls
mandriva
SuseLinux103:/mnt # cd mandriva
SuseLinux103:/mnt/mandriva # ls
bin  dev  home    lib        media  ooobuildtime.log  proc                root  sys  usr
boot  etc  initrd  lost+found  mnt    opt              .readahead_collect  sbin  tmp  var
SuseLinux103:/mnt/mandriva #


Gins 12-30-2008 02:57 PM

I changed the 'fstab' file in open SuSE 10.3.

I will reboot and see whether I am in business now.

The following is the new file.


Code:

SuseLinux103:/etc # cat fstab



/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part8 /                    ext3      acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part5 /                    ext3      acl,user_xattr 0

/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1UP109613-part2 /windows/C          ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part1 /windows/D          ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part2 /windows/E          ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_MAXTOR_STM35003_9QM357QE-part7 swap                swap      defaults              0 0
proc                /proc                proc      defaults              0 0
sysfs                /sys                sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts              /dev/pts            devpts    mode=0620,gid=5      0 0
/dev/fd0            /media/floppy        auto      noauto,user,sync      0 0
SuseLinux103:/etc #


Gins 12-30-2008 03:11 PM

yancek

I got the same old error message.
I rebooted twice.
Ubuntu and open SuSE 10.3 comes to the screen.

What would be the next step?


-----------------------------------------
I installed all the programs on the sdb drive.
So bootloader and mbr are on the sdb.


All times are GMT -5. The time now is 02:04 PM.