-   Mandriva (
-   -   how to reload sbp2 module /Flush terminal command cache (

Lakota 12-06-2004 02:21 AM

how to reload sbp2 module /Flush terminal command cache
after initiating the following command
su -c "/sbin/rmmod sbp2"
my iPod tells me it is now ok to disconnect. Problem being, I need to reboot before I can get linux to acknowledge the iPod is reconnected. I found a script which claims to rectify this problem called Upon reconnecting iPod it automatically goes to the Ok to disconnect screen, I run as root and it acknowledges my Epson printer, but finds no new devices (wishfully my firewire iPod). Next I thought maybe try loading sbp2 by hand. Must be doing it wrong because terminal window barks back
[root@]# modprob sbp2
bash: modprob: command not found
[root@]# insmod sbp2
insmod: can't read 'sbp2': No such file or directory


Figured it out, as you see I had no idea how to load a module by hand, just thought to see how Mandrake does it, and looked at my etc/modprobe.devfs file and voila not only did I get a spelling lesson (modprobe not modprob) I learned proper command:
# /sbin/modprobe sbp2
or better yet, as regular user:
su -c "/sbin/modprobe sbp2"
Anyway, tried it out and iPod found after loading module, without rebooting. I'm happy.

This does lead me to another problem though. As you can see I type all kinds of foolish crap into the terminal trying to figure out what works. I quite like using page up to find commands rather than remember them. Is there a way to clear the cache of commands, so I can flush out a huge number of bad commands and have it start fresh?

Lakota 12-07-2004 02:08 PM

Ok, found that on my own now to. Any other newbies trying to flush cache, open .bash_history and delete the crap out using Kate or whatever.

All times are GMT -5. The time now is 11:56 PM.