LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   how to boot into graphical mode (https://www.linuxquestions.org/questions/mandriva-30/how-to-boot-into-graphical-mode-270191/)

furtivefelon 12-25-2004 10:15 AM

how to boot into graphical mode
 
hi, somehow the mandrake just boots into the command line mode everytime i start computer, how do i get it to go into graphical mode?? thanks alot!

otish1000c 12-25-2004 10:39 AM

go to Mandrake Control Center->boot->autologin. check the box that says "launch graphical blah, blah when system starts". choose auto login or not, which ever you like, reboot.

otis

furtivefelon 12-25-2004 10:39 AM

here is the error i get after i typed "startx".. the video configueration is really confusing..

execue failed for /etc/x11/x (errno 2)
giving up.
xinit: No such file or directory (errno 2): unable to connect to x server
xinit: No such process (errno 3): server error

anyone know what's wrong??

chumisekar 12-25-2004 10:39 PM

The mandrake has not recognised the VGA card of ur system and the card has not been configured

regards
Sumithra

furtivefelon 12-25-2004 11:28 PM

do u know how to configure the graphics card?? and by the way, if i can graphically install the software, why don't they just make it easier and use that as the booting for the os?!

chumisekar 12-25-2004 11:35 PM

What is the VGA card you are using

sumithra

otish1000c 12-26-2004 06:50 AM

sorry, i didn't understand your first post correctly. i assumed you had GUI working & just wanted to know how to set it up to auto login to graphical mode.

as was mentioned, the type of vid card you have would be helpful. but, in lieu of that, if you still don't have it worked out yet, when you get dumped at the prompt login as root & run drakx to configure & test the video card. to do so.........

at the login prompt, login as normal user, then type......

Code:

su
hit enter, then type in the root password, hit enter again. that will get you to root mode. then type........

Code:

DrakX
hit enter. that will bring up the Mandrake video card config screen. make sure you choose the correct or most compatable driver for your video card, set the resolution, refresh rate, & screen size, then most importantly, use the "test" button to make sure the settings work. if the test screen looks good, accept the config & you should be able to boot into GUI mode.

if that doesn't work for some reason, then please post back with your vid card info & any other steps you have taken & error messages.

otis

furtivefelon 12-26-2004 07:48 AM

i haven't try the stuff u told me yet, but i just want to update on my system specs :D

processor: Anthlon XP 2600, 2000mhz
ram: 512
Video card: Radeon 9000 pro 128mb of ram (frankly, they don't have specific driver for this, they have something along the lines of radeon driver.. forgot the specific name :|)
sound: on board


mmm.. i'll try ur suggestion after seeing if it supports my config, because i didn't see a specific driver for my vid card.. thanks alot!

furtivefelon 12-26-2004 08:54 AM

alright, i just tried ur suggestion.. when i type in DrakX, it says the command is not recognized :|.. do you know what's going on? thanks alot!

otish1000c 12-26-2004 09:07 AM

yes, i know what's going on.......... i had a brain fart.

the command i gave you was wrong. the proper command is XFdrake. in terminal as root type........

Code:

XFdrake
CaPs sensitive. then proceed witht eh vid card config.

sorry,

otis

furtivefelon 12-26-2004 09:24 AM

ahh.. it went into the window, but i tried changing alot of the parameters, they all doesn't work..

here is what i see:

Graphics card: last choice: ATI Radeon (fglrx)
all revelevent choices: Radeon, Radeon (fbdev), Radeon (fglrx), Radeon 8500
Monitor: 1280*1024 @ 60Hz
Res: Frame-buffer

when i click on test, it displayed this always:

An error occurred
(EE) Problem parsing the config file
(EE) Error parsing the config file

Try change some parameters

anyone have an idea of what i'm doing wrong?

Thanks alot!

otish1000c 12-26-2004 02:21 PM

sorry, but i'm not good with ATI cards. Nvidia man, here.

the only thing i can suggest, if you haven't already, is try various ATI/Radeon drivers, or maybe a generic one. hopefully somebody using ATI will see this thread & be able to offer more help.

it might also be helpful if you could somehow post the contents of your /etc/X11/xorg.conf file. that contains all the configs pertaining to your vid card, monitor, & other assorted input devices. maybe something in that needs to be edited/added/commented out.

otis

sharkee 12-26-2004 09:14 PM

Ok ,
Lets try to get you a graphical mode. do the Xfdrake as advised above and scroll to Xorg drivers and select Vesa . I think you may have to set the res to 16 instead of 24 bit. If successfull google for drivers for your card.
Regards
Sharkee

furtivefelon 12-27-2004 09:40 AM

i went on ATI's website.. they have drivers for linux.. however, i have one question.. it gave me several "XFree86" versions, wonder which version i should download for the offical release of Mandrake 10.1? versions availiable for XFree86 is: 4.1.0, 4.2.0, 4.3.0.. thanks alot! :D

sharkee 12-27-2004 07:11 PM

take a look here http://www.linuxforums.org/forum/viewtopic.php?t=21368

Regards
Sharke


All times are GMT -5. The time now is 09:11 PM.